Jump to content

Force default audio track not honored?


landgazr
 Share

Recommended Posts

landgazr
Hi everybody!
 
I've been messing around with codec intros lately and there is some weird behavior I came across. The intros themselves work great, but I was finding that my AC3 movies kept showing the AAC intro. I tried using mkvtoolnix to change the default audio track with the same result.
 
After more tinkering, I found that I had to change the actual track order in the MKV in order for my AC3 intro to actually show. It is like Emby uses the first audio track it finds and uses it, even if the AC3 (or DTS or whatever) track is set as default and the playback option to play the default track, regardless of language, is set.
 
It follows then that Emby seemingly cannot play any other audio track itself without manual intervention in the play UI.
 
For people who are having the same issue, here are the sequence of mkvtoolnix commands that worked for me:
 
mkvmerge --track-order 0:0,0:2,0:1,0:3 in.mkv -o out.mkv


mkvpropedit -v out.mkv -v --edit track:2 --set track-uid=2 --edit track:3 --set track-uid=3


mkvpropedit out.mkv --edit track:a1 --set flag-default=1 --edit track:a2 --set flag-default=0

This assumes the following initial track ID order:

 
0 - video
1 - aac
2 - ac3/eac3
3 - sub
 
(If I didn't set the UIDs, the audio would work but the wrong codec would be displayed under the plot summary.)
 
Has anyone else seen this?
 
 
 
 
  • Like 1
Link to comment
Share on other sites

mastrmind11

 

Hi everybody!
 
I've been messing around with codec intros lately and there is some weird behavior I came across. The intros themselves work great, but I was finding that my AC3 movies kept showing the AAC intro. I tried using mkvtoolnix to change the default audio track with the same result.
 
After more tinkering, I found that I had to change the actual track order in the MKV in order for my AC3 intro to actually show. It is like Emby uses the first audio track it finds and uses it, even if the AC3 (or DTS or whatever) track is set as default and the playback option to play the default track, regardless of language, is set.
 
It follows then that Emby seemingly cannot play any other audio track itself without manual intervention in the play UI.
 
For people who are having the same issue, here are the sequence of mkvtoolnix commands that worked for me:
 
mkvmerge --track-order 0:0,0:2,0:1,0:3 in.mkv -o out.mkv


mkvpropedit -v out.mkv -v --edit track:2 --set track-uid=2 --edit track:3 --set track-uid=3


mkvpropedit out.mkv --edit track:a1 --set flag-default=1 --edit track:a2 --set flag-default=0

This assumes the following initial track ID order:

 
0 - video
1 - aac
2 - ac3/eac3
3 - sub
 
(If I didn't set the UIDs, the audio would work but the wrong codec would be displayed under the plot summary.)
 
Has anyone else seen this?

 

https://emby.media/community/index.php?/topic/46593-cinema-mode-codecs-how-to-distinguish/

Link to comment
Share on other sites

landgazr

Thanks mastrmind11!

 

I read through the thread, and it seems that you might be saying that Emby matches both codecs so it is picking one at random? That is possible, although highly coincidental that, 100% of the time I have tried this, the AAC intro always shows. So whatever is set as the default in the MKV doesn't seem to matter.

Link to comment
Share on other sites

mastrmind11

Thanks mastrmind11!

 

I read through the thread, and it seems that you might be saying that Emby matches both codecs so it is picking one at random? That is possible, although highly coincidental that, 100% of the time I have tried this, the AAC intro always shows. So whatever is set as the default in the MKV doesn't seem to matter.

yeah I agree with you.  I was just showing you that you're not alone.

Link to comment
Share on other sites

landgazr

Hey mastermind11-

 

Thank you, and I appreciate the perspective. Guess I should find the instructions on how to report this, or see if it has been reported already as a possible bug.

Link to comment
Share on other sites

mastrmind11

Hey mastermind11-

 

Thank you, and I appreciate the perspective. Guess I should find the instructions on how to report this, or see if it has been reported already as a possible bug.

Just post it in the feature request forum.

Link to comment
Share on other sites

zigzagtshirt

@@landgazr

 

My anecdotal experience has been that it selects the audio track listed first.  This seems to be true for selecting the intro, as well as selecting which audio track to transcode when transcoding is necessary.

 

Again, this is from anecdotal observation.  Feel free to say that I'm wrong.

Link to comment
Share on other sites

landgazr

@@zigzagtshirt

 

You very well could be correct because I didn't confirm whether, when playing the movie, the first listed track was used when transcoding was necessary. Either way, this doesn't seem like a trivial issue.

Link to comment
Share on other sites

We already honor them out of the box by default, however if you change the subtitle mode user setting then you'll see different behavior.

Link to comment
Share on other sites

landgazr

I'm a little confused then Luke. Why does the audio track selection have anything to do with subtitles? Or are you referring to language? What is the "different behavior" you are mentioning? I never changed the subtitle settings (so afaik I'm still witnessing "out-of-the-box" behavior) so then I should not be seeing what I am?

 

Sent from my SM-G920V using Tapatalk

Edited by landgazr
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...