Jump to content

Search the Community

Showing results for tags 'default audio'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • General
    • Announcements
    • Emby Premiere Purchase/Subscription Support
    • Feature Requests
    • Tutorials and Guides
  • Emby Server
    • General/Windows
    • Android Server
    • Asustor
    • FreeBSD
    • Linux
    • NetGear ReadyNAS
    • MacOS
    • QNAP
    • Synology
    • TerraMaster NAS
    • Thecus
    • Western Digital
    • DLNA
    • Live TV
  • Emby Apps
    • Amazon Alexa
    • Android Mobile
    • Android TV / Fire TV
    • Emby Theater
    • iOS
    • Apple TV
    • Kodi
    • Raspberry Pi
    • Roku
    • Samsung Smart TV
    • Sony PlayStation
    • LG Smart TV
    • Web App
    • Windows Media Center
    • Plugins
  • Language-specific support
    • Arabic
    • Dutch
    • French
    • German
    • Italian
    • Portuguese
    • Russian
    • Spanish
    • Swedish
  • Community Contributions
    • Ember for Emby
    • Fan Art & Videos
    • Tools and Utilities
    • Web App CSS
  • Other
    • General Discussion
    • Developer API
    • Hardware
    • Media Clubs
    • Legacy Support

Blogs

  • Emby Blog

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Found 2 results

  1. (I was counseled to post this as a feature request here, having previously posted this in the General/Windows forum) Hi everybody! I've been messing around with codec intros lately and there is some weird behavior I came across. The intros themselves work great, but I was finding that my AC3 movies kept showing the AAC intro. I tried using mkvtoolnix to change the default audio track with the same result. After more tinkering, I found that I had to change the actual track order in the MKV in order for my AC3 intro to actually show. It is like Emby uses the first audio track it finds and uses it, even if the AC3 (or DTS or whatever) track is set as default and the playback option to play the default track, regardless of language, is set. It follows then that Emby seemingly cannot play any other audio track itself without manual intervention in the play UI. In other words, I had to modify my MKV in order to make Emby do what the default audio playback setting should have already done. For people who are having the same issue, here are the sequence of mkvtoolnix commands that worked for me: mkvmerge --track-order 0:0,0:2,0:1,0:3 in.mkv -o out.mkv mkvpropedit -v out.mkv -v --edit track:2 --set track-uid=2 --edit track:3 --set track-uid=3 mkvpropedit out.mkv --edit track:a1 --set flag-default=1 --edit track:a2 --set flag-default=0 This assumes the following initial track ID order: 0 - video 1 - aac 2 - ac3/eac3 3 - sub (If I didn't set the UIDs, the audio would work but the wrong codec would be displayed under the plot summary.) I have seen the behavior both in Emby Theater (Xbox) and the regular browser-based UI. I am running Emby Server 3.2.12 on Fedora 21.
  2. Hi everybody! I've been messing around with codec intros lately and there is some weird behavior I came across. The intros themselves work great, but I was finding that my AC3 movies kept showing the AAC intro. I tried using mkvtoolnix to change the default audio track with the same result. After more tinkering, I found that I had to change the actual track order in the MKV in order for my AC3 intro to actually show. It is like Emby uses the first audio track it finds and uses it, even if the AC3 (or DTS or whatever) track is set as default and the playback option to play the default track, regardless of language, is set. It follows then that Emby seemingly cannot play any other audio track itself without manual intervention in the play UI. For people who are having the same issue, here are the sequence of mkvtoolnix commands that worked for me: mkvmerge --track-order 0:0,0:2,0:1,0:3 in.mkv -o out.mkv mkvpropedit -v out.mkv -v --edit track:2 --set track-uid=2 --edit track:3 --set track-uid=3 mkvpropedit out.mkv --edit track:a1 --set flag-default=1 --edit track:a2 --set flag-default=0 This assumes the following initial track ID order: 0 - video 1 - aac 2 - ac3/eac3 3 - sub (If I didn't set the UIDs, the audio would work but the wrong codec would be displayed under the plot summary.) Has anyone else seen this?
×
×
  • Create New...