Jump to content

Can get to server remotely but Emby Connect "unable to connect to selected server".


h82failsonline
 Share

Recommended Posts

h82failsonline

Sorry if this is a common thread, I tried to search and only came up with people unable to access anything remotely.

 

I have UPnP & NAT-PMP disabled on my router for security reasons.  I have forwarded 8096-8097 to different non standard ports in my router also for security reasons, thats just how I do most services and it works fine.  To be clear I did not change the default ports in emby, I'm using my router to put them on a different port over WAN.  I also have a dynamic dns assigned to my ip.

 

 Using myIP:mycustomport or myservername.asdf.com:mycustomport in a browser on a remote computer works perfectly.  I have also been able to setup emby for kodi remotely using one of the above.

 

 However I have been attempting to add some guest users so they are not messing up my library as far as what has been watched etc, and cannot edit the metadata.  I don't need emby connect to keep track of my ip since I have a dynamic dns as stated above.  However it seems like its going to make me create a Emby Connect account.  I made a Emby Connect account and it cant get to my server, I've tried the IP and the dns address (of course I put the custom port in).

 

Under Expert-Advanced in the server dashboard I see there are settings for both local and remote ports.  The only thing I can think of is that Emby Connect needs the same port its connecting on to be configured as the remote port.  Everything else is working fine with NAT translating the port as I said above however.  So I tired changing the Public http/https ports to what I am using.  Emby Connect still wont work.  (normal remote connections still work fine).  Then I also redid my port forward so its going strait though on those custom ports (same internal and external).  Still Emby Connect cant find my server..   AHHH!!  Is there some other ports I need to forward or something for Emby Connect?  Why is it the only thing that can't find my server.  After every change I retest connecting remotely in a browser and everything I do always works.  (Sorry for super long question, I'd rather give all the info at once)

Link to comment
Share on other sites

Hi, on the front page of the emby server dashboard it will show your remote access url. that is what emby connect will attempt to use when away from home. is that address correct?

Link to comment
Share on other sites

h82failsonline

Yes, and did some more testing

 

Very Odd thing: With default port set to local http/https and a custom port set to public http/https, & with only the custom ports used for public forwarded though the router I actually can't connect remotely with my phone browser (wifi d/c). :-/ ?? seems odd..

 

 If I set my router to route the same custom ports to the std ports I have set for local it connects fine. (public ports set in emby to something that can't get out).   So it seems like everything that I can get to work is actually using the local ports set in emby.  If I setup only the public ports to have outside access and attempt to connect using those ports nothing works at all.

 

I tried setting public and local ports back to default.  Then as a extra test I removed my custom ports and forwarded the default ports strait though my router, still no change.  Other stuff works fine, Emby Connect doesn't see it.  

 

Tried Emby Connect with the domain name http & https, with the ip, with http://ip , https://ip etc.

Link to comment
Share on other sites

h82failsonline

I can PM you info to try yourself if you'd like, I'm about to give up on Emby Connect and just make regular user accounts for my guests.

 

I didn't realize until I made some that if I "hide this user from login screens" to all of my users I would have a regular login screen with username/password fields.  Thats all I wanted is to not have a huge list of users advertising to all my friends who else has access.

Link to comment
Share on other sites

h82failsonline

Yep. This is windows 2012r2, "AppData\Roaming\Emby-Server\System\MediaBrowser.ServerApplication.exe" was added from the installer.  Also tried allowing the "Emby" Service and also allowing 8096 on tcp & udp.  Unless other ports are needed for emby connect, I give up. :(

Link to comment
Share on other sites

Make sure there are no rules in windows firewall that are blocking mediabrowser.serverapplication.exe.

Link to comment
Share on other sites

  • 4 weeks later...
neptunepic

Hi Luke, I'm having the same problem when trying to access my Emby server using public wifi (like at airports, coffe shops etc). I've tested and discovered that on my phone, if I disable wifi i can access the server using cellular data but wifi is a no-go.

 

I'm assuming this has something to do with the default ports being used by Emby server are blocked by most public wifi hotspots?

 

Have you any suggestions for this? If I can't watch stuff while I'm traveling it's kind of a waste for me. Are there different ports that won't be blocked by public wifi (assuming that's the problem)?

 

Thanks!

Link to comment
Share on other sites

mastrmind11

For obvious reasons, most public wifi hotspots have very strict firewall rules and generally only allow outbound port 80 and 443 so you can access the internet.  That being the case, you can set up an SSH tunnel directly to your server over 443 and the hotspot will think you're just browsing the internet.  Here is a basic primer.  https://www.verot.net/socks.htm

Link to comment
Share on other sites

neptunepic

Thanks but my server is windows 7, not Linux.

Is there a tutorial that could walk me through that process?

Link to comment
Share on other sites

Thanks but my server is windows 7, not Linux.

Is there a tutorial that could walk me through that process?

 

Just be aware, now that we're clear it's not an Emby problem, what he's saying above is a little on the advanced side. You might find it easier just to use your mobile connection.

Link to comment
Share on other sites

mastrmind11

Thanks but my server is windows 7, not Linux.

Is there a tutorial that could walk me through that process?

Another option, probably more user friendly, is to set up a VPN server on your Emby server.  That way you can just log into your VPN server using your device and point to localhost:8096 to get to Emby.  Here's a simple tutorial for setting up and connecting via PPTP: https://www.howtogeek.com/135996/how-to-create-a-vpn-server-on-your-windows-computer-without-installing-any-software/ and also http://pureinfotech.com/how-to-create-a-vpn-server-using-windows-7-built-in-tool/

Link to comment
Share on other sites

  • 8 months later...
septemberboy7

Hi, on the front page of the emby server dashboard it will show your remote access url. that is what emby connect will attempt to use when away from home. is that address correct?

I don't have a public ip address. I can't use that ip that's why I'm using emby connect.

Link to comment
Share on other sites

I don't have a public ip address. I can't use that ip that's why I'm using emby connect.

 

Hi.  Even with Connect, your system has to be accessible from the outside.  Nothing can get in if the door is locked (or there is no door) :).

Link to comment
Share on other sites

efigalaxie

You don’t have a public static IP address. You do have a dynamic IP address. There is a service that you can use to get around your issue. I am sorry, but you will need to google that. I can’t recall the name.

 

OpenDNS is the name.....

Edited by efigalaxie
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...