Jump to content

How to update to the Latest Version on an Asustor


geoff511

Recommended Posts

Hi,

Any of you that have read some of my posts (or maybe rants :D ) may have realized I'm not real happy with the Asustor updates coming from App. Central.

But thanks to a fellow Asustor user  lllrinzlerlll  , he has let me know a way to keep your Asustor version up-to-date and not have to put up with the atrocious versions we are subjected to.

Have heard that Admin Luke is trying to get Asustor to change the way they write the updates or maybe make them ourselves but til then this is the way a few of us are doing it.

 

We are copying the Mono Linux version over what is installed on the NAS.

 

-  just go to  - https://github.com/M...releases/latest ,  select Emby.Mono.zip release.

When you unzip the Mono version, you will notice in step 5/6 that it's the same files and structure as what you already have.

 

(Would strongly suggest you make a backup copy of this whole section from your NAS - FIRST - just in case it doesn't work or it goofs in some way. That way you can just copy it all back over the top of the original files/folders.

  Once you've done it once and worked, keep a copy of the last update, just in case the new one isn't liked, you can always just copy it back over the new files and keep using the previous version.)

 

If you haven't already enabled SSH, then open Services, goto Terminal and enable the SSH service. Usually uses port 22.

 

How to install -

 

1. On the NAS log into Emby and click shutdown, then in Asustor App Central disable Emby 

2. Download Emby.Mono.zip to a PC and unpack the zip file to a folder

3. Download and install WinSCP to a PC

4. In WinSCP create an FTP connection with your NAS, you will need to know the IP address, a user and password and have FTP or SFTP enabled in the NAS under settings, FTP is normally port 21 and SFTP is normally port 22 (you will see port number in WinSCP when creating a connection, sometimes its autofilled)

5. In the WinSCP remote window navigate to volume1/@.plugins/AppCentral/mediabrowser/bin (if you cant see @.plugins then you need to enable view hidden files in WinSCP)

6. In the WinSCP local window navigate to where you have the Emby Server unpacked

7. You can highlight all local files and drag them across to the remote path

8. Once complete (for me it took around 10 seconds), you can disconnect your WinSCP session

9. Go back to Asustor App Central and re-enable Emby

10. Give it a minute and then log into Emby, you should be running the latest Linux version you downloaded from the Emby site

 

The benefit of this is Asustor has no idea you have upgraded the system and thinks its running the latest version from the Asustor servers.

 

As long as you don't upgrade Emby from App Central and do it this way every time you will be fine.

 

You can update Emby whenever a new Linux version is available on the Emby site

 

Doing it this way only upgrades the Emby version and doesn't touch the rest of your files (where your metadata is etc). However make sure your not overriding any folders etc where your settings are saved.

 

-------------------------

If any of this is beyond your understanding or you are not comfortable with zip files, copying files via an FTP style program or getting your "hands dirty" in the files section of your NAS, then please don't do it, get someone who is comfortable doing it, and knows what they are doing.

------------------------

 

The instructions are a direct copy from an email lllrinzlerlll sent me and yes it does work, so thank you very much lllrinzlerlll for all your help.

Edited by geoff511
  • Like 1
Link to post
Share on other sites
  • 1 month later...

Hi geoff 511

Thanks a lot for your tutorial, i've updatetd my asustor 3 times like this now. But i can't find the manual/mono version now on the download section. can someone tell me where i can find the file?

Link to post
Share on other sites
Luke

Hi geoff 511

Thanks a lot for your tutorial, i've updatetd my asustor 3 times like this now. But i can't find the manual/mono version now on the download section. can someone tell me where i can find the file?

 

For now you can get it here:

 

https://github.com/MediaBrowser/Emby/releases/latest

 

We hope to soon have our own Asustor package developed by us and then this wont' be needed anymore.

  • Like 1
Link to post
Share on other sites
  • 1 month later...

Got a Weird behaviour since I've used this option to upgrade Emby: it doesn't create .NFO files anymore... it edits the ones that are there (change something and it's reflected in the existing NFO), but new shows doesn't get NFOs, or any media files created in their directories (Posters.jpg, thumbnails, etc...)

 

I see absolutely nothing for that in the logs either (debug activated) and NFO is activated in Library/Metadata/Metadata Savers... (didn't change the config for the upgrade)

 

Any Ideas?

 

EDIT:  I had just posted this, after 2h of searching, upgrading to the latest & greatest... when I happend on the Library folder config...   saving Metadata & Artwork to the Media Folder wasn't selected... must have somehow changed after an update.

Edited by TSandman
Link to post
Share on other sites

Thanks for the feedback. Several months ago those settings changed from global to per library and that's why you had to reconfigure them. Thanks.

Link to post
Share on other sites

I have emailed the Asustor rep who handles packaging Emby Server and have asked him to please update it to the latest version.

 

In the future we plan to take over this process ourselves and then new releases will always be immediately available. Thanks guys.

Link to post
Share on other sites

I have emailed the Asustor rep who handles packaging Emby Server and have asked him to please update it to the latest version.

 

In the future we plan to take over this process ourselves and then new releases will always be immediately available. Thanks guys.

Big thanks mate .-)

Link to post
Share on other sites
  • 3 weeks later...
  • 2 weeks later...
  • 4 weeks later...

hello,

 

how can you see hidden files?, i enable it with winscp but nothing change nas side.

 

Thanks

 

Hi, I'm not sure what you're referring to? How does this relate to Emby?

Link to post
Share on other sites
  • 1 month later...
freeflight29

Hi, I'm not sure what you're referring to? How does this relate to Emby?

hello,

 

sorry for my 'late" answer.

the problem is that my "root" folder when i connect with winscp to the nas is not volume1

 

below my "root" path when i 'am connected to the nas

 

59f4ff6be286b_asustorwinscp.png

 

so could you tell me how i can gain access to this path "volume1/@.plugins/AppCentral/mediabrowser/bin" ?

 

 

Thank you

Edited by freeflight29
Link to post
Share on other sites

hello,

 

sorry for my 'late" answer.

the problem is that my "root" folder when i connect with winscp to the nas is not volume1

 

below my "root" path when i 'am connected to the nas

 

59f4ff6be286b_asustorwinscp.png

 

so could you tell me how i can gain access to this path "volume1/@.plugins/AppCentral/mediabrowser/bin" ?

 

 

Thank you

 

 

@@freeflight29, the process is:

 

Open App Central -> Go to Manual Install -> Click Browse -> Select the package -> Click Upload

Link to post
Share on other sites
freeflight29

@@freeflight29, the process is:

 

Open App Central -> Go to Manual Install -> Click Browse -> Select the package -> Click Upload

lol sorry, i didn't see a new package in app central, so i thought i have to install it with winscp. 

thanks for you answer.

But i still intrested to navigate to volume1/@.plugins/AppCentral/mediabrowser/bin, i mean to "volume1" for modify what i want if i need to do something directly on it.

Link to post
Share on other sites
  • 4 months later...

Hello.

 

I updated my Emby Server with this Instructions... 3-4 Times in the past.

 

But now if i try to update to version 3.3... i have this error...   someone know how to solve this?

 

5a9bd0e6d9bc7_FaillUpdating.png

Log.txt

Edited by Gee
Link to post
Share on other sites

Hi @@Gee, I see. You're actually using the package built by Asustor and not built by us, and you're also running on an old version.

 

I would suggest uninstalling and then installing our new package, which you can find on our website:

https://emby.media/download

 

However please be aware, when you uninstall I'm not sure what's going to happen to your program data folder:

/volume1/.@plugins/AppCentral/mediabrowser/bin/ProgramData-Server

Thanks.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...