Jump to content

Help with Remote Connection


Recommended Posts

Hello All,

 

I'm having a bit of trouble connecting remotely. I have a DDNS address set up and I was able to successfully have a remote connection using port 80 for about 6 months, but recently something changed. I was messing around with internet information services (trying to set up an FTP server) I couldn't figure IIS out so I uninstalled it and went with FileZilla where I was able to setup without a problem. However, after that when I typed my URL in a web browser it took me to some IIS website instead of Emby.

 

So in the midst of my stupidity here is some of the troubleshooting I have done.

 

I have forwarded port 8096 and I have set an inbound rule in windows firewall to allow connections on that port.

I have combed through the firewall and I don't see anything that sticks out.

I have used canyouseeme.org several times (trying to open up random ports) and still cannot get a remote connection.

I have also turned wifi off on my cell and still cannot connect.

I have read through the connectivity wiki page that has been posted. 

I have verified that all the IP's are the same via the router and the PC Emby is running on. I'm using a static IP on the machine.

 

 

I am beginning to think my ISP is blocking me from external connections... Hope I'm wrong.

 

Any pointers you experts could give would be appreciated. Attached is a log.

 

Thank you,

Guy

server-63622271522.txt

Link to post
Share on other sites
Happy2Play

Looks like you set your public port to 58452.  Verify your settings on Dashboard-Advanced-Hosting

Link to post
Share on other sites

Thank you for the reply.

 

That log might not be correct. I was messing around earlier and tried to use a random port.

 

Here is what I have now.

589d352b69e01_20170209_223136.jpg

 

 

Here is the port forwarded in my router.

589d355312e74_20170209_223352.jpg

Link to post
Share on other sites
Happy2Play

Sounds like a firewall issue then.  Emby should have autoconfigured the firewall but there may have been issues.  You could try shutting down your server and going to your system.xml and resetting the switch "<IsPortAuthorized>true</IsPortAuthorized>" to false and starting your server to force a firewall update. (C:\Users\username\AppData\Roaming\Emby-Server\config)

Link to post
Share on other sites

Tried that and still can't connect or see the port open at canyouseeme.org

 

Now I do have it running on a VM and the VM is on a server running windows 2008.

Edited by GB1983
Link to post
Share on other sites

So for kicks, I disabled my firewall and restarted the Emby service. I was not able to see the port opened at canyouseeme.org.

 

Yes, I turned the firewall back on after this.

 

Is there a way to see if my ISP is blocking me? Again, I appreciate the help. I'm usually able to figure this stuff out on my own but this has me stumped.

Link to post
Share on other sites
mastrmind11

So for kicks, I disabled my firewall and restarted the Emby service. I was not able to see the port opened at canyouseeme.org.

 

Yes, I turned the firewall back on after this.

 

Is there a way to see if my ISP is blocking me? Again, I appreciate the help. I'm usually able to figure this stuff out on my own but this has me stumped.

Pick a random, high number port and forward it to your internal 8096.  That will rule out whether your ISP is blocking you (which I kinda doubt anyway).

Link to post
Share on other sites

As a 'get it working exercise', have you disabled the firewalls on both the VM Host and the VM itself ?  Remember the TCP 8096 needs to get through the router firewall, the VM Host firewall AND the Emby Host (VM) firewall - Incoming and Outgoing.  

 

Once this works, reenable all the firewalls - then Enable dropped packet logging on the firewalls and watch for the dropped requests, then you will know where the problem is and can create new rules on each firewall to allow TCP 8096 (and TCP 8920 for SSL) through to the Emby server running on the VM.

 

The rules on the Emby VM 'should' be there already during setup (via the Emby executable rule), but i bet the Windows VM Host firewall is blocking things...

Edited by rbjtech
Link to post
Share on other sites

Hi @@GB1983, I would suggest taking a look at our Connection Troubleshooter.  

 

Please try the steps listed and let us know exactly what succeeds and what fails as that will help us determine the problem. I know you said you read it but you didn't indicate which of the suggestions you tried. thanks !

Link to post
Share on other sites
  • 3 weeks later...

Ok guys I got it working.

 

I added inbound and outbound rules in my firewall for port 8096 in both the server and the VM.

 

I then added the port forwarding rule in my static NAT in my router for port 8096.

 

Rebooted the router and it is working now.

 

I appreciate all the replies.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...