Jump to content

Xbox app crashing to dash


xxJonoxx
 Share

Recommended Posts

xxJonoxx

Hi There Emby people,

 

The Xbox app seems to be crashing to the dash with the latest preview build -

 

10.0.15026.1001

(rs_xbox_dev_flight.170201-2341)

 

I have reported it to MS via preview channel, but thought you might like to know. Not sure what your communication is like between yourself and the platform holder.

 

Getting lots of 'Exception.Message: Unable to read data from the transport connection: Connection reset by peer.' type error msgs in the logs on the server.

 

 

Link to comment
Share on other sites

LqHnyBear

I too am having the exact same problem. Video whether direct playing or transcoding plays for a few seconds then the APP crashes to Xbox One dashboard however just prior to installing the Xbox One preview build emby was freezing while playing any videos. It's play the exact same length then just freeze everytime.

Link to comment
Share on other sites

FrostByte

however just prior to installing the Xbox One preview build emby was freezing while playing any videos. It's play the exact same length then just freeze everytime.

 

I get this all the time myself and have seen it reported several times.  It's right in the 40-50 minute point where it freezes for me, when you restart it then refreezes again about 40-50 afterward.

Link to comment
Share on other sites

LqHnyBear

I get this all the time myself and have seen it reported several times.  It's right in the 40-50 minute point where it freezes for me, when you restart it then refreezes again about 40-50 afterward.

 I was having that problem too but it seemed to happen only on certain files. It seemed to be mostly when transcoding.

Link to comment
Share on other sites

That's a good piece of information, for those who have seen this happen, what is the playback method? Is it direct play or transcoding? Is there a pattern there? Thanks !

Link to comment
Share on other sites

FrostByte

I don't have anything that transcodes on the XB1 unless you want to count DTS > AC3.  I'll have to test some more movies to see if I can find any pattern.  A lot of episodes are just under the time frame in which it happens on my system once commercials are taken out.  It's very odd that it always seems to happen at about the same time increments in a movie

Link to comment
Share on other sites

LqHnyBear

I don't have anything that transcodes on the XB1 unless you want to count DTS > AC3.  I'll have to test some more movies to see if I can find any pattern.  A lot of episodes are just under the time frame in which it happens on my system once commercials are taken out.  It's very odd that it always seems to happen at about the same time increments in a movie

Same here. Always about the same legnth of time about 40-60 min into it.

Link to comment
Share on other sites

I don't have anything that transcodes on the XB1 unless you want to count DTS > AC3.  I'll have to test some more movies to see if I can find any pattern.  A lot of episodes are just under the time frame in which it happens on my system once commercials are taken out.  It's very odd that it always seems to happen at about the same time increments in a movie

 

Remux vs direct stream would still be a useful piece of information. Is it one or the other, or both? thanks !

Link to comment
Share on other sites

FrostByte

Played 4 movies today as a test, 2 with DTS requiring remux and 2 with AC3 which just played.  All 4 movies just stopped playing at some point.  The app did not hang, it just stops and I can click 'B' and go back and resume playing movie afterward.  This has pretty much been my experience with the XB1 app so far, I'm usually fine with episodes, but movies I can expect to resume playing at least 2 or 3 times during the movie.

 

XB1 configuration

Audio Dolby bitstream connected directly to receiver via HDMI

hard wired to router

 

I've included the server log and the 2 remux logs for the DTS movies in the zip and below are the stop times for the 4 movies

 

Dracula Untold with DTS

 

589e281067fb6_xbox.jpg

 

The Dark Knight with AC3

 

589e282636c35_xbox2.jpg

 

The Matrix with DTS

 

589e2838f1732_xbox3.jpg

 

Iron Man with AC3 which actually stopped at 7:23 which is much sooner than usual

 

589e284ce5580_xbox4.jpg

 

 

 

 

 

logs.zip

Link to comment
Share on other sites

Deathsquirrel

@@FrostByte that appears to be a different issue than is covered in this thread.  Looks like the same thing many of us have been going through that's documented at https://emby.media/community/index.php?/topic/41562-emby-theater-app-freezes-xbox-one/?hl=%2Bxbox+%2Bone. It's not a crash to dashboard, playback just hangs.

 

I've had to go back to my NUC for anything longer than 22 minutes.  It's just too frustrating.

  • Like 1
Link to comment
Share on other sites

TrainAss

I too am on the Xbox Ones preview build (rs2_release_xbox_1703.170210-1900). Server is build 3.2.1.107 beta and theater client is version 2.0.1 according to the server dashboard. My theater client just updated as well.

 

I tried playing The Lion King, and after a few seconds, while Cinderella's castle is playing with the Disney theme, the playback begins to stutter and the client crashes back to the Xbox One dashboard.

 

I've attached logs which I hope Will help. I've no issues playing the same content on the theater client on my Windows 10 PC

server-63622886399.txt

ffmpeg-remux-1493da1e-7ca3-46f9-ae16-01b1b16bdd5f.txt

Link to comment
Share on other sites

Ok, I'm not seeing any problems on the stable xbox release but I run test videos all the time, so I am keeping an eye out for it, thanks.

Link to comment
Share on other sites

LqHnyBear

Ok, I'm not seeing any problems on the stable xbox release but I run test videos all the time, so I am keeping an eye out for it, thanks.

Do you have access to the insider preview builds? That's where the crashing on play is happening.

Link to comment
Share on other sites

schmitty

I have been having these issues too... since my Xbox Insider registration was changed from the Preview to new Beta ring. It only seems to happen with certain files 10-30 seconds into playback. Everything is direct play. Sometimes it will even crash to the dashboard while not playing. With some crashes, it will allow to resume Emby... others, it will completely crash.

 

 

Sent from my iPhone using Tapatalk

Link to comment
Share on other sites

Yep I'm in the alpha ring for Xbox testing, this is happening for me as well. All I do is keep reporting to Microsoft that they have created an incompatibility with Emby Theater and keep testing it with each build I get from them. If your an Emby user and this is the only device you have to watch Emby on I recommend removing yourself from the earlier rings of testing for Xbox if Emby playback is the most important thing to you on your Xbox.

Link to comment
Share on other sites

Just to give you an example of something that happened previously with the fast ring that was out of our control, there was another problem about not being able to connect to the server at all. Understandably some of you came in here looking for an Emby fix but it ended up being fixed by a subsequent fast ring update.

Link to comment
Share on other sites

LqHnyBear

Just to give you an example of something that happened previously with the fast ring that was out of our control, there was another problem about not being able to connect to the server at all. Understandably some of you came in here looking for an Emby fix but it ended up being fixed by a subsequent fast ring update.

 Odd thing is some video play with no crash and others crash 4-5 seconds after they start playing. If there is any info I can give you just tell me what to do otherwise I'll wait and hope the Xbone updates fix it as they're released.

  • Like 1
Link to comment
Share on other sites

xxJonoxx

Just to give you an example of something that happened previously with the fast ring that was out of our control, there was another problem about not being able to connect to the server at all. Understandably some of you came in here looking for an Emby fix but it ended up being fixed by a subsequent fast ring update.

 

Oh I hope my OP didn't give that impression, it was more as an FYI. I do keep reporting it with every new build.

 

Is there any way we can pull logs from the client to assist? (I'm guessing not given the walled gardens that is the Xbox).

Link to comment
Share on other sites

No, although we could always add a function to submit a log to us. I don't think it's going to be useful though because if it's happening during video playback without any user interaction, then that is more than likely just a crash in the UWP video player.  I will have to see what the process is to switch back and forth from Xbox insider to the stable channel because that's ultimately what i'd need to be able to do.

Link to comment
Share on other sites

TrainAss

Once you're in the preview program and have the update installed, if you want out you'll need to not only unenroll but factory reset the console.

 

https://support.xbox.com/en-CA/xbox-one/console/xbox-insider-program

 

It's also not a quick process. I re-registered I January when I replaced my Xbox one with a One S (in December) and only just got back in.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...