Jump to content

SoundCloud Plug-IN + DLNA Streaming Error


tgunergun
 Share

Recommended Posts

Hi Guys,

 

Could you please confirm whether SC plug-in for Emby really works? I can browse some of my SC content in the folder tree from a DLNA client but when i try to play any, it fails and keep jumping to next track.

 

I tried with different DLNA clients such as 8player or iMediaShare on IOS as well as with renders like samsung and panasonic smart tvs and mede8er media box but no luck ;-(

 

I'm using latest nightly built of Emby on Windows 10, tried the stable version but its DLNA server functionality is somehow broken.

Anyway, some logs attached, your help is greatly appreciated.

 

Cheers,

Tunc

ffmpeg-transcode-4cbcf750-5cca-4dd8-94d3-7918a47cc05a.txt

ffmpeg-transcode-be0b961c-267c-497b-965a-e792d5d014b1.txt

server-63619749306.txt

Edited by tgunergun
Link to comment
Share on other sites

Hi @@tgunergun, I tested soundcloud in the web app, it worked just fine. According to the log, this content requires authorization @@softworkz

https://api.soundcloud.com/tracks/170164770/stream?client_id=02gUJC0hH2ct1EGOcYXQIzRFU91c72Ea: Server returned 401 Unauthorized (authorization failed)

The plugin has configuration to enter soundcloud credentials. It's possible you might need to enter them.

Link to comment
Share on other sites

Hi @@tgunergun, I tested soundcloud in the web app, it worked just fine. According to the log, this content requires authorization @@softworkz

https://api.soundcloud.com/tracks/170164770/stream?client_id=02gUJC0hH2ct1EGOcYXQIzRFU91c72Ea: Server returned 401 Unauthorized (authorization failed)

The plugin has configuration to enter soundcloud credentials. It's possible you might need to enter them.

 

I entered my credential few times as well as restarted the server, the problem remains, on the top i can NOT browse the tracks i uploaded under my SC account  and stream info.

"My favorites", "followers", "I'm following" info is available via DLNA to any APP (Emby IOS , etc...)

 

PS: If there would be something wrong with my credentials I couldnt see my favorites on SC.

 

More logs attached., thank you!

ffmpeg-transcode-d8c2ac19-c6c1-4116-b448-2d7a913a7801.txt

ffmpeg-transcode-fa81f4c3-3162-4f86-912f-06f93b15831b.txt

server-63619763379.txt

ffmpeg-transcode-517c16e2-45d7-45e3-8951-1e363c789b70.txt

ffmpeg-transcode-86032ff4-b002-4071-adc2-eaa4eb58b692.txt

ffmpeg-transcode-93e76b99-3761-4993-a0ed-8e3497d8e3f2.txt

ffmpeg-transcode-fae7ede4-eb18-4f2e-bbdf-f77ce481401a.txt

Edited by tgunergun
Link to comment
Share on other sites

Ok, I do not know the answer about why SoundClound is returning those 401 unauthorized status codes, sorry. This is a community volunteer plugin. I am adding @@softworkz to the conversation since he is the plugin developer. Thanks !

Link to comment
Share on other sites

Ok, I do not know the answer about why SoundClound is returning those 401 unauthorized status codes, sorry. This is a community volunteer plugin. I am adding @@softworkz to the conversation since he is the plugin developer. Thanks !

 

Thanks Luke! Hope @softworkz responds and can help us! cheers.

 

https://developers.soundcloud.com/docs/api/reference

Edited by tgunergun
Link to comment
Share on other sites

from API dev guide;

 

401 Unauthorized

This means that we were not able to authenticate you based on the information provided in the request. Make sure you're sending a client_id or an access_token.Our public endpoints will work by just providing a client_id. Acting on behalf of another user is different. The Authentication section gives a detailed explanation of how this works. If you're connecting using OAuth, don't forget that tokens can expire. These will need to be refreshed. Not doing so can also result in getting a 401 error.

If you need to check your application's details, use the Your Applications page. This will include the client_id for your application.

Edited by tgunergun
Link to comment
Share on other sites

@softworkz @luke 

 

It works, many thanks for providing a quick fix.

Now I CAN browse my own tracks (the ones i uploaded on SC) via DLNA client (8player) and my DLNA renderer (mede8er ) plays any track from SC, however I noticed following strange behavior;

 

- my favorites (likes) on SC appear twice when i browse them via DLNA client (8player); (see attached photo)

- above does not happen if i use emby client as it probably connects via http not dlna procotol (multicast);

- On both clients (emby + 8player) i cant seek (ahead or back) the playing track; (see attached photo)

 

Version 3.1.6223.5529 dev

 

cheers

post-179848-0-77189300-1484425342_thumb.png

post-179848-0-34645800-1484425344_thumb.png

Edited by tgunergun
Link to comment
Share on other sites

@@tgunergun, is it only the favorites appearing twice while all other tracks are appearing just once?

Can you reproduce the behavior with another DLNA client as well?

 

Regarding seek, I checked and I can seek in the Emby web client (directly browsing the url of your Emby server).

Have you tried like this?

Link to comment
Share on other sites

@@tgunergun, is it only the favorites appearing twice while all other tracks are appearing just once?

Can you reproduce the behavior with another DLNA client as well?

 

Regarding seek, I checked and I can seek in the Emby web client (directly browsing the url of your Emby server).

Have you tried like this?

 

I tried to reproduce the issue with other DLNA clients, seems this is an isolated case for 8player, i'll contact its developer for troubleshooting.

 

Regarding seek functionality, yes, it works from Emby web client, but not with any DLNA client. I tested 8player, Media Player Link Lite, AirPlayer and AllCastTV, no luck.

 

May be this is something that @luke can have look at it? It seems not relevant to SC plug-in?

 

cheers.

Link to comment
Share on other sites

Yeah, that would probably be @@Luke's area.

 

To increase your chances for getting this resolved, it might help if you could test one or two other channel plugins (for audio) and confirm that the problem exists for those as well.

Link to comment
Share on other sites

Yeah, that would probably be @@Luke's area.

 

To increase your chances for getting this resolved, it might help if you could test one or two other channel plugins (for audio) and confirm that the problem exists for those as well.

 

@softworkz @luke

 

OK, i tested with TuneIn, same results with 3 different DLNA players, seek does not work at all.

 

Please advise how to troubleshoot it?

 

Many thanks

Edited by tgunergun
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...