Jump to content


Photo

Telegram notification?


  • Please log in to reply
60 replies to this topic

#21 Overseer OFFLINE  

Overseer

    Advanced Member

  • Members
  • 245 posts
  • Local time: 05:02 PM
  • LocationYelm, WA, US

Posted 21 May 2018 - 09:31 PM

I downloaded the zip from github, copied the DLL to my plugin folder and restarted EMBY.  The plug-in appears under my plug-ins.  I got to the setup page but the "Configure Telegram notifications for:" box is empty.  Should users appear there?

 

I enter the bot token and user key but when I hit save I get the following message:

 

Exception of type 'MediaBrowser.Common.Extensions.ResourceNotFoundException' was thrown.

 

This looks to be part of the log for the error:

2018-05-21 18:21:54.060 Info HttpServer: WS http://emby.****.us:8096/socket?api_key=7efd282bdd334a3093fb65807d9f1dce&deviceId=b1c59c9e8e45f8eed19df40dd7d0955ec560f628. UserAgent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/66.0.3359.181 Safari/537.36
2018-05-21 18:22:54.053 Error HttpServer: Error in SharpWebSocket: An exception has occurred while receiving a message.. Exception.Message: The header part of a frame cannot be read from the data source.
2018-05-21 18:23:18.386 Info HttpServer: HTTP GET http://emby.****.us:8096/web/configurationpage?fakeusernameremembered=&fakepasswordremembered=. UserAgent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/66.0.3359.181 Safari/537.36
2018-05-21 18:23:18.390 Error HttpServer: Error processing request
	*** Error Report ***
	Version: 3.4.1.6
	Command line: C:\Users\Admin\AppData\Roaming\Emby-Server\system\EmbyServer.dll -service
	Operating system: Microsoft Windows NT 6.2.9200.0
	64-Bit OS: True
	64-Bit Process: True
	User Interactive: True
	Processor count: 4
	Program data path: C:\Users\Admin\AppData\Roaming\Emby-Server\programdata
	Application directory: C:\Users\Admin\AppData\Roaming\Emby-Server\system
	MediaBrowser.Common.Extensions.ResourceNotFoundException: Exception of type 'MediaBrowser.Common.Extensions.ResourceNotFoundException' was thrown.
	   at MediaBrowser.WebDashboard.Api.DashboardService.Get(GetDashboardConfigurationPage request)
	   at Emby.Server.Implementations.Services.ServiceExecGeneral.Execute(Type serviceType, IRequest request, Object instance, Object requestDto, String requestName)
	   at Emby.Server.Implementations.Services.ServiceController.Execute(HttpListenerHost appHost, Object requestDto, IRequest req)
	   at Emby.Server.Implementations.Services.ServiceHandler.ProcessRequestAsync(HttpListenerHost appHost, IRequest httpReq, IResponse httpRes, ILogger logger, String operationName, CancellationToken cancellationToken)
	   at Emby.Server.Implementations.HttpServer.HttpListenerHost.RequestHandler(IHttpRequest httpReq, String urlString, String host, String localPath, CancellationToken cancellationToken)
	MediaBrowser.Common.Extensions.ResourceNotFoundException
	   at MediaBrowser.WebDashboard.Api.DashboardService.Get(GetDashboardConfigurationPage request)
	   at Emby.Server.Implementations.Services.ServiceExecGeneral.Execute(Type serviceType, IRequest request, Object instance, Object requestDto, String requestName)
	   at Emby.Server.Implementations.Services.ServiceController.Execute(HttpListenerHost appHost, Object requestDto, IRequest req)
	   at Emby.Server.Implementations.Services.ServiceHandler.ProcessRequestAsync(HttpListenerHost appHost, IRequest httpReq, IResponse httpRes, ILogger logger, String operationName, CancellationToken cancellationToken)
	   at Emby.Server.Implementations.HttpServer.HttpListenerHost.RequestHandler(IHttpRequest httpReq, String urlString, String host, String localPath, CancellationToken cancellationToken)

Attached Files


Edited by Overseer, 21 May 2018 - 09:33 PM.


#22 darkside40 OFFLINE  

darkside40

    Advanced Member

  • Members
  • 87 posts
  • Local time: 03:02 AM

Posted 22 May 2018 - 02:49 AM

I will have a look at it.

Seems that you use the latest beta.

I have only tested the Plugin on the stable version of Emby.

 

First i have to figure out how to have multiple Server Versions installed on my machine. 



#23 Overseer OFFLINE  

Overseer

    Advanced Member

  • Members
  • 245 posts
  • Local time: 05:02 PM
  • LocationYelm, WA, US

Posted 22 May 2018 - 09:37 AM

My apologies. Yes, I'm on the beta channel for Emby server. I should have mentioned that.

#24 george.carstoiu OFFLINE  

george.carstoiu

    Member

  • Members
  • 18 posts
  • Local time: 03:02 AM

Posted 07 July 2018 - 01:14 PM

Thanks for the work. Just installed and configured and it works flawlessly. Looking forward to seeing it in the plugins catalog.


  • Davide likes this

#25 darkside40 OFFLINE  

darkside40

    Advanced Member

  • Members
  • 87 posts
  • Local time: 03:02 AM

Posted 22 July 2018 - 02:53 PM

Confirmed working with 3.5.0.0



#26 MindBullet OFFLINE  

MindBullet

    Advanced Member

  • Members
  • 221 posts
  • Local time: 03:02 AM

Posted 28 July 2018 - 12:59 AM

@ darkside40 great job! Working flawlessly on 3.5.0.1 over here :) Do you think there's a chance to add more variaty to messages? What I'd love to see would be a "Recently added" notification, which shoots, when there's something added to the server. Do you think that's possible? Kind regards :)

 

Also I think it would be great to fix the textfield misbehavior. If you once added a Chat ID or token for a specific user you can't go back. If you once saved it and then want to disable it for this user, you can't save it, because it's asking you to fill in the token. Only way out seems to be reinstalling it :D Cheers


Edited by GodOnEmby, 28 July 2018 - 01:08 AM.


#27 darkside40 OFFLINE  

darkside40

    Advanced Member

  • Members
  • 87 posts
  • Local time: 03:02 AM

Posted 02 August 2019 - 09:01 AM

@ Luke what would be needed to get that Plugin into the Emby Plugin Catalog. It works so far for one year now for me.

I know there are some issues to be targeted, for example that sometimes only a filename is posted, instead of the movie name, but i first have to find out if this is a problem only to this plugin.



#28 ebr OFFLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 51887 posts
  • Local time: 09:02 PM

Posted 02 August 2019 - 10:52 AM

@ Luke what would be needed to get that Plugin into the Emby Plugin Catalog. It works so far for one year now for me.

I know there are some issues to be targeted, for example that sometimes only a filename is posted, instead of the movie name, but i first have to find out if this is a problem only to this plugin.

 

A developer willing to fully support it.  That means keep it up to date with server versions as well as fix any issues and respond to user help requests.

 

Do we have that for this plug-in?



#29 darkside40 OFFLINE  

darkside40

    Advanced Member

  • Members
  • 87 posts
  • Local time: 03:02 AM

Posted 06 August 2019 - 03:18 PM

First of all i think i will try to resolve some issues with the plugin, like improper URL encoding or missing rate limiting.



#30 darkside40 OFFLINE  

darkside40

    Advanced Member

  • Members
  • 87 posts
  • Local time: 03:02 AM

Posted 13 August 2019 - 03:16 PM

Okay pushed a new Version to the repo addressing the problem with inproper URL encoding:

https://github.com/b...cation/releases

 

Next issue is moving to newer .netstandard2.0 and a newer Emby Server Core.


Edited by darkside40, 13 August 2019 - 03:17 PM.


#31 darkside40 OFFLINE  

darkside40

    Advanced Member

  • Members
  • 87 posts
  • Local time: 03:02 AM

Posted 22 August 2019 - 03:08 PM

New version is online: 

https://github.com/b...es/tag/v1.1.0.0



#32 adamstewiegreen OFFLINE  

adamstewiegreen

    Advanced Member

  • Members
  • 330 posts
  • Local time: 11:02 AM
  • LocationMuswellbrook, NSW

Posted 23 August 2019 - 11:19 PM

Thanks for resurrecting this, I just tried it out last night and it works great.  Only issue I've had is that apostrophes don't show properly so "Adam's" turns into "Adam's".



#33 darkside40 OFFLINE  

darkside40

    Advanced Member

  • Members
  • 87 posts
  • Local time: 03:02 AM

Posted 24 August 2019 - 09:16 AM

Thanks for the info, i have a look at it in the next couple of days.



#34 adamstewiegreen OFFLINE  

adamstewiegreen

    Advanced Member

  • Members
  • 330 posts
  • Local time: 11:02 AM
  • LocationMuswellbrook, NSW

Posted 24 August 2019 - 09:36 AM

Another thing, when I pause a show I get a notification saying that the show has finished (which it hasn't). and when I play it doesn't say it's playing again

#35 darkside40 OFFLINE  

darkside40

    Advanced Member

  • Members
  • 87 posts
  • Local time: 03:02 AM

Posted 25 August 2019 - 03:09 AM

That is no problem of the plugin, because it just forwards the messages it gets from the notification framework.



#36 gewbert OFFLINE  

gewbert

    Member

  • Members
  • 14 posts
  • Local time: 08:02 PM

Posted 25 August 2019 - 11:28 AM

Thanks very much for this!

 

Is there any chance of getting the ability to send cover art with the message?  I have a friend who uses Plex and his channel puts out a message like this when something is added.

 

5d62a9220a56f_Capture.jpg



#37 darkside40 OFFLINE  

darkside40

    Advanced Member

  • Members
  • 87 posts
  • Local time: 03:02 AM

Posted 25 August 2019 - 12:04 PM

In the moment it is not possible to add Coverart to the message. Thats another limitation of the Emby Notification Framework, see here: https://emby.media/c...n-notification/



#38 darkside40 OFFLINE  

darkside40

    Advanced Member

  • Members
  • 87 posts
  • Local time: 03:02 AM

Posted 25 August 2019 - 02:49 PM

Thanks for resurrecting this, I just tried it out last night and it works great.  Only issue I've had is that apostrophes don't show properly so "Adam's" turns into "Adam's".

 

Hi there,

i just tried it by modifying the Test Message and the apostrophe was correct escaped.

Are you using the latest Version of the Plugin?

Attached Files


Edited by darkside40, 25 August 2019 - 02:53 PM.


#39 adamstewiegreen OFFLINE  

adamstewiegreen

    Advanced Member

  • Members
  • 330 posts
  • Local time: 11:02 AM
  • LocationMuswellbrook, NSW

Posted 25 August 2019 - 06:51 PM

I did some digging and that's how the default fire tv name appears to Emby, so I changed its display name (which I didn't know I could do until now).

#40 darkside40 OFFLINE  

darkside40

    Advanced Member

  • Members
  • 87 posts
  • Local time: 03:02 AM

Posted 26 August 2019 - 03:23 AM

So the problem is solved?






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users