Jump to content

Emby Theater for Linux


xnappo

Recommended Posts

frabe8378910

Playback of recorded ts files in ET which Emby server Versjon 3.2.13.0 streams gives the same error message as posted in #77. If I play the stream with mpv the stream plays without problem.

mpv "http://192.168.9.2:8096/emby/Videos/8b966788d9811a536d66a4c544549d15/stream.ts?Static=true&mediaSourceId=8b966788d9811a536d66a4c544549d15&deviceId=emby-EB1501P&api_key=2eea4b7e75ad43c9baafc83804fc8b1b&Tag=1341f5c8a83f4805fa18cbd3bf839ab0"

I renamed mpv to mpv-rename and started up ET. ET gives the same error message as posted in #77 again when trying to play the above video file. So it seems that ET is using the embedded chromium video player, which do not have support for recorded ts files with H265 and AAC embedded streams as posted in #89 . I have done a git pull of the git repository so ET should be up-to-date.

 

Yes, I have verified that too.

I have found several situations, i.e. ET not in fullscreen, with "--disable-gpu" where the playback is done by embedded chromium. I've not found a way the force playback by mpv so far.

Next I'll try to make a matrix, when ET will use mpv for playback.

 

Without the --disable-gpu param I can "play" recorded ts video files without error message posted in #77. But I only get a gray 16:9 window without any video content playing. Before I tested this I did a git pull.

 

590b75e0a15fd_Selection_004.png

 

The pc I use for ET has a VGA compatible controller: NVIDIA Corporation GT218 [iON] (rev a2) graphic card

 

I have the same effect. With "--disable-gpu" ET main menu is kind of laggy and I have playback. Max. 5MB/s okay is playable, anything higher is stuttering. 

Without "--disable-gpu" I have stutter free sound at 60MB/s, but an invisible video. :D

The HW is a Zotac ID80 box with a NVIDIA card.

 

I'll do some more testing on the weekend.

 

 

Link to post
Share on other sites
frabe8378910

So basically it's playing underneath the UI?

That may be possible. But I was not abe to get to the window behind. Even if I played with minimize or maximize the windows.

Link to post
Share on other sites
haraldov

With ET for electron (git pull version 2.6.7) I have same errors as reported earlier in post #77. Without "--disable-gpu" I have no error but the video do not show as posted in #101. It seems like mpv is playing underneath the UI, because I see the video time amount passed in the OSD changing as the recording plays.

 

The log shows cecExePath: '--disable-gpu'. This must be wrong, but maybe not related to this problem.

Initializing cec-client...

{ cecExePath: '--disable-gpu',
  cecEmitter:
   EventEmitter {
     domain: null,
     _events: {},
     _eventsCount: 0,
     _maxListeners: undefined } }
ERROR: cec-client not installed, running without cec functionality.

et-09052017.log

Edited by haraldov
Link to post
Share on other sites
haraldov

This might be the reason: https://github.com/e...ron/issues/9164

 

I have tried using electron version 1.6.7 and 1.7.0 with no  --disable-gpu in the et.sh and I get no video as posted in #101.

But then I downgraded electron to version 1.4.16 like this and I have video and OSD menu overlay which disappers after a while !

emby@emby-EB1501P:~$ sudo npm -g remove electron

# You might get a error about files not found when trying to install other
# version of electron. Fix this issue like this:  
# emby@emby-EB1501P:~$ sudo rm -rf /usr/local/lib/node_modules

emby@emby-EB1501P:~$ sudo npm -g install electron@1.4.16 --arch=ia32

After this sucess I tried the next released electron version which was 1.5.0 and I get no video again.

Release notes for electron 1.5.0 says:

This is the first release running on upgraded versions of Chrome and Node
Upgraded from Chrome 53.0.2785.143 to 54.0.2840.101
Upgraded from Node 6.5.0 to 7.4.0

I am using electron on XUbuntu 16.04 with open source NVIDIA drivers nouveau driver.

.

et-11052017.log

Edited by haraldov
Link to post
Share on other sites
haraldov

I have the same error #66 with ET as @denz on my rpi3 with raspbian when trying to play livetv-stream from streamdev-plugin for vdr.2.3.3 and from recorded ts files from emby server 3.2.12.0

 

Sucess again with ET for electron on rpi3. When downgrading electron to version 1.4.16 on my rpi3 with raspbian I do not have the Java script error reported earlier in post #77. I can also play recorded ts files with mpv player.   

I'll do some more testing tomorrow with the XUbuntu pc and the rpi3.

Great work guys.

Edited by haraldov
Link to post
Share on other sites
Luke

@, with this now functional on RPI, we soon may not need the RPI-specific code base anymore.

Link to post
Share on other sites
Luke

Yes. I think our next objective now is a nice and easy single-command installation process.

 

The windows version is also using this same code base so that will allow all of them to develop and mature together, which is great.

  • Like 1
Link to post
Share on other sites

No luck it doesn't work I can't maximise the app when I try it just moves to top left corner and when I go to play something I get a javascript error

 

post-1589-0-72153600-1494502533_thumb.png

Link to post
Share on other sites

I do have it installed I followed instructions few posts back to compile mpv 

 

I think the issue is the location f drive that is on the server

 

 

591470eadd06b_Screenshotfrom201705112210

 

59146eac84b16_Screenshotfrom201705112200

 

when I maximise

 

5914716a5a2cc_Screenshotfrom201705112212

 

When I try to watch live tv nothing changes in theater only in the console window there is movement

 

591472c596233_Screenshotfrom201705112216

 

 

Edited by denz
Link to post
Share on other sites
haraldov

I do not have the Javascript error when I run the application without the --disable-gpu and with electron 1.4.16. 

electron --enable-transparent-visuals main.js

You must also use the application with the open source NVIDIA nouveau driver. If you use nvidia driver version 340.102 and 304.135 ET start up with a transparent blue overlay

 

5914d46c29d1c_ETforlinuxwithnvidia340dri

 

You can easily switch over to the nouveau driver with the Software & Update --> Additional Driver 

 

5914d4b0bb810_PropetaryDriverinstallatio

 

I also can not expand the ET window to fullscreen on my Intel Eebox 1501B box and with my RPI3 with raspbian Jessie.

 

5914d4897635b_ETforlinuxwithnvidia340dri

et-electron-11052017.log

Edited by haraldov
Link to post
Share on other sites
haraldov

@haraldov, there was a new beta of electron released today, so you could also try that.

 

I have tried electron v1.7.0 and I get the Java script error with this version also. The only version which work is electron 1.4.16 and less I believe.

Edited by haraldov
Link to post
Share on other sites

I did a clean raspbian install when I first ran electron theater I needed to install the following components

 

sudo npm install lodash

sudo npm install promise 

sudo np install cuid 

 

Once I installed it same issues as before you cannot maximise the app or watch anything.

Edited by denz
Link to post
Share on other sites

I ran the following command sudo npm -g install electron@1.4.16  as haraldov recommended and now emby starts full screen however still cannot watch anything still the same error. 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...