Jump to content

BUG in Emby DLNA server when serving external subtitles to Samsung Smart TV DLNA Client


Wayve
 Share

Recommended Posts

Hi,

Emby Server 3.0.8500.0 (Windows 10 64-bit) is unable to serve external .srt subtitles to Samsung Tizen JS9000, whereas Serviio is successfully able to do so.

Proper DLNA profile configured for Samsung Tizen TV in Emby and confirmed to be in use. The subtitle profile section contains the below:

  <SubtitleProfiles>
    <SubtitleProfile format="srt" method="External" didlMode="CaptionInfoEx" />
  </SubtitleProfiles>

 

Wireshark TCP capture for failed Emby external subtitles serving scenario showed the following wrong section:

<CaptionInfoEx d3p1:type="srt" xmlns:d3p1="sec" xmlns="sec">
http://10.42.0.167:8096/Videos/e59398b141080a191c061086f182d404/e59398b141080a191c061086f182d404/Subtitles/4/0/Stream.srt
</CaptionInfoEx>

 

Wireshark TCP capture for successful Serviio external subtitles serving scenario showed the following correct section:

<sec:CaptionInfoEx sec:type="srt">
http://10.42.0.167:8895/resource/1/1_SUBTITLE.srt
</sec:CaptionInfoEx>

 

This issue is tied to the methods in MediaBrowser.Dlna/Didl/DidlBuilder.cs which should be checked.

Looking forward to have this issue fixed..and making Emby The One & Only !

Regards.

Link to comment
Share on other sites

Hi, thanks for the report. I think the forum is encoding your examples. Can you please paste them again and highlight them using the code tool? Thanks !

Link to comment
Share on other sites

Thx Luke for the feedback.

Concerning the encodings, they are actually correct. However, a more readable form would be as follows:

 

Wireshark TCP capture for failed Emby external subtitles serving scenario showed the following wrong section:

<CaptionInfoEx d3p1:type="srt" xmlns:d3p1="sec" xmlns="sec">http://10.42.0.167:8.../4/0/Stream.srt</CaptionInfoEx>

 

Wireshark TCP capture for successful Serviio external subtitles serving scenario showed the following correct section:

<sec:CaptionInfoEx sec:type="srt">http://10.42.0.167:8.../1_SUBTITLE.srt</sec:CaptionInfoEx>

 

This issue is tied to the methods in MediaBrowser.Dlna/Didl/DidlBuilder.cs which should be checked.

Regards.

Link to comment
Share on other sites

Much appreciated + Looking forward to the next release !

One more thing:

For Samsung DLNA devices, the below additional section needs to be added to the root element of every xml response from server side:

xmlns:sec="http://www.sec.co.kr/"

 

This custom section is properly declared in Emby's system profile related to Samsung Smart TV as follows:

  <XmlRootAttributes>
    <XmlAttribute name="xmlns:sec" value="http://www.sec.co.kr/"/>
  </XmlRootAttributes>

 

​However, it has never been actually sent from Emby's side to Samsung TV (in the case of Serviio, I can clearly see it being transmitted every time).

This issue is also tied to the methods in MediaBrowser.Dlna/Didl/DidlBuilder.cs which should be checked as well.

regards.

Link to comment
Share on other sites

Thanks. I believe I went through all of those as well and made sure they were consistently applied, so I think that is resolved as well.

Link to comment
Share on other sites

  • 2 weeks later...

Same problem here with a Samsung series 6 TV (UN50KU6000), there are no external srt subtitles. I tried the beta and dev versions and also didn't work, is there any expectation when will be the next release?

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...