Jump to content

ServerWMC Not Connected


iam4uk
 Share

Recommended Posts

I installed serverwmc today after updating MB3 server and seeing the "Live TV" section.  ServerWMC is running and its interface reports that all is well, but MB3Server reports "serverwmc not connected."

 

I have not found documentation or troubleshooting tips for this exciting new additional capability; can anyone point me in the right direction?

 

 

Windows 7 Home Premium x64 SP1

intel i5-2500K, 8 GB RAM

nvidia GT 430, driver 332.21

 

Media Browser Server 3.0.5135.31685, running on ports 8096 and 8945

(I noticed a reference to port 9080 for serverwmc, but have not found any option for specifying any ports in MBServer.)

 

 

Link to comment
Share on other sites

Logos302

I could be wrong but I believe there is a special version of ServerWMC for MB3 that needs to be installed and not just the regular one.  you will also need to supply logs from the server before they will be able to help.

Link to comment
Share on other sites

I installed serverwmc today after updating MB3 server and seeing the "Live TV" section.  ServerWMC is running and its interface reports that all is well, but MB3Server reports "serverwmc not connected."

 

I have not found documentation or troubleshooting tips for this exciting new additional capability; can anyone point me in the right direction?

 

 

Windows 7 Home Premium x64 SP1

intel i5-2500K, 8 GB RAM

nvidia GT 430, driver 332.21

 

Media Browser Server 3.0.5135.31685, running on ports 8096 and 8945

(I noticed a reference to port 9080 for serverwmc, but have not found any option for specifying any ports in MBServer.)

The port is correct... If you go into Plugins -> ServerWMC (On your MB3 server)

The port and the ServerWMC/IP Name filed should be there. If its hosted on the same machine, try setting it to 127.0.0.1, otherwise use the IP address of the machine that has the TV Tuner and ServerWMC on it.

 

Also, make sure that you have serverWMC running BEFORE you start up MB3...

 

As @@Logos302 said, please post your logs if checking those things don't help.

Edited by robsch
  • Like 1
Link to comment
Share on other sites

The thing that caught me unawares was the need to have WMC already set up for Live TV, recognizing your tuner, channels, downloading guide information, etc. If this isn't done already, ServerWMC apparently won't have anything to connect to, since it's just a connection between WMC and MB3. :)

 

If you've already done all this, please ignore. :D

Link to comment
Share on other sites

I followed the guidance of robsch and it worked.  The MBServer plugin had been set to "localhost," which did not work, so I input the IP address of the computer.

 

Now serverwmc live tv is working, but what can be done with it?  I don't see it in MediaBrowser on my computer or android app.

Link to comment
Share on other sites

Thank you, Luke. I am enthused by the direction of the development of MediaBrowser.

 

Sent from my SCH-I545 using Tapatalk

 

 

Link to comment
Share on other sites

I followed the guidance of robsch and it worked.  The MBServer plugin had been set to "localhost," which did not work, so I input the IP address of the computer.

 

Now serverwmc live tv is working, but what can be done with it?  I don't see it in MediaBrowser on my computer or android app.

Glad I could help.

Link to comment
Share on other sites

nicko84

Hi !

 

MB3 Server is always running BEFORE ServerWMC starts....so LiveTV can't connect.

 

Have you a trick to run Server WMC BEFORE MB3 Server starts please ?

 

Thanks for your help !

Link to comment
Share on other sites

swhitmore

Hey guys,
 
I couldn't get the plugin to connect to the ServerWMC either. I've installed it on my HTPC (different for the server), and tried the computer name and IP with no luck. I've added the ports to my firewall on both the server and HTPC with no luck. I just keep getting the error "CONNECTION FAILED".
 
ServerWMC Log
MB Server Log

Checked netstat and it's definitely listening.
 
 gQFaX5E.png

Link to comment
Share on other sites

WWWestern

swhitmore, аnd is on HTPC, where was installed ServerWMC, also is installed MCE and configured channels and EPG?

Link to comment
Share on other sites

swhitmore

swhitmore, аnd is on HTPC, where was installed ServerWMC, also is installed MCE and configured channels and EPG?

 

Yeah, I use WMC on the HTPC for live TV already. Could PlayReady be causing issues?

Edited by swhitmore
Link to comment
Share on other sites

Hi !

 

MB3 Server is always running BEFORE ServerWMC starts....so LiveTV can't connect.

 

Have you a trick to run Server WMC BEFORE MB3 Server starts please ?

 

Thanks for your help !

You need to make serverwmc into a service with srvstart, then make a scheduled action to watch serverwmc being started and have it launch mb server at that operation

Link to comment
Share on other sites

WWWestern

You need to make serverwmc into a service with srvstart...

Why not use C:\Program Files (x86)\ServerWMC\InstallService.bat ?

Link to comment
Share on other sites

BATTLE DONKEY

Have u tried going to the scheduled tasks and refreshing the guide. I had the same issue where under the live tv tab it said serverwmc was not connected even tho the serverwmc application was picking up all my channels and tuners. Once I refreshed the guide everything sorted itself out n was up and running

Link to comment
Share on other sites

swhitmore

Have u tried going to the scheduled tasks and refreshing the guide. I had the same issue where under the live tv tab it said serverwmc was not connected even tho the serverwmc application was picking up all my channels and tuners. Once I refreshed the guide everything sorted itself out n was up and running

 

Thanks, I just tried that, but still getting the same connection failed error.

Link to comment
Share on other sites

swhitmore

Ok, so I've tried changing ports, firewall settings etc. Still no luck. Am I the only one? @@krustyreturns any chance you can take a look at this?

Edited by swhitmore
Link to comment
Share on other sites

nicko84

You need to make serverwmc into a service with srvstart, then make a scheduled action to watch serverwmc being started and have it launch mb server at that operation

 

Thanks for your help ! 

 

I will try this...but developers have to find a better way to solve this problem...

Link to comment
Share on other sites

scarecrow420

FYI ServerWMC can run as a windows service already, no need to convert it using srvstart.  Check the ServerWMC wiki.  A previous poster in this thread had the right idea (InstallService.bat)

 

So if I understand your problem correctly, you want MB3 and ServerWMC to start on windows start/reboot but you need ServerWMC to be running before MB3?  I would suggest the order shouldnt matter (MB3 should keep attempting to connect to ServerWMC so when it is started, the connection is established).  But if you do want to try and influence the start order, apart from the scheduled action suggestion you could also set ServerWMC (installed as a servie) to auto start, and MB3 service to autostart (delayed).  that should ensure ServerWMC is started by windows, before MB3 is

Link to comment
Share on other sites

Ok, so I've tried changing ports, firewall settings etc. Still no luck. Am I the only one? @@krustyreturns any chance you can take a look at this?

Do you happen to have WMC running (ie. open)

 

One thing I found, which I thoguht was odd, and it might just be due to my hardware is that if I had WMC, then when I connected with MB3 to ServerWMC, I would see it, be able to see the guide, but not tune into any station. Once I shut down WMC, and restarted ServerWMC, it would work like a champ.

 

- Robert

Link to comment
Share on other sites

nicko84

FYI ServerWMC can run as a windows service already, no need to convert it using srvstart.  Check the ServerWMC wiki.  A previous poster in this thread had the right idea (InstallService.bat)

 

So if I understand your problem correctly, you want MB3 and ServerWMC to start on windows start/reboot but you need ServerWMC to be running before MB3?  I would suggest the order shouldnt matter (MB3 should keep attempting to connect to ServerWMC so when it is started, the connection is established).  But if you do want to try and influence the start order, apart from the scheduled action suggestion you could also set ServerWMC (installed as a servie) to auto start, and MB3 service to autostart (delayed).  that should ensure ServerWMC is started by windows, before MB3 is

 

Yes that's it !

 

To start ServerWMC BEFORE MB Server is running you have to :

 

First, you run"install.bat" in "C:\Program Files\ServerWMC" to install ServerWMC as a Service (with autostart)

 

Than you chose to start MB3 Server as a Service too (and not to start it with Windows) AND you modify the MB3 Service from autostart to autostart (delayed).

 

Thanks for your help !

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...