Jump to content

Built HTPC for parents that have no internet


FTompkins73
 Share

Go to solution Solved by ebr,

Recommended Posts

FTompkins73

I recently built a HTPC for my parents who have no internet.  All is good and I love Emby.  The problem I am having is when they launch Emby for media center it does not find the server that is on the very same HTPC.  I was able to log in manually, but my parents are elderly and very tech impaired.  I wanted to set up a simple one click and "boom" there are the movies and tv shows to choose from.  Having them have to go through the manual log in steps every time they want to use emby is sort of making difficult for them something nice I was trying to set up for their entertainment.  Any suggestions?  I had hoped that once I manually logged them in it would remember the settings...No luck.  The main dashboard page showed no in home access url since there is no network connected.  Tried binding to a local network address and still no luck.  Any help with this would be very helpful.  Yes I realize Emby is designed to be used on a network etc, but there should be a way to use it otherwise.  Would simply connecting a router do the trick?  I mean there would still be no internet, but would that at least establish a network so that emby classic would log in automatically?

Link to comment
Share on other sites

Is Emby for WMC by any chance starting up before Emby Server is up and ready? Aside from that we'll have to see what @@ebr thinks. Thanks.

Link to comment
Share on other sites

Yes, first make sure the server is up and available before EMC starts.

 

Second, there is an option on the first config page in the app to have it automatically log in.

Link to comment
Share on other sites

FTompkins73

Yes the server is up and running and shows the ports it is running on in the dashboard but the local access http field is blank. And the auto log in is set to log in current user (once I got them logged in). I tried to replicate it simply by unplugging my Ethernet cable on my setup (since I run WMC on the same machine as the server). And restarted server. Dashboard shows the same as my parents yet it still logged me in automatically. I will try a few more things tonight after work to see if I can replicate it.  And post anything I find out.

 

 

 

582b4c6ad8ae2_Capture.jpg

Link to comment
Share on other sites

kaufhauslicht

For your specific purpose, why do you need a server backend like emby at all? Maybe it is way easier to set up your parent's HTPC with Kodi (OS: LibreELEC), store all media on the internal drive and use a really simple, as well easy readable, skin like Eminence or Conq.

 

How do you collect media information without internet connection, anyway?

Edited by kaufhauslicht
Link to comment
Share on other sites

FTompkins73

To answer your question:

1-I wanted a windows machine (my parents do like to play the games installed with windows)

   Also a whole list of sub-reasons I wanted a windows machine for them that I am not even going to go into.

2-I have never used or messed with any other app (and it didn't seem simpler to learn a whole new way of doing things)

3- My parents have used my system when babysitting for me and are already used to it

4- I store metadata with the movies so there is no need to "scrap" as you put it

5- And finally what's it to you what I choose?  I was looking for answers to my question not a "hey just toss Emby out the window and start all over solution! If I wanted to do what you suggested I would have done that to begin with!  I just wanted Emby to work for them the way it works for me that is all.

  • Like 1
Link to comment
Share on other sites

kaufhauslicht

Sorry, my intention was not to insult you or your basic idea. Speaking of experience with my no-tech parents: I found the Kodi solution way easier for them (simpler interface, remote control etc.). But of course, everyone is entitled to a different opinion. 

Link to comment
Share on other sites

FTompkins73

I have been able to replicate it on my machine.  If I disconnect the Ethernet cable and restart the server it will show the following in the dashboard home page.

 

 

582c494458a43_Capture3.jpg

 

But it will still log me in automatically....however....if I power down my machine and then reboot it without the Ethernet cable connected it still shows the same thing in the server dashboard page.  But when I try to log in to WMC it returns the following

 

 

582c495894852_Capture4.jpg

Edited by FTompkins73
Link to comment
Share on other sites

FTompkins73

Any other suggestions?  I had thought that I made a foolish mistake of letting the WMC on my parents machine connect to the server on my machine during the initial set up.  So I did uninstall everything from there machine and reinstalled everything without my machine being on the home network.  Just to be sure there is no confusion for the app on either machine I now make sure that they are never connected to the network at the same time (just to be safe).  IDK maybe something to do with the way the server boots up if there is no network connected? As opposed to it starting up with a network connected and then being removed?  Not sure what the difference is, but it probably has to do with windows settings or such.  Any help would really be appreciated.  Maybe you guys could try replicating as well if you run WMC on the same machine as your server?

Edited by FTompkins73
Link to comment
Share on other sites

When you say you are "unplugging the internet cable" are you actually unplugging a usb network adapter?

 

What it looks like to me is that the machine has no network at all as opposed to just no internet connection.  Our system will not work without a network.

Link to comment
Share on other sites

FTompkins73

Unplugging the cat 5 Ethernet cable from the PC's internal network card.  The PC for my parents is a standalone PC no network...they have no internet at all.  And IT DOES WORK with the manual login, (type the user name and it will log into the server) this is the part I was trying to get around, So that my parents don't have to dig out the keyboard every time and manually log in.  I guess I just don't understand why it won't remember and automatically log in thereafter.

 

Sorry I thought it was established from the beginning when stating that my parents have no internet that they have no network.

 

I in FACT stated "The main dashboard page showed no in home access url since there is no network connected." in my very first post! Just pointing out that I have already given this info.

 

And in my second and fourth post it shows in the dashboard screen capture that there is no local address listed.

 

Sorry just VERY CONFUSED and Frustrated.

Edited by FTompkins73
Link to comment
Share on other sites

DAVe3283

My parents have a similar setup with very limited internet (sub-1Mbps connection). However, I don't see the issue you do. It sounds like you have narrowed it down to the machine booting without a network connection being the root cause.

 

That makes sense, as if there is not network available, Emby for WMC can't bind to an adapter and listen for the broadcast packets. I suspect you could solve this in 2 ways:

  1. Connect to a router, as you suggested. This will give it a network link and an IP address via DHCP.
  2. Install a loopback network adapter, and set it to a static IP address.

Those both will give Emby for WMC an IP address / adapter to bind to, and things will probably work fine. Good luck!

Link to comment
Share on other sites

mediacowboy

Does Emby for WMC not have a remember user option?

 

If it does couldn't you do the manual option setting it to use the loopback address and then login in once with the remember user and be golden?

 

 

 

P.S. I do not run Emby for WMC but I have been reading this as it is something I would love to do in the future.

Edited by mediacowboy
Link to comment
Share on other sites

  • Solution

Install a loopback network adapter, and set it to a static IP address.

 

I think this will be your simplest solution.  Just get some sort of network interface that will allow access via either "localhost" or the loopback IP address.

  • Like 1
Link to comment
Share on other sites

FTompkins73

Ok so that worked.  Installed a loopback plug. Set a static IP. In configure reset the auto find server. Now all is good.  Thanks Guys!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...