Jump to content
Sign in to follow this  
bradford

ANSWERED Transcoding to Shield TV Broken "Unable to write data to the transport connection: The socket has been shut down."

Recommended Posts

bradford

My setup:

 

Running on Debian Jessy under a LXC Container (not docker). It's worked great-ish so far, but now all transcodes to the Shield TV fail. 

 

Direct play still works, and transcoding to the browser works as well (it transcodes using different settings to the browser, which could be significant - that transcode log is attached as ChromeTranscodeLog.txt). 

 

When I attempt to play a video that needs transcoding, it tries 3 times and fails. The error in the log shows 

Error ServiceStackHost: Error occured while Processing Request: Unable to write data to the transport connection: The socket has been shut down.

I recently upgraded my motherboard, as well as Emby server and mono.

 

Attached is the server and transcode logs.

 

I submitted an Android TV report at 1746 Eastern Time (a few minutes ago). 

 

Thank you for any insight you can provide.

ServerLog.txt

TranscodeLog.txt

ChromeTranscodeLog.txt

Share this post


Link to post
Share on other sites
Luke

Everything here looks pretty normal. ffmpeg 3.2 is very new, we haven't tested on that just yet. I guess we would need to see more examples to see if there's anything we can identify.

  • Like 1

Share this post


Link to post
Share on other sites
bradford

Is it a ffmpeg issue then?

Share this post


Link to post
Share on other sites
Luke

I am not sure yet. You said you submitted an Android TV issue report so we'll have to wait and see if @@ebr finds anything there.

Share this post


Link to post
Share on other sites
bradford

You got me thinking. I thought I was using the provided ffmpeg, but after you mentioned that I looked. I was using one provided by apt. I switched back to the provided one and it seems to work now. It's weird that the update would cause the issue - before the update I had no issues. I don't know if it was mono or emby, or maybe something entirely different. 

 

I do have one suggestion - in the transcode screen for emby, it would be nice to have an option under FFmpeg version for "ffmpeg packaged with emby". The custom value had been updated to the apt installed version, and in order to change it back to the packaged version of ffmpeg I had to track it down.

 

So this issue is resolved-ish. I may be back to open it up since I plan on compiling my own ffmpeg and if it's a new version of ffmpeg to blame, this issue will come back. 

 

Thanks for your help!

Share this post


Link to post
Share on other sites
Luke

Thanks for reporting back, we'll look into that. Thanks.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...