Jump to content

Taming Transcoding -- What Worked For Me


Ecurb
 Share

Recommended Posts

Lately it seems that Emby (Version 3.0.7200.0), which always seemed fragile and unreliable to me, has suddenly become rock solid (I hope I don't jinx it).  Transcoding on the web client was always a problem because my homeserver is a dual core atom with 2gb memory running whs2011.  Playing direct is  fine, but if it has to transcode then I max out the cpu and it is game over.  Things I learned while tweaking Emby to finally work as expected:

 

1. Turn off "Allow video playback that requires transcoding" under each user

2. Leave on  "Allow audio playback that requires transcoding" under each user

 

Before I did this Emby would transcode my windows home server recordings (720p, AC3) when I played them remotely on my laptop and it maxed out the server cpu and the playback was awful.  When I turned off "Allow playback that requires transcoding" suddenly Emby would happily direct play the recordings but I had lost audio.  Allowing transcoding, but only for audio, still resulted in direct play for video and gave me back audio with no appreciable impact on the cpu.  I believe the bottom line was that the AC3 was causing the transcoding (my laptop only has stereo) but it transcoded everything and not just the audio. 

 

Now Emby plays nicely on every device I have as well as remotely (Emby connect) without loading the homeserver. Very cool.

 

Now if I can get the DVR integration going as well (NPVR with Ceton InfiniTV 4 tuners) I might finally have a Windows Media Center replacement.

 

 

 

 

 

 

  • Like 2
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...