Jump to content

Permissions: Emby drives not accessible on Windows client


teiva
 Share

Go to solution Solved by teiva,

Recommended Posts

Ubuntu Server 16.04.1


SAMBA version 2: 4.3.11


Windows 10 client (Bash/Putty)


Emby 3.0.8100.0


Docker 1.12.2


 


"Movies" folder has been added to Emby library but cannot get access from Windows client.


"Test" folder Emby cannot locate but I have access from Windows client


 


What I've tried so far...


1. Matching workgroups between ubuntu server and windows client


2. Added automount into fstab


3. Turned off smb2/3 on windows client


4. Created a SAMBA user to match the user logged in on Windows client


 


What I haven't tried...


1. Matching folder/file perms to emby user/group >> default emby user and emby group was not found and I have no idea where to look within docker to get the emby config for users and groups


 


----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------


 


$ ls -l /media/Movies


-rwxrwxrwx 1 windowsuser docker      28089 Oct 14 12:14 Warcraft.2016.1080p.BluRay.x264.AC3-BUYMORE-Obfuscated.nfo

 

$ ls -l /samba/Test

-rwxr--r-- 1 nobody nogroup 3191 Oct 14 03:11 sambaPerm.txt

 

----------------------------------------------------------------------------------------------------------------------------------

smb.conf

 

[global]

  workgroup = WORKGROUP

  server string = Samba Server %v

  netbios name = ubuntu

  disable netbios = yes

  smb ports = 445

  security = user

  map to guest = bad user

  dns proxy = no

  passdb backend = smbpasswd

  preferred master = yes

  printing = cups

  printcap name = cups

  printcap cache time = 750

  cups options = raw

  usershare allow guests = Yes

  usershare max shares = 100

  usershare owner only = false

  wins support = no

  name resolve order = bcast host lmhosts

 

 

#============================ Share Definitions ==============================

 

[Test]

  path = /samba/test

  browsable =yes

  writable = yes

  guest ok = yes

  read only = no

  force user = nobody

 

[Movies]

  comment = Movies and videos for kids

  path = /media/Movies

  browseable = yes

  writable = yes

  read only = no

  guest ok = yes

  available = yes

  valid users = windowsuser,windowsuser2

  public = yes

 

Link to comment
Share on other sites

  • Solution

http://www.krizna.com/ubuntu/setup-file-server-ubuntu-14-04-samba/

 

Side Notes:

My windows user that I'm logging in as belongs to my designated group for the folder permissions on Ubuntu. It was a weird process since windows 10 usernames are emails. I had to force a bad name for Ubuntu to take the email.

sudo adduser --force-badname <username@email.com>

 

In addition directories containing spaces will not work with this setup. "TV Shows" vs "TV".

Edited by teivalp
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...