Jump to content

Emby for Kodi missing dependencies


Diedrich
 Share

Recommended Posts

Emby for Kodi 2.2.45

Kodi 16.1

 

After deleting the addon and deleting all emby addon folders in Kodi I attempted a reinstall of the Beta addon. I kept getting dependency missing errors. They were:

folder.gifplugin.video.emby.movies/ 2016-08-02 19:52 -
folder.gifplugin.video.emby.musicvideos/ 2016-08-02 19:52 -
folder.gifplugin.video.emby.tvshows/ 2016-08-02 19:52

 

After manually installing them from zip from http://embydata.com/downloads/addons/xbmb3c/kodi-beta-repo/ I was able to install 2.2.45 beta. Just thought I should let you know. 

Edited by dvgmar
  • Like 1
Link to comment
Share on other sites

The dependencies only exists within our repositories. So to install the emby for kodi addon the first time, you need to install the repo, then install emby for kodi from it, and Kodi will automatically install the dependencies.

 

 

Sent from my iPhone using Tapatalk

Link to comment
Share on other sites

The reason for doing what I did was because I was not able to update to the latest beta. I updated the repo to v.5 but that didn't help so I removed all repos and all traces of Emby add-on. When re-installing the beta v.5 repo I then got the dependencies error while trying to install the Emby add-on.

Link to comment
Share on other sites

Interesting... How did you update? The issue was that previous repo had broken links (emby updated their hosting link a while back) which is why you needed to first uninstall the repo, then install the new version. I can't reproduce this, maybe Kodi had cached the old links somewhere and it was conflicting, when you tried to install the add-on?

 

When reporting stuff like that, it's best to provide your Kodi log with Kodi debugging enabled so we can see what actually happened. Otherwise it's all speculation and nothing really gets resolved. ;)

Link to comment
Share on other sites

I had the same problem today with my new Intel NUC6i3 box

 

- installed LibreElec v7.90.007 ALPHA to get Kodi-17-beta3

- added source for kodi.emby.media

- installed the beta repository (1.05)

- install Emby video addon from Emby Beta Repository and get dependency error

 

Any advice?

 

Link to comment
Share on other sites

Yeah. Provide your Kodi log when attempting to install, as I can't reproduce it. I have done what you have done and didn't get any errors. Sounds to me like a Kodi problem more than anything else.

 

When reporting stuff like that, it's best to provide your Kodi log with Kodi debugging enabled so we can see what actually happened. Otherwise it's all speculation and nothing really gets resolved. ;)

Edited by Angelblue05
Link to comment
Share on other sites

here is a snippet from the log file... not sure how to upload the entire zip of the logs

 

11:46:00 T:139867321251584   ERROR: CAddonInstallJob[script.hdhomerun.view]: failed to install dependency script.module.requests
11:46:18 T:139867321251584   ERROR: CAddonInstallJob[plugin.video.emby.movies]: failed to install dependency script.module.requests
11:46:18 T:139867321251584   ERROR: CAddonInstallJob[plugin.video.emby]: failed to install dependency plugin.video.emby.movies
11:46:29 T:139867212211968   ERROR: CAddonInstallJob[plugin.video.emby.movies]: failed to install dependency script.module.requests
11:46:37 T:139867212211968   ERROR: CAddonInstallJob[plugin.video.emby.tvshows]: failed to install dependency script.module.requests
11:46:48 T:139866926991104   ERROR: CAddonInstallJob[plugin.video.emby.movies]: failed to install dependency script.module.requests
11:46:48 T:139866926991104   ERROR: CAddonInstallJob[plugin.video.emby]: failed to install dependency plugin.video.emby.movies
 
 
 
Who provides the "script.module.requests" addon?
  • Like 1
Link to comment
Share on other sites

You need to enable Kodi debug. Otherwise it doesn't give any information as to where it's looking. Thanks :)

 

And script.module.requests exists in both the Kodi default repository, and ours.

 

Sent from my iPhone using Tapatalk

Edited by Angelblue05
Link to comment
Share on other sites

Try uninstalling the emby repository and reinstalling it again. Worked for me when I had a dependency error

Link to comment
Share on other sites

Ok, there should not be any issues installing the add-on from repository. If you experience the issue, please post your Kodi log, with Kodi debugging enabled (under settings > system > debugging), and try to install from the repository again to capture the error.

 

Thank you, otherwise I can't fix the situation if other users also experience the same issue as you in the future.

Edited by Angelblue05
Link to comment
Share on other sites

@ - Thanks for the info in the first post.  I've been trying to get this to work right for 2 days now.  That was exactly the info I needed.

  • Like 1
Link to comment
Share on other sites

I'm still looking into why it's doing this. It's complaining script module requests is missing, yet it's in the Emby repository (as well as the Kodi repository)...

 

Edit: Ok, I managed to reproduce this.

Edited by Angelblue05
  • Like 1
Link to comment
Share on other sites

Alright, I finally managed to resolve this. 

 

To fix it, go to your settings > add-ons > Check for updates (side bar), then try to install the add-on. The dependencies needed a version bump for xbmc,python since the version used is no longer compatible with Krypton.

  • Like 1
Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...