Jump to content

Problem with Home Video/Photos subfolders


DancingMan
 Share

Go to solution Solved by DancingMan,

Recommended Posts

DancingMan

Let me start by saying I'm not at home, so I can't provide screen shots right now. :)

 

I'm running Emby beta 3.1.159.

 

 

I have a HomeVideo/Photo library named PicsVids.  The folder structure is:

Library PicsVids

Folder Year 1

Folder Event 1

Folder Event 2

......

Folder Year 2

Folder Event 1

Folder Event 2

......

Folder Year 3

Folder Event 1

Folder Event 2

......

Folder Year 4

Folder Event 1

Folder Event 2

......

 

Inside each year, there are subfolders for different events (Christmas, Halloween, a concert, etc.), and some of the years also have miscellaneous pictures & videos that don't fit into any particular event.

 

Here's the issue: if any folder has only 1 video in it (but multiple pictures and subfolders), clicking on that folder just opens that video's details page.  For example: If Year 2 Event 2 has 1 video and 20 pictures, when I click on the Year 2 Event 2 folder it only goes to that video's details page.  Or if Year 4 has 1 video, 30 pictures, and 10 event subfolders, when I click on the Year 4 folder it just opens the details page for that 1 video... none of the other content in that folder is reachable.  If there are no videos or multiple videos in a folder, then that folder opens as you would expect to show the next level.

Edited by DancingMan
Link to comment
Share on other sites

  • 3 weeks later...
  • Solution
DancingMan

I'm currently running 3.1.183.0 beta... the folders here seem to be working now!  Not sure what version fixed it, but it's all good now!  Thanks guys - great job as always!!

Link to comment
Share on other sites

DancingMan

My pleasure!

 

Just noticed one other slight issue:  If I have a folder with one video and a bunch of pictures and/or other folders in it, that one video is listed with the name of the folder.  For example, I have a folder "2015"; inside it are a bunch of folders for events (a friend's birthday, a vacation, a concert, etc) and one video named "Anabelle.mp4".  When I go into the 2015 folder, I see all of the subfolders correctly but that video shows as named "2015".  Also, under "2014" I have a folder named "Josh Groban Concert" with a bunch of pictures and a video "20140820_203346.mp4"; but when I go into the "Josh Groban Concert" folder that one video shows as named "Josh Groban Concert".

Edited by DancingMan
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...