Jump to content

When jumping while jump is in progress, jumps relative to 0:00


FordGT90Concept
 Share

Go to solution Solved by ebr,

Recommended Posts

FordGT90Concept

I started a recording, let it play until a commercial started, then hit the right D-pad 4 times to make it jump past the commercial. What did it do? 0:00 + 1 jump forward. Identifying this problem, I then tried playing it from a ways in and jumped back twice. What did it do? 0:00 - 1 jump backwards = 0:00

 

Somehow, when jumping mid-jump, it loses context of where it is at. Jumping mid-jump either needs to be disallowed or it needs to keep track of the jumps and get the stream to the right point.

 

The media streamed was 1080i to a Leelbox Amlogic chip on Emby for Android TV. The audio is being down-mixed (because issues if direct). It takes several seconds between pushing the button and it actually getting there so there is ample time for this bug to occur.

Link to comment
Share on other sites

Any seeking in a transcoded stream requires us to start a whole new transcode.  However, I'm able to still make this happen quite fast on my Shield and NP.

 

The program already tries to keep you from doing what you are doing but, since it basically has to start the whole thing over again, there may still be some window for this to occur.  I'll see if it can be tightened up at all.

Link to comment
Share on other sites

FordGT90Concept

It's fixed in the beta! I verified jumping forward and backwards. It now correctly moves as many times as you push it without falling back to 0:00! :D

Edited by FordGT90Concept
  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...