Jump to content

Moving files to new storage location


Monchypa
 Share

Recommended Posts

Hi,

New to posting in the forums, and have done my best to try to find an answer somewhere but cant find any information how to solve my problem.

 

I have used the automatic organizating feature to give my media the correct names and to store them in an ordered fahion.

 

 

I use emby server running on a windows 10 PC

I used to store all media on a NAS on my network, but as the storage space ran out, and since i also needed to upgrade the NAS to be a bit faster i invested in a new NAS and decided to move parts of my data to the new location.

 

I moved all data concerning TV to the new NAS - 192.168.1.3- from the old NAS 192.168.1.2

 

After changing the library to reflect the new NAS i find all data reachable from my apps without any problems.

 

But... when adding a new epiosode of a show to the watch directory i find that the auto organize feature recognizes the show, but cannot find the path for the show (in this case 192.168.1.2 - ie the old NAS). I then try to click the small folder icon to try to tell Emby to change the path to the new NAS, but that does not work.

The response i then get is:

The following file will be moved from:

 

\\192.168.1.3\sources\Queen.of.the.South.S01E01

to:

 

\\192.168.1.2\tv\Queen of the South (2016)\Season 1\Queen of the South - 1x1

Are you sure you wish to proceed?

 

 

So I assume the information about the target is stored with the series, in an XML file, but i have no idea where this might be.

I did remove all smart matches, but that did not help.

 

Any suggestions as to what could be done to change the storage path would be greatly appreciated.

 

 

- Also - thank you for a brilliant app - its perfect for both me and my family.

 

/Lasse

Edited by Monchypa
Link to comment
Share on other sites

  • 1 year later...

My library was moved from /volume4 to /volume6 and everything works fine, but auto organize still somehow points to the old location and because it does not exist anymore fails with "access denied".

2017-11-14 20:45:44.767 Info HttpServer: HTTP POST http://192.168.0.22:8096/emby/Library/FileOrganizations/...../Episode/Organize. UserAgent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:56.0) Gecko/20100101 Firefox/56.0
2017-11-14 20:45:44.798 Info App: Sorting file /volume2/autoorganizefolder/abcd-x264-106.mkv into series /volume4/series/Some Series
2017-11-14 20:45:44.805 Info App: Sorting file /volume2/autoorganizefolder/abcd-x264-106.mkv to new path /volume4/series/Some Series/Season 01/S01E06 - Sometitle.mkv
2017-11-14 20:45:44.834 Warn App: Access to the path "/volume4/series" is denied.
2017-11-14 20:45:44.836 Error HttpServer: Error processing request
	*** Error Report ***
	Version: 3.2.36.0
	Command line: /var/packages/EmbyServer/target/server/MediaBrowser.Server.Mono.exe -package synology -programdata /var/packages/EmbyServer/target/var -ffmpeg /var/packages/EmbyServer/target/ffmpeg/bin/ffmpeg -ffprobe /var/packages/EmbyServer/target/ffmpeg/bin/ffprobe -restartpath /var/packages/EmbyServer/scripts/restart
	Operating system: Unix 3.10.35.0
	64-Bit OS: True
	64-Bit Process: True
	User Interactive: False
	Mono: 5.2.0.224 (tarball Thu Sep 21 19:34:24 CST 2017)
	Processor count: 8
	Program data path: /var/packages/EmbyServer/target/var
	Application directory: /volume1/@appstore/EmbyServer/releases/v3.2.36.0
	System.Exception: Access to the path "/volume4/series" is denied.
	  at Emby.AutoOrganize.Core.FileOrganizationService+<PerformEpisodeOrganization>d__31.MoveNext () [0x000bc] in <8572b145ecc545d8806f27f93948fd6f>:0 
	System.Exception
	  at Emby.AutoOrganize.Core.FileOrganizationService+<PerformEpisodeOrganization>d__31.MoveNext () [0x000bc] in <8572b145ecc545d8806f27f93948fd6f>:0 

EDIT:

I also tried using the "Smart Matchs" tab to remove the series, and retried, but still the same problem.

Edited by n00b42
Link to comment
Share on other sites

Right now this is a known issue. It's happening due to old database entries hanging around. We need to improve our database cleanup and then that will resolve this. Thanks.

  • Like 1
Link to comment
Share on other sites

  • 1 month later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...