Jump to content

Changing audio track when playing over DLNA


WhyNotPurple
 Share

Recommended Posts

WhyNotPurple

I'm having trouble playing video files with a secondary audio track. When streaming the file (so not transcoding), the player will always select the default audio track regardless of other settings (like audio language preference of profile) and I changing the language in the remote has no effect.

 

The playing device is a 2011 Netcast LG TV, and I'm running Emby Server Version 3.0.6070.0 on Windows 10.

 

I found this thread that mentions that this issue is resolved. Am I missing something, or is it that my TV is just too old to support this?

 

I have attached the log file.

 

Also, a very minor issue, something I noticed when trying to find the log file, I am no longer able to select any text of Emby in the browser (using Firefox). It would've been easier to be able to copy paste the path to the log files, but I had to do this via "inspect element". I am able to select everything in the left hand menu, though. Just nothing in the main frame is selectable.

 

Any help would be greatly appreciated, even if it is just a conformation that I'm out of luck ;)

 

EDIT: I forgot to add that I use an edited DLNA profile of the one I found here. In this profile the video audio codecs are included in the "Codecs" section with the condition "AudioChannels" (see screenshot below). I assume this means that Emby should switch to transcoding when trying to switch audio channels, but this is not something I see as an option when adding new codecs manually.

 

uomKTU5.png

20160824_Emby_Log_Exceprt.txt

Edited by WhyNotPurple
Link to comment
Share on other sites

Hi, currently we give preference to the default track. We will be reviewing this behavior for a future release. thanks.

Link to comment
Share on other sites

WhyNotPurple

Ah okay, that explains it!

 

I was confused by the audio language preference in the profile playback settings, assuming that they were there for the reason of making sure the right audio track is selected. Guess I'll try changing the default audio tracks with MKVToolnix. Thanks for the reply!

 

EDIT: changing the default audio track doesn't change anything. It is always the first track that is played, not the default. I would have to recode the file and remove the track... So it is not the default track that is given preference it seems.

Edited by WhyNotPurple
Link to comment
Share on other sites

WhyNotPurple

Well in my case I had a MKV file with both audio in Russian (track 2) and Dutch (track 3). The language preference was set to Dutch. At first the Russian track was set as the default track (and was noted in Emby as such). Playing the file only resulted in Russian audio, and there was no way of switching. I then edited the MKV to make Dutch the default track. Emby recognized this in the data show via the browser interface. But again, playing the file only resulted in Russian audio. For a third try I edited the MKV to set the Russian audio as "disable", but this again made no difference. Thus I don't see any reason to assume that the language preference or default track had any effect. I assume that it is my TV directly playing the file and only using the first track that it finds. I didn't test this with any other files, however.

Edited by WhyNotPurple
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...