Jump to content

Can't See or Edit Metadata


MarcusJ
 Share

Recommended Posts

I've recently had issues getting emby to correctly handle collections. A suggestion was offered to delete the problematic collection folders in Emby-Server/data/collections.  I did that and it seemed to work fine. It was a GREAT start to my day. Huge thanks to all of the folks that jumped in to help out!

 

Since then I have gone through the movie and collection libraries and continued the process of manually assigning movies to collections (I had stopped this process because of the challenges I was having). I was able to successfully add some new collections today, while others showed the same symptoms as other movies had shown in the past when I was having the original problem.  I treated these new problem collections the same way (deleted the named collection folders in Emby-Server/data/collections.  After deleting several of them, I then re-scanned the entire library to allow emby to rebuild the folders correctly, which it seemed to be doing correctly. I did this multiple times - each time deleting 5-10 collection folders in Emby-Server/data/collections that were not functioning properly when attempting to add them to collections. 

 

The scans seemed to go very well - MUCH faster than prior scans - I mean like a drop from 8 hour scans over the last few days down to 20 minutes or less.  I was encouraged by the fast scan times as I thought the system was cleaned up and functioning more efficiently.

 

However, after the last couple scans when I have tried to open any of the metadata, nothing happens.  For example, when I try to "Edit Info" on a collection or an individual movie while in the "Movies" or "Collections" libraries, it literally does nothing...no metadata pops up, and the screen simply stays on the same page of posters that I was on.  When I try to open ANY metadata thru the Metadata Manager, I simply get the colorful spinning circle forever.  No metadata ever opens.  I've tried opening metadata for Collections and for individual movies while in the Metadata Manager and it behaves the exact same way - spinning circle of wait...No metadata ever appears.

 

I have re-started the emby server multiple times, and have re-started my computer 3 times. I have re-scanned the libraries multiple times and have done two "Clean Database" functions.  None of this has helped.  The scans each time get faster.  The last one was 8 mins. but the inability to see or edit metadata is the same...not happening.

 

I am 99% certain this is not a bug of any kind.  This is in my mind, a case of user-inflicted damage caused by my deleting files and making changes on the fly to emby-server folders to fix other issues.  This has now somehow bitten me by confusing the server or getting elements out of sync with one another.

 

I'm now at a stopping point as the core functionality of emby (for my needs) is not functional.

 

Before I throw in the towel, is there anything I can do to refresh my system and potentially get it back on track?  I hate to throw away 4+ months of nearly dedicated time getting this library in good working order, only to get here...Beyond frustrated...

Link to comment
Share on other sites

Luke, thank you for your offer to help. I am attaching the log file as requested.  I started the process at 8:52 pm local time.  Here's what I did during the logging:

  1. Dashboard>Logs>Enable Debug Logging (I hope that's what you wanted)
  2. Clicked on Home
  3. Clicked on Collections
  4. Right-clicked on the "Bourne" collection
  5. Clicked on Edit Info - Nothing happened...
  6. Thru the menu I selected "Movies"
  7. While in the "Suggestions" area, I right-clicked on the latest movie that I added which is actually "The Mummy", but because of the way I named it ("Mummy 1, The") emby mis-identified it as "The Mummy at 19" or something similar to that. After right-clicking the movie poster, I selected "Edit Info".  Again, nothing happened.
  8. Thru the menu, I opened the Metadata Manager
  9. Then I clicked on "Collections"
  10. Then I right-clicked on the "Bourne" collection, and the spinning circle of wait started.  I waited about 10-15 secs before continuing.
  11. Hit the Refresh button in the browser
  12. Once the Metadata Manager opened again, I selected "Movies"
  13. Then I scrolled to the movie "Blade" and clicked on it, and the spinning circle of wait started.  I waited about 10-15 secs before continuing.
  14. Hit the Refresh button in the browser
  15. Once the Metadata Manager opened again, I selected "Entertainers"
  16. Then I selected "Across the Universe",and the spinning circle of wait started.  I waited about quite a few minutes this time before continuing.
  17. Hit the Refresh button in the browser
  18. Once the Metadata Manager opened again, I selected "Photos"
  19. Then I scrolled down and clicked on "Brandon's Senior Pictures", and then selected the specific photo called "Brandon 1",and the spinning circle of wait started.  I waited about 10-15 secs before continuing
  20. Hit the Refresh button in the browser
  21. Thru the menu, I selected "Manage Server"
  22. Then I scrolled down and clicked on "Scheduled Tasks"
  23. Then I started a new library scan which ran in 4 mins and 50 secs

I hope there's a smoking gun in the log file somewhere, but I am losing hope.  You've been great by providing so much help to me. I feel bad that I've so many problems...

 

Log.txt

Link to comment
Share on other sites

Is it possible you moved some things around but did not reconfigure your library paths in server setup?

2016-08-22 18:31:30.2073 Error LibraryMonitor: Error watching path: \\JohnsonNAS\video\Home Videos\Pagosa Springs - Emandee
	*** Error Report ***
	Version: 3.0.6070.0
	Command line: C:\Users\Mark\AppData\Roaming\Emby-Server\System\MediaBrowser.ServerApplication.exe
	Operating system: Microsoft Windows NT 6.2.9200.0
	Processor count: 8
	64-Bit OS: True
	64-Bit Process: True
	Program data path: C:\Users\Mark\AppData\Roaming\Emby-Server
	Application Path: C:\Users\Mark\AppData\Roaming\Emby-Server\System\MediaBrowser.ServerApplication.exe
	The directory name \\JohnsonNAS\video\Home Videos\Pagosa Springs - Emandee is invalid.
	System.ArgumentException
	   at System.IO.FileSystemWatcher..ctor(String path, String filter)
	   at MediaBrowser.Server.Implementations.IO.LibraryMonitor.<>c__DisplayClass13.<StartWatchingPath>b__12()

Perhaps this is why your library scans are running really fast.

  • Like 1
Link to comment
Share on other sites

Once you've cleared the path situation, can you please remove your installed plugins, then restart the server and run a library scan? thanks.

  • Like 1
Link to comment
Share on other sites

Holy Shiite!  I must have!  I just found the entire "Home Videos" folder accidentally moved. No idea how that happened...I feel like a fool...

Link to comment
Share on other sites

By "remove your installed plugins" do you mean for me to uninstall them?  One of them is "Emby for kodi Sync Queue". Will that cause a problem?

Link to comment
Share on other sites

Since you sound like you're having major problems I think it is best to just run with the core server, and then add plugins back later.

  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...