Jump to content

Sorting Collections in Movie view


Raven
 Share

Go to solution Solved by Happy2Play,

Recommended Posts

Sorry if this has been asked before (I've searched) but I've noticed over the last half dozen releases or so, sorting of Collections seems to have changed.  It seems movie Collections now appear before all single movies in the Movie view.  Is there any way to sort Collections in amongst the Movies (eg, in alpha order) rather than aggregating all the Collections before the single movies?

 

(side note, jumping to a letter in the Movie list also displays Collections first.  Eg, jump to 'F', all Collections [F-Z] are first, then all single movies beginning with 'F').

 

Eg,

Current view:

Anchorman Collection (Collection)

Avengers Collection (Collection)

Ace Ventura: Pet Detective (single movie)

Adjustment Bureau, The (single movie)

Antz (single movie)

 

 

Preferred view:

Ace Ventura: Pet Detective (single movie)

Adjustment Bureau, The (single movie)

Anchorman Collection (Collection)

Antz (single movie)

Avengers (Collection)

 

Current Emby version:  3.0.6070.0

Auto-boxset plugin

Collections view - off  (but makes no difference to sorting if on)

Link to comment
Share on other sites

lepitismak

Library > Display > disable the option to group libraries in boxed sets

Edited by lepitismak
Link to comment
Share on other sites

 

 

 It seems movie Collections now appear before all single movies in the Movie view.

 

I will test this out, they should be mixed within the movies like you say. @@Happy2Play do you see this? thanks.

  • Like 1
Link to comment
Share on other sites

Library > Display > disable the option to group libraries in boxed sets

 

This stops Collections altogether which is not what I want.  I still want movies grouped in Collections (box sets) but I want them sorted with all other movies, not before them all.  Luke has got it   :)

 

Quick update:  just noticed, Emby Theatre (v2.5.8) displays correctly but the web and Android clients don't.

Edited by Raven
Link to comment
Share on other sites

Happy2Play

Can you provide a screenshot of the issue?

 

Everything looks fine to me.

 

57b7d803c9613_collection.jpg

Link to comment
Share on other sites

What should I be looking for? The Sort title appears to be blank in each Collection - should it have the Collection name? If so, shouldn't this be filled in by emby by default?

Link to comment
Share on other sites

Happy2Play

Luke was talking about the A-Z sort button at the top of the screen, what is it set to (Name/Ascending)?

Link to comment
Share on other sites

Yep, sort by Name, Ascending.  I tried sorting by by something else (eg, Release date, Rating, etc) and it changed the sort order of individual movies but didn't at all affect the Collections.  They were still displayed before everything else and sorted by alpha.

 

I've tried turning Collections off and on, and have run Auto-Box sets numerous times.  I did have one corrupted Collection but I deleted it in and let emby recreate it and the xml looks fine.  I don't think this ultimately had anything to do with this sorting issue as it existed before and after that corrupted Collection.

Edited by Raven
Link to comment
Share on other sites

Happy2Play

And as Luke ask is there anything in the "sort title" field in the metadata manager for the collection or per movie?

Link to comment
Share on other sites

Each Collection has sort by Release date but changing that to Sort Name makes no difference.  Individual Movies are sorted by Title.  Currently, Collections have nothing in the Sort Title field but filling this in with the Collection name makes no difference.

 

Interestingly, the Metadata Manager displays the list of Movies/Collections sorted correctly...

Edited by Raven
Link to comment
Share on other sites

Happy2Play

Hmm, can you one of the collection.xml that you are having an issue with.

Link to comment
Share on other sites

Happy2Play

What client was your screenshot in post 6 from?  Not seeing any issues, and can't reproduce in stable, beta or dev.  Only thing I can think of is posting a clean server log with you navigating to movies to see if someone can see anything in the log to show the filtering of collections first.

 

Restarting your server will generate a new log.

Link to comment
Share on other sites

Screenshot was from the web client.

 

Just as an experiment, I manually deleted all the Collections from the data/Collections folder (saved them to a backup location just in case) and ran a Scan Library task to recreate all the Collections.  Same outcome - Collections sorted before individual movies.

 

Server restarted, navigated from Dashboard to Home to Movies.  Log attached.

 

Thanks for all your help so far   :)

server-63607375397.txt

Link to comment
Share on other sites

Happy2Play

To me it looks like you are sorting by Date Created not Name

 

h.t.t.p://localhost:8096/emby/Users/0b359b9a9e6f42008a2c3bf7a069df37/Items?SortBy=IsFolder,SortName&SortOrder=Ascending&Fields=DateCreated,PrimaryImageAspectRatio,MediaSourceCount&ImageTypeLimit=1&EnableImageTypes=Primary,Backdrop,Banner,Thumb 

 

Here is what I get

 

h.t.t.p://whs2011-home:8096/emby/Users/06d517a29e044718816b34ce7f76c674/Items?SortBy=SortName&SortOrder=Ascending&IncludeItemTypes=Movie&Recursive=true&Fields=PrimaryImageAspectRatio,MediaSourceCount,SortName,BasicSyncInfo&ImageTypeLimit=1&EnableImageTypes=Primary,Backdrop,Banner,Thumb

Edited by Happy2Play
Link to comment
Share on other sites

Happy2Play

When you refresh that page do you get a log entry like mine?  Only other thing I can think of is does it appear correct in another browser or clearing your browser history.

Link to comment
Share on other sites

if you create a new collection manually and add a movie to it, does that collection get sorted properly?

Link to comment
Share on other sites

When you refresh that page do you get a log entry like mine?  Only other thing I can think of is does it appear correct in another browser or clearing your browser history.

Nope, still shows for example:

http://192.168.178.57:8096/emby/Users/0b359b9a9e6f42008a2c3bf7a069df37/Items?SortBy=IsFolder,SortName&SortOrder=Ascending&Fields=DateCreated,PrimaryImageAspectRatio,MediaSourceCount&ImageTypeLimit=1&EnableImageTypes=Primary,Backdrop,Banner,Thumb&StartIndex=0&Limit=100&ParentId=c8ca023cdbb96c78e4de5fcb477df512.

Tried Opera and IE and same display - Collections first, then movies.  Does the "SortBy=IsFolder" cause any issues here?  

 

if you create a new collection manually and add a movie to it, does that collection get sorted properly?

Just tried.  Created a new Collection named "temp collection".  Added two completely unrelated movies (3 Amigos and The A-Team).  Entered the Sort Title as "temp collection" and Display Order as "Sort Title".  Outcome = still sorted in the Collections group and not mixed into the movies group.

Edited by Raven
Link to comment
Share on other sites

can you expand your earlier provided screenshot to provide the entire browser window? thanks.

Link to comment
Share on other sites

Happy2Play

I will have to test some more, looking closer that is a "Unset/Mixed" content library correct?  Also I added Folder view and get the "SortBy=IsFolder" so don't worry about that.

 

I will setup a "Unset" library and see if I see what you do.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...