Jump to content

Emby Server crash within every hour


Praefervidus
 Share

Recommended Posts

Praefervidus

Hello,

 

I used the last version of Emby and it was working well. Then I updated to the new version. Since this update, I have only problems, such as:

- Maximumly the server works for one hour and then crash, though I don't do any work on it, nor scan new libraries. the crash comes with a long text page, indicating that many files are opened.

- Sometimes, though I do "save" my updates within a movie/song/TV Show, the server does not save them.

- When I click on "movies", it shows a circle of colours and then crashes.

 

When the server crashes, I cannot open it again. I have to restart the mac. This is really bad.

 

After that I read many threads and decided to delete the new version and install the old one. So I went through the following steps:

- Delete "emby.server.mac.app" from the Application.

When I looked for a folder called: "config" I did not find one, nor I found the folder "mediabrowser".

- Then I installed the older version was working. I was really surprised that the media folders and movies were there on the web page. it seems that there is a database hidden.

 

The older version is showing the same problems as above.

 

How can I uninstall clean, including the database?

 

 

Thanks in advance for your cooperation.

Edited by Praefervidus
Link to comment
Share on other sites

Praefervidus

Hello,

 

down you see what happens after scanning a library finished and I tried to access the library:

-------------

 

Response Status Error Code IOException Message Too many open files Stack Trace [GetDashboardResource: 7/22/2016 7:47:36 AM]: [REQUEST: {ResourceName:login.html}] System.IO.IOException: Too many open files at System.IO.FileStream..ctor (System.String path, FileMode mode, FileAccess access, FileShare share, Int32 bufferSize, Boolean anonymous, FileOptions options) <0x53d3750 + 0x006f7> in <filename unknown>:0 at System.IO.FileStream..ctor (System.String path, FileMode mode, FileAccess access, FileShare share, Int32 bufferSize, FileOptions options, System.String msgPath, Boolean bFromProxy, Boolean useLongPath, Boolean checkHost) <0xd2b88b8 + 0x00043> in <filename unknown>:0 at (wrapper remoting-invoke-with-check) System.IO.FileStream:.ctor (string,System.IO.FileMode,System.IO.FileAccess,System.IO.FileShare,int,System.IO.FileOptions,string,bool,bool,bool) at System.IO.StreamReader..ctor (System.String path, System.Text.Encoding encoding, Boolean detectEncodingFromByteOrderMarks, Int32 bufferSize, Boolean checkHost) <0xd2b8610 + 0x000db> in <filename unknown>:0 at System.IO.StreamReader..ctor (System.String path, System.Text.Encoding encoding, Boolean detectEncodingFromByteOrderMarks, Int32 bufferSize) <0xd2b85c8 + 0x00037> in <filename unknown>:0 at System.IO.StreamReader..ctor (System.String path, Boolean detectEncodingFromByteOrderMarks) <0xd2b8578 + 0x0003b> in <filename unknown>:0 at System.IO.StreamReader..ctor (System.String path) <0xd2b8548 + 0x0001f> in <filename unknown>:0 at (wrapper remoting-invoke-with-check) System.IO.StreamReader:.ctor (string) at System.IO.File.ReadAllText (System.String path) <0x14be0880 + 0x0002f> in <filename unknown>:0 at MediaBrowser.WebDashboard.Api.PackageCreator+<ModifyHtml>c__async3.MoveNext () <0x15fac2e8 + 0x004cb> in <filename unknown>:0 --- End of stack trace from previous location where exception was thrown --- at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw () <0x17dff3c0 + 0x0002b> in <filename unknown>:0 at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess (System.Threading.Tasks.Task task) <0x17dff1d0 + 0x000bb> in <filename unknown>:0 at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification (System.Threading.Tasks.Task task) <0x17dff130 + 0x00083> in <filename unknown>:0 at System.Runtime.CompilerServices.TaskAwaiter.ValidateEnd (System.Threading.Tasks.Task task) <0xd2b5fe0 + 0x00033> in <filename unknown>:0 at System.Runtime.CompilerServices.ConfiguredTaskAwaitable`1+ConfiguredTaskAwaiter[TResult].GetResult () <0xd2df3c0 + 0x00017> in <filename unknown>:0 at MediaBrowser.WebDashboard.Api.PackageCreator+<GetResource>c__async0.MoveNext () <0x15f97168 + 0x003db> in <filename unknown>:0 --- End of stack trace from previous location where exception was thrown --- at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw () <0x17dff3c0 + 0x0002b> in <filename unknown>:0 at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess (System.Threading.Tasks.Task task) <0x17dff1d0 + 0x000bb> in <filename unknown>:0 at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification (System.Threading.Tasks.Task task) <0x17dff130 + 0x00083> in <filename unknown>:0 at System.Runtime.CompilerServices.TaskAwaiter.ValidateEnd (System.Threading.Tasks.Task task) <0xd2b5fe0 + 0x00033> in <filename unknown>:0 at System.Runtime.CompilerServices.ConfiguredTaskAwaitable`1+ConfiguredTaskAwaiter[TResult].GetResult () <0xd2df3c0 + 0x00017> in <filename unknown>:0 at MediaBrowser.Server.Implementations.HttpServer.HttpResultFactory+<GetStaticResult>c__async1.MoveNext () <0x15f94bc0 + 0x0073f> in <filename unknown>:0 --- End of stack trace from previous location where exception was thrown --- at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw () <0x17dff3c0 + 0x0002b> in <filename unknown>:0 at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess (System.Threading.Tasks.Task task) <0x17dff1d0 + 0x000bb> in <filename unknown>:0 at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification (System.Threading.Tasks.Task task) <0x17dff130 + 0x00083> in <filename unknown>:0 at System.Runtime.CompilerServices.TaskAwaiter.ValidateEnd (System.Threading.Tasks.Task task) <0xd2b5fe0 + 0x00033> in <filename unknown>:0 at System.Runtime.CompilerServices.ConfiguredTaskAwaitable`1+ConfiguredTaskAwaiter[TResult].GetResult () <0xd2df3c0 + 0x00017> in <filename unknown>:0 at MediaBrowser.Server.Implementations.HttpServer.HttpResultFactory+<GetStaticResult>c__async0.MoveNext () <0x15f90100 + 0x00587> in <filename unknown>:0 --- End of stack trace from previous location where exception was thrown --- at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw () <0x17dff3c0 + 0x0002b> in <filename unknown>:0 at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess (System.Threading.Tasks.Task task) <0x17dff1d0 + 0x000bb> in <filename unknown>:0 at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification (System.Threading.Tasks.Task task) <0x17dff130 + 0x00083> in <filename unknown>:0 at System.Runtime.CompilerServices.TaskAwaiter.ValidateEnd (System.Threading.Tasks.Task task) <0xd2b5fe0 + 0x00033> in <filename unknown>:0 at System.Runtime.CompilerServices.ConfiguredTaskAwaitable`1+ConfiguredTaskAwaiter[TResult].GetResult () <0xd2df3c0 + 0x00017> in <filename unknown>:0 at MediaBrowser.WebDashboard.Api.DashboardService+<Get>c__async0.MoveNext () <0x15f8ca50 + 0x00aeb> in <filename unknown>:0  Errors
Link to comment
Share on other sites

Praefervidus

Hello,

 

I just installed the version you mentioned above keeping the "emby-server" folder.

I added a new library and the scan started automatically. I noticed the scanning on "dashboard". The scan percent went to "72.1%" then changed to "67.2" then the scan ended.

 

When I wanted to see the new library content by clicking first on "Home". The page started loading "coloured circles" and hanged on.

After 5 minutes where nothing happened, I refreshed the page. When I did this, a log-on screen appeared. When I clicked on "log-on", the following error message showed up:

-----

"Connection Failure

 

We're unable to connect to the selected server right now. Please ensure it is running and try again."

-----

 

Now I could not log-on the server.

I clicked then on emby icon "browse library", a blank screen showed up with not contents.

 

I waited another five minutes and tried again. The app crashed.

 

I started the app again and I found the following error in notifications:

---

Scan media library failed.

11 minutes ago
unknown error No transaction is active on this connection
----
 
Another thing I noticed, though I have in movie file the complete metadata, the actor did not appear at all in section "people". So it seems that emby server does not read the movie metadata. Correct?
Link to comment
Share on other sites

Hi, can you startup the server, and grab the last couple emby server logs, under server dashboard -> logs .Then attach them here? thanks.

Link to comment
Share on other sites

I am getting essentially the same error.  I get to my TV section then I get tons of these:

 

2016-07-25 17:45:07.0769 Error App: Error in ffprobe
*** Error Report ***
Version: 3.0.6000.0
Command line: /Applications/Emby.Server.Mac.app/Contents/MonoBundle/Emby.Server.Mac.exe
Operating system: Unix 14.5.0.0
Processor count: 8
64-Bit OS: False
64-Bit Process: False
Program data path: /Users/<user>/.config/emby-server
Mono: 4.4.1 (mono-4.4.0-branch-c7sr0/4747417)
Application Path: /Applications/Emby.Server.Mac.app/Contents/MonoBundle/Emby.Server.Mac.exe
Too many open files
System.IO.IOException
 at System.Diagnostics.Process.CreatePipe (System.IntPtr& read, System.IntPtr& write, Boolean writeDirection) <0x158c5c60 + 0x0018f> in <filename unknown>:0 
 at System.Diagnostics.Process.Start_noshell (System.Diagnostics.ProcessStartInfo startInfo, System.Diagnostics.Process process) <0x158c4ed8 + 0x0021b> in <filename unknown>:0 
--- End of stack trace from previous location where exception was thrown ---
 at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw () <0x189852b8 + 0x0002b> in <filename unknown>:0 
 at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess (System.Threading.Tasks.Task task) <0x189850c8 + 0x000bb> in <filename unknown>:0 
 at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification (System.Threading.Tasks.Task task) <0x18985028 + 0x00083> in <filename unknown>:0 
 at System.Runtime.CompilerServices.TaskAwaiter.ValidateEnd (System.Threading.Tasks.Task task) <0xb466d60 + 0x00033> in <filename unknown>:0 
 at System.Runtime.CompilerServices.ConfiguredTaskAwaitable`1+ConfiguredTaskAwaiter[TResult].GetResult () <0xb9e41a0 + 0x00017> in <filename unknown>:0 
 at MediaBrowser.Providers.MediaInfo.FFProbeVideoInfo+<GetMediaInfo>c__async1.MoveNext () <0x188b02e0 + 0x00513> in <filename unknown>:0 
--- End of stack trace from previous location where exception was thrown ---
 at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw () <0x189852b8 + 0x0002b> in <filename unknown>:0 
 at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess (System.Threading.Tasks.Task task) <0x189850c8 + 0x000bb> in <filename unknown>:0 
 at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification (System.Threading.Tasks.Task task) <0x18985028 + 0x00083> in <filename unknown>:0 
 at System.Runtime.CompilerServices.TaskAwaiter.ValidateEnd (System.Threading.Tasks.Task task) <0xb466d60 + 0x00033> in <filename unknown>:0 
 at System.Runtime.CompilerServices.ConfiguredTaskAwaitable`1+ConfiguredTaskAwaiter[TResult].GetResult () <0xb9e41a0 + 0x00017> in <filename unknown>:0 
 at MediaBrowser.Providers.MediaInfo.FFProbeVideoInfo+<ProbeVideo>c__async0`1[T].MoveNext () <0x188af080 + 0x0095b> in <filename unknown>:0 
--- End of stack trace from previous location where exception was thrown ---
 at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw () <0x189852b8 + 0x0002b> in <filename unknown>:0 
 at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess (System.Threading.Tasks.Task task) <0x189850c8 + 0x000bb> in <filename unknown>:0 
 at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification (System.Threading.Tasks.Task task) <0x18985028 + 0x00083> in <filename unknown>:0 
 at System.Runtime.CompilerServices.TaskAwaiter.ValidateEnd (System.Threading.Tasks.Task task) <0xb466d60 + 0x00033> in <filename unknown>:0 
 at System.Runtime.CompilerServices.ConfiguredTaskAwaitable`1+ConfiguredTaskAwaiter[TResult].GetResult () <0x15abb4a0 + 0x00013> in <filename unknown>:0 
 at MediaBrowser.Providers.Manager.MetadataService`2+<RunCustomProvider>c__async7[TItemType,TIdType].MoveNext () <0x188ae3e8 + 0x0026b> in <filename unknown>:0 
 
 
I just installed the version Luke linked to and still the same problem.  MB becomes unresponsive and I finally have to kill it. Funny note; If I remove my TV section all works fine...
 
I start the server, go to library, then start the scan. It gets to about 72% then becomes unresponsive.
 
Thanks for any help. :-)

server-63605066386.txt

Edited by El Gordito
Link to comment
Share on other sites

Don't know if this related yet, but my QNAP Emby server is now stoping/locking up every morning.  I just recently upgraded to 3.0.5985.0. from 3.0.5930.0.

 

 Looks like I got to about 67% on the library scan before it failed/stopped. 

 

I get a bunch of these:

 

2016-07-27 09:53:37.3206 Error HttpClient: Error getting response from https://api.themoviedb.org/3/tv/17404/season/23?api_key=f6bd687ffa63cd282b6ff2c6877f2669&append_to_response=images,keywords,external_ids,credits,videos&language=en&include_image_language=en,null

*** Error Report ***

Version: 3.0.5985.0

Command line: /share/MD0_DATA/.qpkg/Emby/Emby/MediaBrowser.Server.Mono.exe

Operating system: Unix 3.4.6.0

Processor count: 4

64-Bit OS: False

64-Bit Process: False

Program data path: /share/MD0_DATA/.qpkg/Emby/Emby/ProgramData-Server

Mono: 4.2.1 (Stable 4.2.1.102/6dd2d0d Sat Nov 21 10:02:10 EST 2015)

Application Path: /share/MD0_DATA/.qpkg/Emby/Emby/MediaBrowser.Server.Mono.exe

One or more errors occurred.

System.AggregateException

  at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw () <0xecb1f9a0 + 0x0002b> in <filename unknown>:0 

  at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess (System.Threading.Tasks.Task task) <0xecb1f7b8 + 0x000bb> in <filename unknown>:0 

  at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification (System.Threading.Tasks.Task task) <0xecb1f720 + 0x0007f> in <filename unknown>:0 

  at System.Runtime.CompilerServices.TaskAwaiter.ValidateEnd (System.Threading.Tasks.Task task) <0xf440a358 + 0x00033> in <filename unknown>:0 

  at System.Runtime.CompilerServices.ConfiguredTaskAwaitable`1+ConfiguredTaskAwaiter[TResult].GetResult () <0xf3969280 + 0x00017> in <filename unknown>:0 

  at MediaBrowser.Common.Implementations.HttpClientManager.HttpClientManager+<SendAsyncInternal>d__1d.MoveNext () <0xf0a3d380 + 0x010ff> in <filename unknown>:0 

InnerException: System.Net.WebException

The remote server returned an error: (404) Not Found.

  at System.Net.HttpWebRequest.EndGetResponse (IAsyncResult asyncResult) <0xf07738e8 + 0x00187> in <filename unknown>:0 

  at System.Threading.Tasks.TaskFactory`1[TResult].FromAsyncCoreLogic (IAsyncResult iar, System.Func`2 endFunction, System.Action`1 endAction, System.Threading.Tasks.Task`1 promise, Boolean requiresSynchronization) <0xf07735b0 + 0x0005c> in <filename unknown>:0 

Link to comment
Share on other sites

Don't know if this related yet, but my QNAP Emby server is now stoping/locking up every morning.  I just recently upgraded to 3.0.5985.0. from 3.0.5930.0.

 

 Looks like I got to about 67% on the library scan before it failed/stopped. 

 

I get a bunch of these:

 

2016-07-27 09:53:37.3206 Error HttpClient: Error getting response from https://api.themoviedb.org/3/tv/17404/season/23?api_key=f6bd687ffa63cd282b6ff2c6877f2669&append_to_response=images,keywords,external_ids,credits,videos&language=en&include_image_language=en,null

*** Error Report ***

Version: 3.0.5985.0

Command line: /share/MD0_DATA/.qpkg/Emby/Emby/MediaBrowser.Server.Mono.exe

Operating system: Unix 3.4.6.0

Processor count: 4

64-Bit OS: False

64-Bit Process: False

Program data path: /share/MD0_DATA/.qpkg/Emby/Emby/ProgramData-Server

Mono: 4.2.1 (Stable 4.2.1.102/6dd2d0d Sat Nov 21 10:02:10 EST 2015)

Application Path: /share/MD0_DATA/.qpkg/Emby/Emby/MediaBrowser.Server.Mono.exe

One or more errors occurred.

System.AggregateException

  at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw () in :0 

  at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess (System.Threading.Tasks.Task task) in :0 

  at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification (System.Threading.Tasks.Task task) in :0 

  at System.Runtime.CompilerServices.TaskAwaiter.ValidateEnd (System.Threading.Tasks.Task task) in :0 

  at System.Runtime.CompilerServices.ConfiguredTaskAwaitable`1+ConfiguredTaskAwaiter[TResult].GetResult () in :0 

  at MediaBrowser.Common.Implementations.HttpClientManager.HttpClientManager+d__1d.MoveNext () in :0 

InnerException: System.Net.WebException

The remote server returned an error: (404) Not Found.

  at System.Net.HttpWebRequest.EndGetResponse (IAsyncResult asyncResult) in :0 

  at System.Threading.Tasks.TaskFactory`1[TResult].FromAsyncCoreLogic (IAsyncResult iar, System.Func`2 endFunction, System.Action`1 endAction, System.Threading.Tasks.Task`1 promise, Boolean requiresSynchronization) in :0 

 

I think 3.0.6000 should have been posted for QNAP by now. I would try that. The error you're displaying here is harmless, so if your problem persists, then please open a new topic with a full description and complete log file. thanks!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...