Jump to content

Why are Studio Logos Getting Coverart Film Treatment


rickster53
 Share

Go to solution Solved by ebr,

Recommended Posts

All of my studio icons are getting a Film treatment from CoverArt.  (see attachment)  I am running with server Version 3.0.5115.35703 and CoverArt 4.0.4.8.

 

Since all the studio logos are thumb.jpg, and since there is no separate treatment for Studios, I made sure the CoverArt treatment for thumbs is "IGNORE", which is my preference, and confirmed the setting in the CoverArt.xml file.  I followed that with a manual library refresh but not joy.  The Film treatment remains.  Please advise. Thanks!

 

 

Studio Treatment.pdf

CoverArt.xml

Link to comment
Share on other sites

Cheesegeezer

I think its to do with the thumb.jpg that coverart looks for, once found in an item, it uses the thumb treatment.

Link to comment
Share on other sites

I think its to do with the thumb.jpg that coverart looks for, once found in an item, it uses the thumb treatment.

...but my thumb treatment is set to "IGNORE" so it shouldn't be applying anything

Link to comment
Share on other sites

Hmmm... was it set to Film before?

 

Can you find the server log where they were first treated by CA?

Link to comment
Share on other sites

Hmmm... was it set to Film before?

 

Can you find the server log where they were first treated by CA?

I'm pretty sure the default setting was Film and I changed it to Ignore, but that didn't change the rendering of studios.  And the "Ignore Images from IBN..."  was also checked.   So in trying to reproduce this and get you a log, I removed the plugin, exited the server, deleted the CoverArt folder under Plugins, and deleted the CoverArt.xml file under Configurations.  Then I restarted the server and reinstalled the plugin without changing any settings, leaving everything at the installation defaults.  That meant Thumbs defaults to Film and when I checked the studios they had the Film treatment, which was expected.  I then changed the thumb setting to Ignore and did a manual scan of the library.  This time they changed back to no treatment.  Not sure what happened before but it seems OK now...

Link to comment
Share on other sites

Ebr, I played around with this some more and uncovered the following...  After doing what I mentioned in the prior post, I unchecked "Ignore Images from IBN..." and the studio icons reverted back to having the Film treatment again, even though the specified treatment for thumbs is "Ignore"..  And, putting the checkmark back on and refreshing the library does nothing, leaving the Film treatment on the studio icons...  I attached the log.

 

https://dl.dropboxusercontent.com/u/45569607/server-63524781034.log

Link to comment
Share on other sites

Just FYI refreshing the library has no impact on images.  I know it did in MB2 but that is not how it works anymore.

 

Is it any different in any of the clients other than the web client?

Link to comment
Share on other sites

I have MB Classic/Chocolate. All "Show" settings for Chocolate are set but am not seeing any Studio logos getting displayed at all. Am I missing a setting somewhere for them to display?

Link to comment
Share on other sites

You would need to index a folder by Studio.

 

I have removed the studio logo display from the detail screen in chocolate because I'm cleaning that theme up to look more modern and have a little less glitz and chrome. 

Link to comment
Share on other sites

when I indexed my Bluray folder, all I get are folder images/outlines with the studio name in each outline--no logos. An index on People displays fine. Could it be that studios are thumb.jpg, unlike People that are folder.jpg?

Edited by rickster53
Link to comment
Share on other sites

Apparently, Studios (thumbs.jpg) are not being displayed. Indexing by Actors, Genres or Directors (folder.jpg) display just fine. Actors & Directors also display with their CoverArt treatment

Link to comment
Share on other sites

I know the MBC views use primary images for just about everything.  I just thought we were also providing primary (folder.jpg) images with our new image sets instead of just thumbs.

Link to comment
Share on other sites

OK... I can reproduce this at will with the following scenario.  If I check the option "Use Original Art Aspect Ratio"  the studios are displayed with the Film treatment, even if Thumbs were configured to "Ignore".  If I uncheck "Use Original Art Aspect Ratio" the Film treatment is removed and it goes back to the proper Ignore setting.  Hope this helps...

Link to comment
Share on other sites

OK... I can reproduce this at will with the following scenario.  If I check the option "Use Original Art Aspect Ratio"  the studios are displayed with the Film treatment, even if Thumbs were configured to "Ignore".  If I uncheck "Use Original Art Aspect Ratio" the Film treatment is removed and it goes back to the proper Ignore setting.  Hope this helps...

Ebr,  Are you able to reproduce this issue given the scenario I discovered and posted...?

Link to comment
Share on other sites

Ebr,  Are you able to reproduce this issue given the scenario I discovered and posted...?

 

I have not had time yet.  I suspect you are looking at cached items that are not getting re-built.  A workaround would be to shut down your server and delete everything from the enhanced-images folder in your server cache folder.  Then re-start and let all your CA images re-build.  Be sure you have the treatment you want selected before you do this.

Link to comment
Share on other sites

Thanks for the workaround suggestion but it did not work. This is a minor issue, so if there's something else you'd like me to try I'd be more than happy to do that. Otherwise, I'll just wait till you have any opportunity to look into this yourself.

Link to comment
Share on other sites

Do you happen to have the server log for when you went through this process but it didn't work?  Need the log from when you first brought them up to view them in the client.

Link to comment
Share on other sites

I just saw your last post and since I wasn't sure which log was appropriate I decided to reestablish a baseline and recreate the situation:

 

So I decided to uninstall CoverArt and then verified by observation that it removed all the treatments. I then reinstalled CoverArt leaving all the default settings. As expected, the default Film treatment was applied to the studio icons. I changed the thumb setting to Ignore and reinspected the studio icons. The Film treatment remained. I double checked the configuration file to make sure it said Ignore for thumbs--it did. I exited the server and deleted the enhanced-images folder as you suggested. I did not change any settings leaving all the defaults except for thumbs which was still set to Ignore. I restarted the server and checked the studio icons. No change---the Film treatment persisted AND the enhanced-images folder was not regenerated. The attached log is from the point of restarting the server after the enhanced-images folder was deleted.

server-63525034628.log

Edited by rickster53
Link to comment
Share on other sites

Okay, if the enhanced-images folder wasn't re-created then that means CA didn't run which means they are getting pulled out of the cache as I had suspected.  Thx.

Link to comment
Share on other sites

Nice work, ebr! That did the trick... Studios displayed without any treatment and showed up under enhanced-images folder.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...