Jump to content

Chromecast not rendering SRT subs correctly


Randomacts
 Share

Recommended Posts

Randomacts

I was going to play some video on my chromecast as I am home for the 4th but it was rendering a black box behind the subs for some reason making it (at least to me) unwatchable. 

 

I know emby theater renders it correctly.

 

It is too late for me to get pictures right now but if nobody is using the TV after I wake up I'll get some pictures.

Link to comment
Share on other sites

Thanks for the report. That's actually the way the chromecast video player renders them.

  • Like 1
Link to comment
Share on other sites

Randomacts

Reminds me of why I tell my brother that we need to get a roku when I move in with him instead of a chromecast.

 

Hopefully you guys can figure out an easy solution for this.. I guess one way would be to burn the subs into the video during the transcode or something so they look correct. 

 

For the few days that I'm here I guess I'll have to plug in my laptop through HDMI to the TV like a caveman =p

Edited by Randomacts
Link to comment
Share on other sites

how are you defining not correct? is it just the presence of the black box? because chromecast is not the only device that does that, there are many that display subtitles like that in fact.

Link to comment
Share on other sites

Randomacts

how are you defining not correct? is it just the presence of the black box? because chromecast is not the only device that does that, there are many that display subtitles like that in fact.

 

I've never seen a video player do that, I mean I do mostly use .ass subs so I don't have much experience with srt subs...  ¯\_(ツ)_/¯

 

If it wasn't so much work to remux I would convert the .srt files for that show to .ass and perhaps add some styling. 

Link to comment
Share on other sites

Chromecast does that, Roku used to do that, pretty much all of the browsers used to do that as well, although gradually many of them are switching to white standalone text with black outline.

Link to comment
Share on other sites

Randomacts

Well I guess 'correct' was a strong word.. but the user experience of a black background isn't ideal obviously. 

Link to comment
Share on other sites

Randomacts

I wish I would have been able to report this before but I've been busy and was hoping to be able to test it more...

 

But anyways .ass subs seem to be doing the same thing only worse on the chromecast.. it is putting the line placement and other info in it as well so it is a bunch of gibberish and completely unwatchable.

 

I can't actually test it right now as I don't have a chromecast... but I figured I should at least report the issue.

Edited by Randomacts
Link to comment
Share on other sites

The new server release is going to just burn in ass/ssa subs now so that shouldn't happen anymore.

Link to comment
Share on other sites

Randomacts

The new server release is going to just burn in ass/ssa subs now so that shouldn't happen anymore.

 

 

I assume that is going to only be done for players that don't support the subs, right?

 

Emby Theater shouldn't need to have subs burned in.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...