Jump to content


Photo

Clearing all live tv metadata/EPG/cached data?

tvheadend

  • Please log in to reply
3 replies to this topic

#1 gstuartj OFFLINE  

gstuartj

    Advanced Member

  • Members
  • 133 posts
  • Local time: 11:30 AM

Posted 29 June 2016 - 12:02 PM

Hi all,

 

I had to rebuild my TVHeadend VM and am trying to get LiveTV working again. The problem I'm having is that Emby seems to use all the old channel data, and I can't get it to reliably refresh things like the channel name and icon after updating it in TVHeadend.

 

I have tried deleting all channels from TVHeadend and doing a refresh, and I have tried deleting metadata/livetv/*, but no dice so far. Every time I reinstall the TVH plugin and do a Guide Refresh I'm stuck with the old channel names and no icons.

 

Is there a query I can run against a DB or something, or am I looking in the wrong places? How can I make sure all live tv data is cleared so I can ensure I get a fresh lineup? Any ideas, @Tolotos ?

 

Thanks,



#2 gstuartj OFFLINE  

gstuartj

    Advanced Member

  • Members
  • 133 posts
  • Local time: 11:30 AM

Posted 08 July 2016 - 09:33 AM

I found a workaround to get all my channels updated using the TVHeadend plugin and am posting it for future reference. Clearing all channels from TVHeadend and doing a Guide Refresh does not clear the old channel data.

 

Instead, you must delete all channels except for one, then do a Guide Refresh, re-add the missing channels, and refresh again. If you need to update the one remaining channel, do the process again but with that one channel.


Edited by gstuartj, 08 July 2016 - 09:40 AM.


#3 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 139810 posts
  • Local time: 10:30 AM

Posted 08 July 2016 - 12:12 PM

Yea unfortunately that might be true because users can customize those things within emby server after the import, so we don't want to blow away those changes.



#4 Doofus ONLINE  

Doofus

    Advanced Member

  • Members
  • 12553 posts
  • Local time: 07:30 AM

Posted 08 July 2016 - 03:51 PM

I had an issue with my guide data, too. Though I'm using HDHR. To completely rebuild the guide, I had to remove the data source (schedules direct), that started a guide refresh which wiped the data. I then added schedules direct, another scan occurred, and all data was regenerated.





Also tagged with one or more of these keywords: tvheadend

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users