Jump to content
Sign in to follow this  
TheShryke

Raspberry Pi 3 (Raspbian Jessie) Won't Play MKV files

Recommended Posts

TheShryke

Hello,
 
I set up my Emby server on my desktop PC and it was all running perfectly, I've recently moved to using a Raspberry Pi 3 using the guide in the second post on this page:
 
http://emby.media/community/index.php?/topic/27026-raspberry-pi/page-8
 
It all works fine, except no MKV file will play, I'm pretty sure this has something to do with ffmpeg, but I have checked that it is in the location that guide used.
 
Any tips?
 
 
EDIT:
 
The error I get is a white box pops up saying  Video Error: There was an error playing the video.

 

I am accessing the server from a Windows 10 machine using Chrome, I don't think this has any effect as I have an identical server set up on this machine and the files play fine, and similar behaviour is shown when accessing the server from Android devices through Chrome.

 

The error also occurs for .avi files

 

I have attached the server log and a remux? log.

remux_log.txt

server_log.txt

Edited by TheShryke

Share this post


Link to post
Share on other sites
TheShryke

Thank you, I have updated my post

Share this post


Link to post
Share on other sites
Luke

We are trying to encode to mp3 which your version of ffmpeg does not support. I am updating the server to handle this better and use something else that your ffmpeg build supports. The change will be up on the beta channel later today. You can either wait for that, or update/recompile your ffmpeg to include libmp3lame.

Share this post


Link to post
Share on other sites
TheShryke

Thank you for the advice, I have moved to the beta channel, I'll see if this update fixes the issue, can you tell me what version number this will be? just so I can check I'm on the right one

Share this post


Link to post
Share on other sites
TheShryke

Hello again, sorry for the double post, but I noticed that I did not manage to update. On my server dashboard it says:

 

Version 3.0.5973.0

A new version of Emby Server is available!

Version 3.1.41 is now available for download.

 
I've followed the link from the last line (Going to Debian 8.0), and that just installs version 3.0.5973.0 again. How should I update to version 3.1.41?
 
 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...