Jump to content

Banner resize causes Emby for WMC to freeze


Go to solution Solved by ebr,

Recommended Posts

seanbuff

Hi All,

 

Have run into an issue while configuring my TV Series view with Banners. It has been running flawlessly with banners for the longest time, however I just wanted to increase the size of them so as to improve the view (not so many rows)

 

I have found that after I changed the size of them, Emby locked up and I had to close down WMC completely. Now everytime I select 'TV Shows' Emby completely freezes and I have to kill it. Normally when entering a view it will select an item to navigate, now it just stays there nothing selected.

 

5756521cece8b_banner_view.jpg

 

The clock doesn't move, so I know it's frozen.

Does anyone know how to reset user views? Poster, banner, strip, etc?

 

I have already tried uninstalling / deleting config from dir / re-install

 

Running server: 3.1.11.0

Running EMC: 3.0.305.0

 

log of when change was made:

MBClassic-6620164438fab00dc14af2ac98fe20d8bed9d5.log

 

log when a new session is opened and navigate to tv shows, pretty much nothing:

MBClassic-762016fe97bf136bc44e728f702dcf486a2898.log

 

 

If anyone can help me reset this view that would be great. Every other media category works fine.

 

Link to post
Share on other sites
throgmorton

Poster size should be stored in the cache from my knowledge, I'm unsure if uninstalling removes the data in the cache.

 

I believe the Emby server stores that in a specific directory which you can probably see from the server interface menu. If you delete that directory I believe it may reset the poster size to defaults.

 

 

Sent from my iPhone using Tapatalk

Link to post
Share on other sites
seanbuff

Is there anything in your Windows Event Log when it freezes up?

hi ebr, nope there is nothing in the Event Log.

 

to be clear, WMC is not frozen as I can hit the green button to get back to its main menu and still navigate that no problem. However if I try start Emby from there it simply puts me back to that frozen view.

Link to post
Share on other sites

Honestly, I'm not sure how to get past this other than drastic measures that would cause you to lose all display prefs.

 

If you log in as a different user, its still okay, right?

 

What has happened is you've hit an old bug in the WMC display engine.  I thought we had this blocked but maybe the banners are a wrinkle we didn't account for.

Link to post
Share on other sites
seanbuff

If you log in as a different user, its still okay, right?

Yup, a different "test" user is fine. But then I reproduced the issue by increasing banners to '450' that's where it locked up.

 

So how drastic is drastic? I don't mind losing all my display prefs again - i can easily live with that. Is that the worst part, or do I stand to lose more?

Link to post
Share on other sites
  • Solution

You will lose display prefs for all apps and all users but that should be it.

 

Shut down the server

Delete data\displaypreferences.db

Restart server

 

And don't make the banners that big again :).

  • Like 1
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...