Jump to content

Chromecast stuck at Ready to Cast


conradfoucher
 Share

Recommended Posts

conradfoucher

Hello,

 

So I've set up emby and it's working fine through the web and through the android app (I can play on both). I can access my server through http://app.emby.media/ ass well as directly through http://<IP_ADDRESS>:8096/ (It's running on a remote server) so I know it's accessible through my home wifi. But I cannot stream anything through my chromecast (all other apps work fine on it). If I start chromecasting something from my android phone (or web browser) it only ever displays the emby logo with "Ready to Cast". No show info or images show up.

 

If I disconnect my phone from the wifi (but leave the chromecast connected to the wifi) then use the cast to nearby chromecast function, the chromecast plays fine. It's my understanding that this features uses the chromecast's connection (I.E not my phone's LTE connection).

I cannot figure out why it works when the casting device is not connected to the wifi, but not when it is, as it is using the same internet connection.

 

Any help would be appreciated.

Link to comment
Share on other sites

conradfoucher

Well for anyone else having the issue, turns out if your Chromecast name contains an emoji Emby cannot play to it.

I removed the TV icon I had in the name and it now works fine.

Link to comment
Share on other sites

Hi, welcome. Thanks for following up and reporting that. I will look into it. I'm surprised that made a difference though between lan and external.

Link to comment
Share on other sites

Since we're only using the receiver name in a couple places, I have an idea where the problem is. I just pushed an update to our Chromecast receiver to hopefully address this.

 

To test the update, add the emoji back, then restart both the CC device and the casting app. Thanks!

Link to comment
Share on other sites

Invert

I`m having a similiar issue, I just set up emby (using the portable server) and tried to cast something from the device where the server is (using the web app) and my android device (using the play one minute button). Chromecast got stuck on the ready to cast screen.

Link to comment
Share on other sites

I`m having a similiar issue, I just set up emby (using the portable server) and tried to cast something from the device where the server is (using the web app) and my android device (using the play one minute button). Chromecast got stuck on the ready to cast screen.

 

Hi, welcome. This means that although your mobile device can connect to your Chromecast, your Chromecast cannot connect to your Emby Server. You'll need to ensure that it's able to do that.

Link to comment
Share on other sites

  • 4 years later...

Hi, I've been trying to make emby work with chromecast for the last couple hours and I finally came across this thread. I had UTF-8 characters in my chromecast name. I didn't think removing them would help but it did! Now it plays without an issue. Thank you @conradfoucher.

Link to comment
Share on other sites

That's great investigation, thanks for that ! We'll get the Chromecast receiver updated to handle that. Thanks !

Link to comment
Share on other sites

Hi there, if you're still seeing this issue, can you please try again? I've just pushed an update to our Chromecast receiver to resolve a similar issue, so it may resolve yours if it's the same thing. Thanks !

Link to comment
Share on other sites

I did try again but nothing changed. Do I need to update anything? I tried to update the emby server but I think it was already up to date.

Link to comment
Share on other sites

27 minutes ago, Vazha said:

I did try again but nothing changed. Do I need to update anything? I tried to update the emby server but I think it was already up to date.

Hi, I thought your issue was solved based on your previous message?

Link to comment
Share on other sites

3 hours ago, Vazha said:

It was, I thought you meant you solved the issue with UTF-8 so I tried again.

Are you saying you changed the name back?

Link to comment
Share on other sites

  • 3 weeks later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...