Jump to content

help needed auto-organize weird results win svr


markbnj
 Share

Recommended Posts

markbnj

Ok.  I've been getting weird results. at one point emby did auto-organize as advertised and even removed the empty directories.

Lately I have been getting (snippet of log file...)  Start here------------------

 

2016-04-10 18:13:57.1328 Info App: Sorting file \\mitch-desk\freshplex\finished-dwnloads-4-emby\Madam Secretary\Madam Secretary.218.hdtv-lol[ettv].mp4
2016-04-10 18:13:57.1818 Debug App: Extracted information from \\mitch-desk\freshplex\finished-dwnloads-4-emby\Madam Secretary\Madam Secretary.218.hdtv-lol[ettv].mp4. Series name Madam Secretary, Season 2, Episode 18
2016-04-10 18:13:59.0009 Info HttpClient: HttpClientManager GET: http://bot.whatismyipaddress.com
2016-04-10 18:14:04.2232 Warn App: Unable to find series in library matching name Madam Secretary
2016-04-10 18:14:04.2472 Info App: Sorting file \\mitch-desk\freshplex\finished-dwnloads-4-emby\Brooklyn.Nine-Nine.S03E20.HDTV.x264-KILLERS[ettv].mp4
2016-04-10 18:14:04.2642 Debug App: Extracted information from \\mitch-desk\freshplex\finished-dwnloads-4-emby\Brooklyn.Nine-Nine.S03E20.HDTV.x264-KILLERS[ettv].mp4. Series name Brooklyn.Nine-Nine, Season 3, Episode 20
2016-04-10 18:14:04.2642 Warn App: Unable to find series in library matching name Brooklyn.Nine-Nine

---end log snippet here.

 

OK.  So I do have directories (Madam Secretary, etc...with Season 01,0x below that).  (image 1)

570ada8b99528_emby01.png

 

and when auto-organize fails, I open the next window, but get a blank line and no ability

to select the series root folder (see pic...)

570adb26c8bdb_emby02.png

where the  series root does not let me enter anything...

and I am connected to the internet when this happens..

 

ideas?  troubleshooting advice?

 

thanks in advance

markb

Link to comment
Share on other sites

the blank line because you don't have any libraries setup with tv as the content type. we will improve this to make it more obvious.

Link to comment
Share on other sites

markbnj

the blank line because you don't have any libraries setup with tv as the content type. we will improve this to make it more obvious.

Ah, I see.  I have been using multi-content.  will adjust and see if it fixes it. thanks

Link to comment
Share on other sites

markbnj

OK I deleted my talk-show directory, and re-created it, using tv, instead of unset.

Did not do anything differently.

Now I kicked off the task for organize new media files, 0 seconds, execution, and no difference.

However, I did see this weird thing in the log.

...snippet...

2016-04-11 18:13:55.4658 Info TaskManager: Executing Organize new media files2016-04-11 18:13:55.4718 Error App: Error getting files from \\mitch-desk\freshplex\finished-dwnloads-4-emby	*** Error Report ***	Version: 3.0.5912.0	Command line: C:\Users\noone\AppData\Roaming\Emby-Server\System\MediaBrowser.ServerApplication.exe	Operating system: Microsoft Windows NT 6.1.7601 Service Pack 1	Processor count: 8	64-Bit OS: True	64-Bit Process: True	Program data path: C:\Users\noone\AppData\Roaming\Emby-Server	Application Path: C:\Users\noone\AppData\Roaming\Emby-Server\System\MediaBrowser.ServerApplication.exe	The network name cannot be found.		System.IO.IOException	   at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)	   at System.IO.FileSystemEnumerableIterator`1.CommonInit()	   at System.IO.FileSystemEnumerableIterator`1..ctor(String path, String originalUserPath, String searchPattern, SearchOption searchOption, SearchResultHandler`1 resultHandler, Boolean checkHost)	   at System.IO.DirectoryInfo.EnumerateFiles(String searchPattern, SearchOption searchOption)	   at CommonIO.ManagedFileSystem.GetFiles(String path, Boolean recursive)	   at MediaBrowser.Server.Implementations.FileOrganization.TvFolderOrganizer.GetFilesToOrganize(String path)	

Well I get the exception errors, but...

C:\Users\noone\AppData\Roaming\Emby-Server\System\MediaBrowser.ServerApplication.exe

does exist. and is there...

Link to comment
Share on other sites

Happy2Play

Well I get the exception errors, but...

C:\Users\noone\AppData\Roaming\Emby-Server\System\MediaBrowser.ServerApplication.exe

does exist. and is there...

The error points to \\mitch-desk\freshplex\finished-dwnloads-4-emby not C:\Users\noone\AppData\Roaming\Emby-Server\System\MediaBrowser.ServerApplication.exe.

Edited by Happy2Play
Link to comment
Share on other sites

  • 2 weeks later...

the blank line because you don't have any libraries setup with tv as the content type. we will improve this to make it more obvious.

 

@Luke: I've already done that. It's contained in PR #1506

Edited by softworkz
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...