Jump to content
glassman

ANSWERED Emby for Kodi plugin: Playback timeout when trying to play movie remotely

Recommended Posts

glassman

Hi there, I'm able to use Emby for Kodi normally when I'm on my LAN, but as soon as I switch off WiFi on my phone, I can't seem to get anything to play. I should mention that I've already selected the option "Play from HTTP instead of SMB" from inside the plugin settings, and that I have port 8096 forwarded correctly on my router.

 

I've attached the log file. The only thing I've done in the log is edited my DDNS hostname from what the no-ip hostname actually was to <hostname>.no-ip.org, for security purposes. Is there anything I'm missing here? I spent the last day trying to figure this out with less than desirable results. Any insight that anyone could provide into this would be greatly appreciated.

 

P.S. - The log entries might look a little strange at the end there as you can see that I'm transferring the log file to a local share, but at that point I had switched WiFi back on solely for that purpose.

kodi.log

Edited by glass.davidjoseph

Share this post


Link to post
Share on other sites
Angelblue05

Can you confirm if you are using playback mode being set to addon (emby for kodi settings > sync option)? Otherwise the play from http does not have any effect.

  • Like 1

Share this post


Link to post
Share on other sites
glassman

Can you confirm if you are using playback mode being set to addon (emby for kodi settings > sync option)? Otherwise the play from http does not have any effect.

 

That's interesting. So apparently I had it set to native. I just switched it to addon, but I can confirm I'm getting the same results.

Share this post


Link to post
Share on other sites
glassman

Yes, that's normal. You will need to resync your library first. Check the settings for more info: https://github.com/MediaBrowser/plugin.video.emby/wiki/Emby-for-Kodi-settings

 

Awesome. That worked. Thank you so much. Being new to this, I guess I thought I needed to use native so that emby would integrate properly into Movies and TV Shows. I thought that by using addon mode, they would only show up as an emby link or something, much the way that plexbmc works.

  • Like 1

Share this post


Link to post
Share on other sites
Angelblue05

Ah, no :) glad it's working now.

 

 

Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites
glassman

One last question. Would the Emby for Kodi Sync Queue plugin help in my specific setup? I was under the impression that all the scanning happened on the server side. Do I have this all wrong?

Share this post


Link to post
Share on other sites
Wheemer

Emby server does the global scanning of your library. However each Kodi instance is keeping a local databse itself. So Kodi also needs to scan, however this scan is a lot faster than normal.

 

Yes that option would be good assuming you have that plugin installed within Emby on your server.

  • Like 1

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...