Jump to content

Specials auto naming same as movie title


lurch9366
 Share

Go to solution Solved by Luke,

Recommended Posts

When ripping a movie from my collection I make sure to name any specials as they are named on the blu-ray and/or blu-ray.com

 

When I place the movie in my collection and scan it rather than naming the specials the same as the file name it names them the same title as the main movie. I than go into emby server and edit each special with the file name. Is there a way to set it to automatically name them the same as the file name?  

Link to comment
Share on other sites

When extras was launched the naming convention was putting all extras in a "specials"  folder. it correctly picks them up in all the apps and displays them as extras it just names them wrong.  I will try naming the folder "extras" on the next movie rip and see if anything changes. If so I will need to go back through all movies in my collection and rename the extras folder.   

Link to comment
Share on other sites

I've seen this issue as well in my setup and realised that some extras had a title metadata set directly in the file. (Usually the name of the movie set automatically by MakeMKV) Removing that made emby directly pick the file name instead...

That worked for me, maybe it's the same for you.

Link to comment
Share on other sites

You assume people do not read the wiki. You come across very condescending and it makes people not want to reach out for help. The goal of these forums is to help and foster this community and find ways to overcome bugs and improve them. Please be aware of this when stating things like you NEED to read the wiki as it is received as hey stupid why don't you do this before posting. Thank for being part of this community Vidman and your input does get the job done.

Link to comment
Share on other sites

I've seen this issue as well in my setup and realised that some extras had a title metadata set directly in the file. (Usually the name of the movie set automatically by MakeMKV) Removing that made emby directly pick the file name instead...

That worked for me, maybe it's the same for you.

Link to comment
Share on other sites

Tv shows uses "/season 0" for specials and will scrape metadata for them

 

Movies uses "/extras" for extra stuff. You can also use "/extras" in Tv too. Using "/extras" wont fetch metadata.

Edited by speechles
Link to comment
Share on other sites

So did you solve the issue?

I changed all my specials folders to extras pr the wiki and it still names them the title of the movie. (Not hard at all using the search feature in windows explorer and tab Ctrl+v) for those that need to do the same thing When looking at the properties details it looks like mkv did embed the movie title into the file title. I will keep an eye on the next rip. Edited by lurch9366
Link to comment
Share on other sites

The embedded title can be removed easily with mkvtoolnix ... you don't even have to remux or anything, just edit in the header editor and save.

I remuxed about 100 extras today using mkvtoolnix. I did not know there was an option to do it without muxing. I will look into this tonight. Thanks!!!

Link to comment
Share on other sites

  • Solution
Luke

the issue is we're pulling the name from embedded metadata which was requested recently, but now we're seeing cases where that's not always desirable. so we might need some options around it.

  • Like 1
Link to comment
Share on other sites

I remuxed about 100 extras today using mkvtoolnix. I did not know there was an option to do it without muxing. I will look into this tonight. Thanks!!!

This is working great. I am able to do many at a time.When done removing the embedded title I then need to rename all "extras" folders to "specials" scan library, name back to "extras" and scan again. for some reason when I scan without changing the folder name emby does not pick up the changes.  

Link to comment
Share on other sites

the issue is we're pulling the name from embedded metadata which was requested recently, but now we're seeing cases where that's not always desirable. so we might need some options around it.

I wold definitely like this option!!

Link to comment
Share on other sites

Well that was fun. After re-scanning we are back to where we started when I name them extras. empy reverts back to previous titles for extras. If I leave them specials it seems to pick them up. Luke would you like me to leave it for now until you change the setting so it does not read the embedded title?  

Link to comment
Share on other sites

I have the same issue on some titles... the old name won't go away... i refresh, i rescan, i ignored the title, cleaned the database, rescan again.... nope... the old title (even though it's not in the file anymore) remains.... so an option to use the file metadata or not is probably a good idea.

 

Or i guess add the file name as the title metadata... ill try that i guess to shake the wrong naming loose.

Edited by MndWrp
  • Like 1
Link to comment
Share on other sites

I have the same issue on some titles... the old name won't go away... i refresh, i rescan, i ignored the title, cleaned the database, rescan again.... nope... the old title (even though it's not in the file anymore) remains.... so an option to use the file metadata or not is probably a good idea.

 

Or i guess add the file name as the title metadata... ill try that i guess to shake the wrong naming loose.

I have both file types in my collection, embedded and no title. It does not seem to make a difference. emby will not pick up the changes.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...