Jump to content

Android Mobile Not Connecting Remotely


DParsons
 Share

Go to solution Solved by Vidman,

Recommended Posts

DParsons

The app is very well done and works perfectly while I'm at home on the same network as my server, but it will not stream remotely. I've tried to create a new server with the same ddns information that I connect remotely to my content with a PC, but it always says "it is not able to connect to the selected server right now please ensure it is running and try again". Should the server settings be the same as my ddns or is there some other method to connect to my home server with the Android mobile app? I'm also connecting via wifi from anywhere I have wifi access.

Link to comment
Share on other sites

DParsons

I can connect the app using chrome on my android with the regular remote access address: http://192.168.1.2:8096. I'm at home now testing it while using the chrome mobile app, and it's working as well, but the regular emby mobile app will also connect while I'm at home. It's just normal http as far as I'm aware although now that you mention https I do use a chrome extension called https everywhere. It's possible that extension may be causing some sort of error since you mentioned https that is the first thing that comes to mind now. If you can let me know if I should be able to connect my emby mobile for android app by creating a new server with my ddns info: http://dspstream.duckdns.org:8096/emby. If that should work then I would say that it must have something to do with the https extension. 

Link to comment
Share on other sites

DParsons

Hello I've disabled the 'https everywhere' addon but it is the same. It just tells me that 'we're unable to connect to the selected server'. I guess that must not be what is happening then.

Link to comment
Share on other sites

Vidman

Why do you have /emby at the end of the duckdns address? Have you followed the connectivity wiki and setup port forwarding to your server? Is your server set to have a static ip?

Edited by Vidman
Link to comment
Share on other sites

DParsons

That is what Emby says the address is under 'remote access'. Everything remote works if I'm accessing Emby from a PC it's only the Android Mobile app that is having an issue connecting remotely. Everything else is fine as far as remote access via a PC is concerned so I would have to say that yes all connectivity setup steps have been taken. I do have a static IP address setup.

Edited by DParsons
Link to comment
Share on other sites

it says that on the server dashboard? is it because you may have configured a custom external address that is possibly not correct?

Link to comment
Share on other sites

  • Solution
Vidman

You need to change that external wan address to just "dspstream.duckdns.org" the rest is added automatically by the server which is why you see the port 8096 twice in the first screenshot

And /emby is not part of the url

Edited by Vidman
  • Like 2
Link to comment
Share on other sites

Yup, he's right. This is good info though. I can have the config page automatically correct this in the future.

Link to comment
Share on other sites

DParsons

Thanks vidman that did the trick. Now I need to renew my premier subscription so I can access the full guide.☺

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...