Jump to content


Photo

Direct Play wierd problem

Direct Play

Best Answer mellomade , 14 March 2016 - 12:56 PM

If W:\ is fully shared - and 'HDMovies2' is located in the root of that drive (and not nested in a folder 'w') then I don't understand how you have this working because the paths would not match.  Is there something I am missing?

 

Maybe try making sure the path name is correctly match case.  Or I would suggest using the IP address to the server rather than the server name.  I have had issues on my systems resolving share names from Windows servers in Linux.

Go to the full post


  • This topic is locked This topic is locked
4 replies to this topic

#1 cvika OFFLINE  

cvika

    Member

  • Members
  • 13 posts
  • Local time: 08:01 PM

Posted 14 March 2016 - 09:52 AM

I install server on Win10, name is MEDIASERVER - local IP 192.168.1.13.

My test library have UNC path - \\Mediaserver\w\HDMovies2.

On other machines install Kodi 16 and latest emby plugin.

 

On machine where is Win10 OS (not server, IP 192.168.1.2) Direct Play working OK, but on Ubuntu not working at all - raise error on initial scan.

 

"Kodi can't locate file W:\HDMovies2\..." (yes/no) - if hit yes, library is visible in Kodi but not working, if hit no - no library at all.

 

My password.xml is same on both machines (Win10 and Ubuntu) (same user, and same password). I test smb share form Ubuntu machine and working ok - create source smb://MEDIASERVER/W/ and I can browse folders and play movies from HDMovies2 folder.

 

I play with path substitution and no luck :(

 

What I can do more (or where I mistake) to enable Direct Play with Ubuntu?

 



#2 mellomade OFFLINE  

mellomade

    Advanced Member

  • Members
  • 465 posts
  • Local time: 02:01 PM
  • LocationHouston, TX

Posted 14 March 2016 - 10:29 AM

If the direct path to your movies is W:\HDMovies2 then your UNC path should be \\MEDIASERVER\HDMovies2 - just remove the \w from your path above.



#3 cvika OFFLINE  

cvika

    Member

  • Members
  • 13 posts
  • Local time: 08:01 PM

Posted 14 March 2016 - 11:27 AM

If the direct path to your movies is W:\HDMovies2 then your UNC path should be \\MEDIASERVER\HDMovies2 - just remove the \w from your path above.

Thank you, I try but not working - path not exist. Again, Kodi on another Win10 machine work OK with \\Mediaserver\w\HDMovies2 path.

 

Edit: W:\ is shared on server machine (and all files and folders on disk)


Edited by cvika, 14 March 2016 - 11:40 AM.


#4 mellomade OFFLINE  

mellomade

    Advanced Member

  • Members
  • 465 posts
  • Local time: 02:01 PM
  • LocationHouston, TX

Posted 14 March 2016 - 12:56 PM   Best Answer

If W:\ is fully shared - and 'HDMovies2' is located in the root of that drive (and not nested in a folder 'w') then I don't understand how you have this working because the paths would not match.  Is there something I am missing?

 

Maybe try making sure the path name is correctly match case.  Or I would suggest using the IP address to the server rather than the server name.  I have had issues on my systems resolving share names from Windows servers in Linux.


  • cvika likes this

#5 cvika OFFLINE  

cvika

    Member

  • Members
  • 13 posts
  • Local time: 08:01 PM

Posted 15 March 2016 - 08:47 AM

IP address work OK - finally :)

 

Now new problem - trakt not working - movies sync OK, shows nothing :(

 

EDIT: After last beta update (Version 3.0.5903.0) working again!


Edited by cvika, 15 March 2016 - 09:09 AM.






Also tagged with one or more of these keywords: Direct Play

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users