Jump to content


Photo
In-Progress

Device sleep, crashing on wake

Kodi Standby Suspend

  • This topic is locked This topic is locked
28 replies to this topic

#1 pünktchen OFFLINE  

pünktchen

    Advanced Member

  • Members
  • 2471 posts
  • Local time: 11:32 AM

Posted 09 March 2016 - 07:36 AM

So here's my scenario:

Kodi on HTPC, Emby on Server

 

I always let the HTPC with running Kodi go to sleep while the Server is still active. The Server itself goes to sleep some minutes after this.

The next time i wake up the HTPC while the Server is still sleeping, i get the known "Library Sync Thread has Exited" error.

Shortly after this i get the notification from the Kodi Emby addon "Server unreachable".

 

Imho this is a simple error in the logic how things are executed.

The addon should first check for successful connection before starting the sync thread.

If the connection is refused, then don't start the sync thread at all.

 

I can attach the logs in the evening if you want some, but maybe my description is enough to find the culprit?!



#2 Angelblue05 OFFLINE  

Angelblue05

    Advanced Member

  • Developers
  • 12738 posts
  • Local time: 03:32 AM

Posted 09 March 2016 - 11:41 AM

Indeed. Thanks for reporting. Looking into it.



#3 Angelblue05 OFFLINE  

Angelblue05

    Advanced Member

  • Developers
  • 12738 posts
  • Local time: 03:32 AM

Posted 09 March 2016 - 11:59 AM

@pünktchen

 

 

Do you mind giving this build a try? Let me know if it resolves this, thanks.

 

Note, you can also get the same build available in Public testing via this method: https://github.com/M...Emby-Repository <---- This makes our lives easier.


Edited by Angelblue05, 13 March 2016 - 05:27 PM.


#4 SwanStream OFFLINE  

SwanStream

    Advanced Member

  • Members
  • 146 posts
  • Local time: 10:32 AM

Posted 09 March 2016 - 03:06 PM

I've seen this as well. And had thought that proposed logic was already in. Since it's new, as a 'feature' to this logic maybe it's useful to have a pop-up letting you know the issue, and ask how quickly you want it retry connection/sync with some default if not responded to? Always nice to know there's an issue, and give me time to resolve the problem before popping up more errors, or alternatively give me no more info if the problem persists. With the sync thread dialog hidden, one can be blissfully uninformed... 



#5 Angelblue05 OFFLINE  

Angelblue05

    Advanced Member

  • Developers
  • 12738 posts
  • Local time: 03:32 AM

Posted 09 March 2016 - 03:14 PM

The logic is already in. However, I think the issue ends up being that the offline marker is not associate with the system going to sleep. That's what I added to the custom build. I'm hoping it will be ok now, but I need it tested.


Sent from my iPhone using Tapatalk

Edited by Angelblue05, 09 March 2016 - 03:15 PM.


#6 pünktchen OFFLINE  

pünktchen

    Advanced Member

  • Members
  • 2471 posts
  • Local time: 11:32 AM

Posted 09 March 2016 - 03:33 PM

I've seen this as well. And had thought that proposed logic was already in. Since it's new, as a 'feature' to this logic maybe it's useful to have a pop-up letting you know the issue, and ask how quickly you want it retry connection/sync with some default if not responded to? Always nice to know there's an issue, and give me time to resolve the problem before popping up more errors, or alternatively give me no more info if the problem persists. With the sync thread dialog hidden, one can be blissfully uninformed...

There's no issue to know about and to resolve, because it's intended by me that the server is still sleeping while waking up the Kodi HTPC. We mostly use the pvr capabilities of Kodi, so it doesn't make sense that the Server would burn energy for nothing. Any dialog with a user interaction in this case is just annoying and irritates the wife.

#7 pünktchen OFFLINE  

pünktchen

    Advanced Member

  • Members
  • 2471 posts
  • Local time: 11:32 AM

Posted 09 March 2016 - 03:34 PM

The logic is already in. However, I think the issue ends up being that the offline marker is not associate with the system going to sleep. That's what I added to the custom build. I'm hoping it will be ok now, but I need it tested.


Sent from my iPhone using Tapatalk

Will have to wait until my wife goes to bed before testing...

#8 pünktchen OFFLINE  

pünktchen

    Advanced Member

  • Members
  • 2471 posts
  • Local time: 11:32 AM

Posted 10 March 2016 - 01:35 PM

Unfortunately i still get the error.
Just as a info if it makes any difference: i don't put the HTPC to sleep from within Kodi, but just let Windows handle the standby.

#9 xnappo OFFLINE  

xnappo

    Advanced Member

  • Developers
  • 4755 posts
  • Local time: 04:32 AM
  • LocationAustin, TX

Posted 10 March 2016 - 03:31 PM

I know not the answer you are looking for, but I have my OpenElec box kill Kodi and restart it upon wake..  You could probably do something like that with Windows, though I don't know how.



#10 Angelblue05 OFFLINE  

Angelblue05

    Advanced Member

  • Developers
  • 12738 posts
  • Local time: 03:32 AM

Posted 10 March 2016 - 03:38 PM

Unfortunately i still get the error.
Just as a info if it makes any difference: i don't put the HTPC to sleep from within Kodi, but just let Windows handle the standby.

It does make a difference.


Sent from my iPhone using Tapatalk

#11 pünktchen OFFLINE  

pünktchen

    Advanced Member

  • Members
  • 2471 posts
  • Local time: 11:32 AM

Posted 10 March 2016 - 03:46 PM

I know not the answer you are looking for, but I have my OpenElec box kill Kodi and restart it upon wake.. You could probably do something like that with Windows, though I don't know how.

I would rather remove the code that displays the error

#12 Angelblue05 OFFLINE  

Angelblue05

    Advanced Member

  • Developers
  • 12738 posts
  • Local time: 03:32 AM

Posted 10 March 2016 - 04:57 PM

Removing the message would not help in any way. Do you have your Kodi log? Can you post it? Thanks. I will try to come up with a solution in the long run, since the issue is that Kodi is not putting the device to sleep.



#13 pünktchen OFFLINE  

pünktchen

    Advanced Member

  • Members
  • 2471 posts
  • Local time: 11:32 AM

Posted 10 March 2016 - 05:49 PM

Removing the message would not help in any way. Do you have your Kodi log? Can you post it? Thanks. I will try to come up with a solution in the long run, since the issue is that Kodi is not putting the device to sleep.

 

Here you go. If you need a log with addon logging enabled, let me know!



#14 Angelblue05 OFFLINE  

Angelblue05

    Advanced Member

  • Developers
  • 12738 posts
  • Local time: 03:32 AM

Posted 10 March 2016 - 05:56 PM

Oops @pünktchen   Please do enable add-on log level set to info, otherwise no relevant info gets captured. Post a new log, thanks! :)



#15 pünktchen OFFLINE  

pünktchen

    Advanced Member

  • Members
  • 2471 posts
  • Local time: 11:32 AM

Posted 12 March 2016 - 10:22 PM

Oops @pünktchen   Please do enable add-on log level set to info, otherwise no relevant info gets captured. Post a new log, thanks! :)

 

I'm really sorry! Here it is.



#16 Angelblue05 OFFLINE  

Angelblue05

    Advanced Member

  • Developers
  • 12738 posts
  • Local time: 03:32 AM

Posted 12 March 2016 - 10:29 PM

... Still no emby add-on log enabled.... Under emby add-on settings > advanced > Log level set to Info. Then repeat the steps to recreate the wake up crash. Sorry about this, but I need as much information about what is happening during this time to come up with a solution.



#17 pünktchen OFFLINE  

pünktchen

    Advanced Member

  • Members
  • 2471 posts
  • Local time: 11:32 AM

Posted 12 March 2016 - 10:41 PM

... Still no emby add-on log enabled.... Under emby add-on settings > advanced > Log level set to Info. Then repeat the steps to recreate the wake up crash. Sorry about this, but I need as much information about what is happening during this time to come up with a solution.

 

It is set to debug!

Damn, i think, i've forgotten my advancedsettings.xml. There's loglevel set to 0 :rolleyes:



#18 Angelblue05 OFFLINE  

Angelblue05

    Advanced Member

  • Developers
  • 12738 posts
  • Local time: 03:32 AM

Posted 12 March 2016 - 10:59 PM

It looks to be set to None according to your previous log. :)


Edited by Angelblue05, 12 March 2016 - 11:05 PM.


#19 pünktchen OFFLINE  

pünktchen

    Advanced Member

  • Members
  • 2471 posts
  • Local time: 11:32 AM

Posted 13 March 2016 - 08:27 AM

And another one :huh:


  • Angelblue05 likes this

#20 Angelblue05 OFFLINE  

Angelblue05

    Advanced Member

  • Developers
  • 12738 posts
  • Local time: 03:32 AM

Posted 13 March 2016 - 05:02 PM

Thanks for the log! I will let you know once I got something for you to test. I think there's a Kodi notification we can use to correct the situation, now that I see it trigger in your log.

 

Oh boy, such a silly mistake. The build I gave you didn't have the fix in it. Instead of clearing the online flag, I was clearing the onWake flag...


Edited by Angelblue05, 13 March 2016 - 05:30 PM.






Also tagged with one or more of these keywords: In-Progress, Kodi, Standby, Suspend

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users