Jump to content

Black screen on video playback


Emaster
 Share

Go to solution Solved by Emaster,

Recommended Posts

As a test, can you go into playback settings and try and set the max bitrate to a low value. i wonder if maybe it's just trying to direct play something that your device can't handle. thanks

Link to comment
Share on other sites

Emaster

It didn't work. I forgot to say (I don't know if it helps) that when I leave the video an image of the video appears just before leaving.

Link to comment
Share on other sites

  • 5 months later...
  • Solution
Emaster

Today I lost some time searching for a solution for this problem and just in case someone steps into the same problem with emby android app video playback (and VLC player too)...

 

The problem: No video, just a black screen except when you change device orientation (landscape to portrait for example), when you exit the playback or when you click settings button, the video appears for a fragment of a second.

Audio and subtitles playing correctly.

Probably this problem only occurs in some devices.with pre kitkat versions.

 

The solution: disable HW overlays in Settings > Developer options (if Developer options don't shows: http://www.androidcentral.com/how-enable-developer-settings-android-42)

 

description of the same problem with this solution (for VLC player) : https://forum.fairphone.com/t/vlc-player-only-shows-black-screen-for-video-playback-on-fp1/19060/7

Link to comment
Share on other sites

  • 2 years later...
FreeBSD_Lover

Today I lost some time searching for a solution for this problem and just in case someone steps into the same problem with emby android app video playback (and VLC player too)...

 

The problem: No video, just a black screen except when you change device orientation (landscape to portrait for example), when you exit the playback or when you click settings button, the video appears for a fragment of a second.

Audio and subtitles playing correctly.

Probably this problem only occurs in some devices.with pre kitkat versions.

 

The solution: disable HW overlays in Settings > Developer options (if Developer options don't shows: http://www.androidcentral.com/how-enable-developer-settings-android-42)

 

description of the same problem with this solution (for VLC player) : https://forum.fairphone.com/t/vlc-player-only-shows-black-screen-for-video-playback-on-fp1/19060/7

 

I have this exact same issue, and "Disable Hardware overlays" does not work on my Samsung Android phone.  Also everytime the phone is rebooted this feature is turned off, meaning hardware overlays are enabled.

 

Are there are other workarounds to this issue?

Link to comment
Share on other sites

FreeBSD_Lover

Sorry Luke,  its a Galaxy Grand Prime. And its my corporate phone so I have to live with it.  If its not worthy your time to support something that old then I'm fine with that.  I could swear video was working on it, but I haven't watch any videos in a long time. Just getting back into it now that I have a new FreeBSD hardware server built with lots of CPU and ram, and a brand new high-gain OTA antenna wired to a HDHomeRun tuner. Sweet sweet set up!  After a few more days of burn in I will do my upgrades which includes the current emby server version.

Edited by FreeBSD_Lover
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...