Jump to content


Photo

Lost all Genres

After one of the latest updat when I go to the metadata ed genre

Best Answer ronvp , 29 December 2013 - 08:42 AM

I found the issue. It repeats each and every time on each movie.  I use mostly MP4 files all complete with full Metadata, including the Genres. When I delete the Genres from the MP4 metadata, it all works perfectly. So somehow, when you have the Genres inside the MP4 metadata, it is pulled by the manual refresh and then it is not parsed causing the Genres to show as a single line. Anyway this can be fixed?

Go to the full post


  • Please log in to reply
58 replies to this topic

#1 ronvp OFFLINE  

ronvp

    Advanced Member

  • Members
  • 483 posts
  • Local time: 01:31 AM

Posted 20 December 2013 - 04:29 PM

After the one of the latest server updates(not sure which one), I lost all of my Genres in the Metadata editor. They are still in the Movie.xml file, just not in the metadata editor..



#2 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 136138 posts
  • Local time: 03:31 AM

Posted 20 December 2013 - 08:37 PM

Is the startup library scan still running?

#3 ronvp OFFLINE  

ronvp

    Advanced Member

  • Members
  • 483 posts
  • Local time: 01:31 AM

Posted 20 December 2013 - 05:39 PM

Is the startup library scan still running?

No, but let me run a manual one



#4 ronvp OFFLINE  

ronvp

    Advanced Member

  • Members
  • 483 posts
  • Local time: 01:31 AM

Posted 20 December 2013 - 05:45 PM

No, but let me run a manual one

Media scan ran pretty quick, still no Genres, I tried a single movie manual refresh, then Genres get wiped out of the movie.xml file



#5 ebr OFFLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 46431 posts
  • Local time: 03:31 AM

Posted 20 December 2013 - 07:06 PM

Post a log from when you do that refresh.



#6 ronvp OFFLINE  

ronvp

    Advanced Member

  • Members
  • 483 posts
  • Local time: 01:31 AM

Posted 20 December 2013 - 09:31 PM

Here is a part of the log, looks like genre cleaner is removing the genres

 

2013-12-20 17:27:43.9648, Debug, ProviderManager, Running MovieGenreCleaner for \\server\\Movies\300 (2006)\300 (2006).mp4
2013-12-20 17:27:43.9648, Info, GenreCleaner, Genre 'Action,Fantasy,War' removed from metadata for 300.



#7 ronvp OFFLINE  

ronvp

    Advanced Member

  • Members
  • 483 posts
  • Local time: 01:31 AM

Posted 20 December 2013 - 09:45 PM

Just did another test, if I use the metadata manager to manually add a Genre, it is added correctly and then with a manual metadata refresh for that same movie it is removed by what appears to be genre manager (see extract from log below). What is strange is that the genres that are listed as "removed" were not there at all. I actually added Genre "3D movie", and I inspected the movie.xml file to confirm it was there. Then when I run a manual refresh, it actually says it removed 'Action & Adventure'. but after the manual refresh, there are no genres whatsoever in the movie.xml file.

 

2013-12-20 17:35:01.4842, Debug, ProviderManager, Running MovieGenreCleaner for \\server\Movies\Avatar (2009) [hsbs]\Avatar (2009) [hsbs].mp4
2013-12-20 17:35:01.4842, Info, GenreCleaner, Genre 'Action & Adventure' removed from metadata for Avatar.



#8 ebr OFFLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 46431 posts
  • Local time: 03:31 AM

Posted 20 December 2013 - 08:12 PM

It sounds to me like you have configured Genre Cleaner to remove most of your genres.

 

Post a screen shot of the configuration page for Genre Cleaner.



#9 ronvp OFFLINE  

ronvp

    Advanced Member

  • Members
  • 483 posts
  • Local time: 01:31 AM

Posted 21 December 2013 - 11:31 AM

EBR, till recently it has been working just fine...and the tool clearly says ".... from any source will be discarded..." it does not say removed or deleted.. Also, if the tool is now removing the genres from the movie XML file, I can not easily alter the mapping and it kinda defeats the purpose..

 

Here is a screen shot..

 

52b5b358b77a9_Untitled.jpg



#10 ebr OFFLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 46431 posts
  • Local time: 03:31 AM

Posted 21 December 2013 - 11:37 AM

Nothing has changed recently with how this plug-in works.  Looking at your setup, it looks like it is working as designed.  If you add a new genre you want to be valid in your metadata, then you are going to have to also tell Genre Cleaner about it.  You can easily add a new allowed genre to the list.  Just hit that Plus button at the top (just like everywhere else in the dashboard).

 

Please let me know if you find it is removing something it shouldn't.

 

discard 
 
 [v. dih-skahrdn. dis-kahrd]  Show IPA
verbs 3 nouns 3
verb (used with object)
1.
to cast aside or dispose of; get rid of:


#11 ronvp OFFLINE  

ronvp

    Advanced Member

  • Members
  • 483 posts
  • Local time: 01:31 AM

Posted 21 December 2013 - 11:46 AM

EBR, something is definitely wrong, I just added several existing Genres (3D Movie, Action, Drama) to a movie and when I click save it is added, and after a refresh they are removed again.. The Genre tool, should really just map and not delete genres, unless they are specifically deleted..



#12 ronvp OFFLINE  

ronvp

    Advanced Member

  • Members
  • 483 posts
  • Local time: 01:31 AM

Posted 21 December 2013 - 11:56 AM

 

Nothing has changed recently with how this plug-in works.  Looking at your setup, it looks like it is working as designed.  If you add a new genre you want to be valid in your metadata, then you are going to have to also tell Genre Cleaner about it.  You can easily add a new allowed genre to the list.  Just hit that Plus button at the top (just like everywhere else in the dashboard).

 

Please let me know if you find it is removing something it shouldn't.

 

discard 
 
 [v. dih-skahrdn. dis-kahrd]  Show IPA
verbs 3 nouns 3
verb (used with object)
1.
to cast aside or dispose of; get rid of:

 

Thanks for the English lesson, have you looked up arrogant!

 

Right now it does not work a designed.. Add any of the listed genres i.e.: "Action" , then click save, select a other movie, inspect the movie.xml. The genre is there, then go back to the movie and hit refresh and the genre is removed.. It happens with any genre.



#13 ebr OFFLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 46431 posts
  • Local time: 03:31 AM

Posted 21 December 2013 - 12:10 PM

Okay, so you added "3D Movie" as a genre in a movie, and that is a genre listed as one to be allowed by Genre Cleaner but it removed it anyway?  Is this what you are saying?

 

If so, please link to or attach an entire server log from that process.  Thanks.



#14 ebr OFFLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 46431 posts
  • Local time: 03:31 AM

Posted 21 December 2013 - 12:12 PM

Oh wait a minute - you have internet metadata enabled?  And you are manually adding something to your metadata and then telling it to force refresh it?

 

If so, then that isn't genre cleaner - that is the normal system.  By doing that, you are asking the system to refresh your metadata from the source.  This will remove any modifications you made, unless you lock them.



#15 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 136138 posts
  • Local time: 03:31 AM

Posted 21 December 2013 - 12:16 PM

yea if you change an xml file manually all you have to do is let the regular scan pick itup



#16 ronvp OFFLINE  

ronvp

    Advanced Member

  • Members
  • 483 posts
  • Local time: 01:31 AM

Posted 23 December 2013 - 09:23 AM

I really did not do anything (except for adding or removing a Genre from just a few movies). al lI did was install the genre cleaner, mapped the genres and it was all good, then after a update, my genres disappeared.

 

So I tried to see what was causing this and added some genres through the Metadata editor and then did a refresh;  I then noticed that any and all genres are removed from the xml file. Including those that are listed in the Genre cleaner. Thus effectively having no Genres at all.

 

Since this appears to be by design, I suggest for the Genre cleaner to disable the genre metadata pulling from the web.

 

I just uninstalled the Genre cleaner and did a refresh and all genres are now pulled correctly from the web. I have disabled the global Genres metadata provider and I will now re-install Genre cleaner and try the mapping again. Is this all I need to do to make it work?



#17 ronvp OFFLINE  

ronvp

    Advanced Member

  • Members
  • 483 posts
  • Local time: 01:31 AM

Posted 23 December 2013 - 09:28 AM

This does not work, I disabled the global metadata provider for Genres and after re-installing the Genre cleaner, all my Genres are disappearing again. Do I need to disable the genre metadata provider for each movie separately?



#18 ronvp OFFLINE  

ronvp

    Advanced Member

  • Members
  • 483 posts
  • Local time: 01:31 AM

Posted 23 December 2013 - 09:30 AM

This does not work, I disabled the global metadata provider for Genres and after re-installing the Genre cleaner, all my Genres are disappearing again. Do I need to disable the genre metadata provider for each movie separately?

Can I reset the Genre tool to force a re-scan without doing any cleaning?



#19 ronvp OFFLINE  

ronvp

    Advanced Member

  • Members
  • 483 posts
  • Local time: 01:31 AM

Posted 23 December 2013 - 04:06 PM

Sorry for keep driving this, but for the genres in general, why does MB show the genres in Groups i.e: If I have a movie that falls within 3 Genres (War, Drama,Politics), Should it not be shown as 3 separate genres?

 

The Genre tool shows the 3 different Genres as a single Genre (War,Drama,Politics). Should it not show the 3 Genres separately?

 

The same is true in the actual clients, you get a bunch of "extra" genres because each the Genres are shown as a group..



#20 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 136138 posts
  • Local time: 03:31 AM

Posted 23 December 2013 - 08:07 PM

because that's how it is in your metadata. 







Also tagged with one or more of these keywords: After one of the latest updat, when I go to the metadata ed, genre

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users