Jump to content

Emby server on Pine64?


EsDeeEm
 Share

Recommended Posts

I have backed the Pine64 Kickstarter and want to deploy it as an Emby server as soon as it arrives. I tried to do it on a Raspberry Pi, but the memory seems to be insufficient to run properly. So I ordered the heaviest Pine they had. It can run Ubuntu Snappy, so I would presume it will run Emby server on that platform. Did I guess right?

Link to comment
Share on other sites

Koleckai Silvestri

I backed it as well. Not for server purposes. I think it will make a decent client with the 2GB model. While I wouldn't use it for a server you can try it. I don't think it will be able to transcode reliably. If none of your content needs transcoding, then it can most likely work. One of the problems with transcoding will be the inherently slow media the OS will be on. SD Cards aren't really performers. The device lacks SATA connections and only USB2 for additional drives. You also might be limited in networking with a single ethernet port.

Edited by Koleckai Silvestri
  • Like 1
Link to comment
Share on other sites

Thanks for the input! Concerning storage I don't have a problem, as all movies are stored on a Syno. On the Pi, it seemed that the indexing was the biggest problem. As good as Emby is, it is still a big memory gulper. Currently the server is running on my windows mediacenter, but takes a huge chunk out of the available memory. That's why I would like to separate it form that.

Link to comment
Share on other sites

hurricanehrndz

I have backed the Pine64 Kickstarter and want to deploy it as an Emby server as soon as it arrives. I tried to do it on a Raspberry Pi, but the memory seems to be insufficient to run properly. So I ordered the heaviest Pine they had. It can run Ubuntu Snappy, so I would presume it will run Emby server on that platform. Did I guess right?

There is no mono for armv8 yet, once there is we will try and build the packages for it.

Link to comment
Share on other sites

  • 2 months later...
curiousgally

There is no mono for armv8 yet, once there is we will try and build the packages for it.

 

Hi i have my pine 64 shipped and currently installed ubuntu on it. I can get started with emby server install if you have the mono ready that I can use.

 

Thanks.

Link to comment
Share on other sites

hurricanehrndz

Then you can install mono from ubuntu's repos if available and download the mono build from github releases. See how it goes and let us know.

Link to comment
Share on other sites

Koleckai Silvestri

Just got charged for my second Pine64 board and few dozen accessories. Hopefully, both of them will be here soon. However, I am not going to attempt to run the server on them. One will have Remix installed on it and I will use it as a client. It wouldn't be powerful enough to replace my Emby Server even with the 2 GB models that I ordered. They certainly wouldn't be able to transcode 4-5 HD videos at a time. The other board is for IOT and smart home control. It will be running OpenHab.

Link to comment
Share on other sites

  • 1 month later...

Has anyone made any progress on this until now?

 

Have you tried the ubuntu package?

Link to comment
Share on other sites

EsDeeEm

I've just bumped into a bug with the eth0 port. Download is virtually impossible at the moment. Trying to fetch the ethtool package to throttle down the ethernet port. After that I can really start experimenting with the packages. Installed the latest Ubuntu build from Longsleep...

Link to comment
Share on other sites

EsDeeEm

It is working!!!

 

At the moment, the server is scanning the shares...

As soon that is done, I will test streaming and transcoding...

 

Here's what I've done:

  1. Install Longsleep Ubuntu 16.04 image (https://www.stdin.xyz/downloads/people/longsleep/pine64-images/ubuntu/)
  2. There is a bug in the distro's core! The ethernet driver seems to have problems with variable speeds. It needs to be forced in 100Mbit with ethtool. I downloaded the deb file and installed it from a USB, as the network connection is virtually unusable.
  3. Run the following ethtool command: sudo ethtool -s eth0 speed 100 autoneg off
  4. installed nano for easy editing (I hate vi!)
  5. Followed the instructions for installing Emby Server and installed the version for xUbuntu 15.10
  6. edited fstab to mount my network shares on my Synology
  7. Started Emby Server, restored my settings with the backup plugin and... PRESTO!
Edited by EsDeeEm
Link to comment
Share on other sites

EsDeeEm

Got it:

Mono JIT compiler version 4.2.1 (Debian 4.2.1.102+dfsg2-7ubuntu4)

Copyright © 2002-2014 Novell, Inc, Xamarin Inc and Contributors. www.mono-project.com

TLS:           __thread

SIGSEGV:       normal

Notifications: epoll

Architecture:  arm64

Disabled:      none

Misc:          softdebug 

LLVM:          supported, not enabled.

GC:            sgen

 

Versie 3.0.5973.0

Emby Server is up-to-date

Edited by EsDeeEm
Link to comment
Share on other sites

I don't know what package for mono but I'd be curious about our server beta package and how that does. thanks.

Link to comment
Share on other sites

  • 3 months later...
curiousgally

I'm trying to install this on my pine64..have this errors.Any help is appreciated.

 

ubuntu@pine64:~$ sudo apt-get install emby-server

Reading package lists... Done

Building dependency tree

Reading state information... Done

Some packages could not be installed. This may mean that you have

requested an impossible situation or if you are using the unstable

distribution that some required packages have not yet been created

or been moved out of Incoming.

The following information may help to resolve the situation:

 

The following packages have unmet dependencies:

emby-server : Depends: mono-runtime (>= 3.0~) but it is not going to be installed

Depends: libmono-corlib4.5-cil (>= 4.0.0~alpha1) but it is not going to be installed

Depends: libmono-microsoft-csharp4.0-cil (>= 1.0) but it is not going to be installed

Depends: libmono-posix4.0-cil (>= 4.0.0~alpha1) but it is not going to be installed

Depends: libmono-system-configuration4.0-cil (>= 4.0.0~alpha1) but it is not going to be installed

Depends: libmono-system-core4.0-cil (>= 4.0.0~alpha1) but it is not going to be installed

Depends: libmono-system-data4.0-cil (>= 4.0.0~alpha1) but it is not going to be installed

Depends: libmono-system-drawing4.0-cil (>= 3.0.6) but it is not going to be installed

Depends: libmono-system-io-compression4.0-cil (>= 3.2.1) but it is not going to be installed

Depends: libmono-system-runtime-serialization4.0-cil (>= 4.0.0~alpha1) but it is not going to be installed

Depends: libmono-system-servicemodel4.0a-cil (>= 3.2.3) but it is not going to be installed

Depends: libmono-system-transactions4.0-cil (>= 1.0) but it is not going to be installed

Depends: libmono-system-web4.0-cil (>= 2.10.3) but it is not going to be installed

Depends: libmono-system-xml-linq4.0-cil (>= 3.0.6) but it is not going to be installed

Depends: libmono-system-xml4.0-cil (>= 3.12.0) but it is not going to be installed

Depends: libmono-system4.0-cil (>= 4.0.0~alpha1) but it is not going to be installed

Depends: mono-devel (>= 1.0) but it is not going to be installed

Recommends: libembymagickwand-6.q8-2 but it is not installable

E: Unable to correct problems, you have held broken packages.

Link to comment
Share on other sites

curiousgally

Should i install imagemagik as mentioned in the steps for manual..or not necessary. After I installed mono, emby server installation succeeded without any issues.

It didn't complain about sqllite3 or imagemagik.

Edited by curiousgally
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...