Jump to content

EmbyTV - Scheduled recording did not actually record


virtualtinker
 Share

Recommended Posts

virtualtinker

Server version: Whatever version came before 3.0.5857.0.

 

Little backstory to help understand how I have the recordings setup as I have suspicions that it ties into the problem.  So I wanted to record Shanna Chronicles and missed the first two episodes.  Doing a search, I saw that the 2 episodes I was missing would air in a couple of weeks.  Great, I thought.  So what I ended up doing was I setup a scheduled series recording of Shannara Chronicles and setup the config to only record new episodes.  I then explicitly went into the 2 upcoming episodes I was missing and set a scheduled recording for those outside of the series.  The episodes were supposed to record Sunday but that never actually occured.  What happened instead was some weird gui thing where the 2 Sunday scheduled recordings still show, but they are passed the recording date now.  See screenshot

 

https://www.dropbox.com/s/anc2cmhyb8lbnjp/shannara_gui_error.PNG?dl=0

 

Looking in the logs, I see that the stream tried to fire, but some kind of exception was thrown.  There are also a ton of errors occurring after, but I don't think they are necessarily related as it seems my logs typically are littered with these errors.  The 2 episodes span multiple log files, so I've attached both with debugging enabled.  These are the specific times when the scheduled recordings were supposed to fire.  In addition, aside from these 2 failed recordings, I have been able to successfully record other media from other channels with success.  A new Shannara airs tonight, so we'll see if that causes problems but the new episodes typically haven't in the past, so I fully expect it to succeed; it really seems tied to the explicit repeat episode recording butting heads with the scheduled recording only set to record new episodes.

 

2016-01-31 14:35:00.0034 Error App: Error recording stream - https://www.dropbox.com/s/3846jz6906g5uow/server-63589795200.txt?dl=0

 

2016-01-31 15:45:00.0061 Error App: Error recording stream - https://www.dropbox.com/s/2vi7bwlg4ts7zno/server-63589848752.txt?dl=0

Link to comment
Share on other sites

Something in your guide does not match with your scheduled recordings - if you notice in your screenshot the icons next to your recordings do not show thumbnails of the show.  This usually means that EmbyTV cannot find that show in the guide for that time.  Did you check the guide before the recordings to see if something changed?  Also - after you update your Emby Server software do you refresh your guide?

 

Your logs show this:

2016-01-31 14:35:00.0034 Info App: Recording timer fired.
2016-01-31 14:35:00.0034 Error App: Error recording stream
	*** Error Report ***
	Version: 3.0.5853.0
	Command line: C:\Users\Chris\AppData\Roaming\MediaBrowser-Server\System\MediaBrowser.ServerApplication.exe
	Operating system: Microsoft Windows NT 6.2.9200.0
	Processor count: 4
	64-Bit OS: True
	64-Bit Process: True
	Program data path: C:\Users\Chris\AppData\Roaming\MediaBrowser-Server
	Application Path: C:\Users\Chris\AppData\Roaming\MediaBrowser-Server\System\MediaBrowser.ServerApplication.exe
	Program with Id EP023215760005T635898696000000000C866 not found
	System.InvalidOperationException
	   at MediaBrowser.Server.Implementations.LiveTv.EmbyTV.EmbyTV.<RecordStream>d__81.MoveNext()
	--- End of stack trace from previous location where exception was thrown ---
	   at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)
	   at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
	   at MediaBrowser.Server.Implementations.LiveTv.EmbyTV.EmbyTV.<_timerProvider_TimerFired>d__76.MoveNext()

Which basically states that the program with episode ID EP023215760005T635898696000000000C866 cannot be found in the guide data.  That means that your guide data and your scheduled data are not jiving.

Link to comment
Share on other sites

I think maybe the identifier might have changed in the guide data, so we'll have to figure out how we're going to handle it.

Link to comment
Share on other sites

virtualtinker

If it's really a matter of the my recorded entries becoming stale and no longer matching the updated guid entries in the guide, I went ahead and deleted my scheduled recording of Shannara then rescheduled it so as to make sure the guid is current.

 

Let me know if there's anything I can do to help in any way in coming up with a solution for this.

Link to comment
Share on other sites

No I think the issue is that guide data can change from one day to the next, and the information that is initially created in the internal schedule is no longer valid by the time the recording actually takes place. 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...