Jump to content

mkv's cant turn subtitles off


dmonaco05
 Share

Recommended Posts

dmonaco05

When I try to stream via emby for wmc and the file is a .mkv movie the subtitles are always on and I can't turn them off.  When I stream a .mp4 the subtitles don't turn on automatically (not even sure if they work at all I never use subtitles).  Ive been through settings on the server and the client and can't seem to figure out how to disable the subs without playing it directly in VLC.

Link to comment
Share on other sites

All playback in WMC is controlled by your codec settings.

 

You will need to edit those to treat subtitles how you wish.

Link to comment
Share on other sites

dmonaco05

All playback in WMC is controlled by your codec settings.

 

You will need to edit those to treat subtitles how you wish.

 

Can you tell me how to edit them?

 

edit: Is it codec settings on the client or server?

Edited by dmonaco05
Link to comment
Share on other sites

It depends on what codecs you have installed but they all have some sort of app that allows you to select things like audio and subtitle track preferences.

 

With LAV, I believe it is actually in the splitter settings.

 

This would be on the machine doing the playback.

Link to comment
Share on other sites

AdrianW

I have issues with some mkvs showing subtitles when they shouldn't - and it usually turns out that the "default track" flag hasn't been set - where it should be specifically set to "no".

 

 

Try this with one of the offending mkv's (it's quite a few steps - but after you have downloaded and installed the process only takes a couple of seconds):

  • download and install mkvtoolnix
  • Run MKVToolnix GUI
  • Click the "edit headers" tab at the far left
  • Drag the mkv file into the main panel
  • Expand the subtitle track by double clicking it
  • Click on "Default Track flag"
  • In the right-hand panel check "Add element"
  • Type Ctrl-S to save
  • Close mkvtoolnix GUI

 

Then try your file again. The subtitles should now not appear.

Edited by AdrianW
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...