Jump to content

Library Sync Thread Has Exited! You should restart Kodi now.


Rew452
 Share

Recommended Posts

I continue to have this problem on my NUC I3 Win 7 HTPC. I have un-installed and re-installed the Emby add-on and even uninstalled Kodi, then reinstalled Kodi, Emby beta repository then the Emby Kodi add-on and yet it keeps having the same problem.

 

I am using Kodi 15.2 DX11 build.

 

Kodi for Media center on the same machine works fine. So I don't think it's a server issue. No problems on my other machines with Emby or Kodi.

 

 

Thanks

Rew

kodi.log

  • Like 1
Link to comment
Share on other sites

The connection to your server timed out. We requested an entire section for your movies and the server wasn't able to respond within 30 sec with the first set of 200 items. Did you have anything going on your server (like transcoding or a schedule task running?)

 

Try reducing the number of items in the add-on settings > sync option to 150. Restart Kodi and let me know if the sync completes. Thanks.

Also you can disable Kodi debug for future logs, we don't need it. :)

Edited by Angelblue05
Link to comment
Share on other sites

Yes, I saw that and it doesn't make sense, the other apps WMC and Theater work just fine on the same system.

 

I removed the Emby Kodi add-on, removed Kodi,rebooted then reinstalled Kodi, installed Emby V1.04 repository then installed the Emby add-on from the beta repository.

 

I am attaching logs from initial Kodi install, Emby Beta repository and then Emby Add-on installs.

Please review and hopefully recommend a fix.

 

I did lower the sync option down to 100 with no change; it still hung with "Library sync thread exited! You should restart Kodi now.

Please report this on the forum."

 

I have tried to reset the database but it fail with Can't stop the database from running.

 

Thanks

Rew

 

 

 

kodi.log

kodi.old.log

kodi.old1.log

Link to comment
Share on other sites

Do you have the server log from that same time?

 

It seems to crash when it tries to process your Movies view from a readtimeout. Having your server log should give us an idea of what might be wrong.

Edited by Angelblue05
Link to comment
Share on other sites

2016-01-11 19:14:59.4260 Info HttpServer: HTTP Response 200 to ::ffff:192.168.1.77. Time: 6755ms (slow).

Can you try again, with 75 items set in the add-on settings > sync option > items to request at once? Same deal, the Kodi log and server log from that same time. Thanks, I just want to see if your server responds faster.

Edited by Angelblue05
  • Like 1
Link to comment
Share on other sites

Lowering the sync items to 75 caused it to immediately to complete; all 536 items. Am I OK now or is there something else that should check?

 

Thanks

Rew

  • Like 2
Link to comment
Share on other sites

Ok yes, should be fine. Lowering the number simply allows your server to respond faster (the timeout for the connection is 30 sec). You could probably adjust the number to see if you can go any higher than 75 (then doing a reset and seeing if the resync works or not). Anyway, I'm glad it's working now :)

 

 

Sent from my iPhone using Tapatalk

  • Like 1
Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...