Jump to content

Installing Kodi Addon on OPENElec running on an Odroid C1


jpaytoncfd

Recommended Posts

jpaytoncfd

I was having issues getting emby installed on my odroid. No matter what I tried the actual emby plugin would not even show up in repo lists. I tried the official odroid lubuntu images as well as several openelec versions. 

 

My solution was to check for updates before and after installing the repository. If I did not do it first I think it cached a dependency error and ignored emby. Then since nothing actually changed it would never fully check the emby plugin for compatability again. It looks like kodi checks md5 sums to see if there are any changes. I think it has something to do with the fact these images we write to the device were pulled from a working device. Kodi is not treating it like a first run and therefor is not trying to cache or update anything. 

 

If you have already installed the repo, uninstall the REPO and delete your addons DB file. (.kodi/userdata/Database/addons*.db.), restart the device and from the settings>addons menu press the left arrow and select Check For Updates, Now install the repo and check for updates again. You should now be able to go to settings>addons>Install From Repo>Emby for Kodi Repo>Video Addons>Emby>INSTALL!

 

You might be able to skip deleting the database file, I have not tried yet. There may be delays too. I had to update after installing the repo twice before anything showed. On my second Odroid I updated before installing the repo and after and emby was right there and installed with no issues.  

 

This only seems to happen if you try to install before doing anything else with kodi. If I had browsed or added an addon before it would have likely worked fine. Maybe even just having the device running long enough to get an updated time and date. 

Link to post
Share on other sites
Guest
This topic is now closed to further replies.
×
×
  • Create New...