Jump to content

Android app does not connect to HTTPS


miquelx
 Share

Recommended Posts

Hello all,
I'm having an issue with the android app. When I try to connect to my server over HTTPS I get a connection failure error. If i switch to HTTP it works.
HTTPS was working fine three-four days ago, when I installed the certificate on the phone.
I've tried with the domain and the IP, both don't work.

How should I proceed?

 

App version: 2.5.55

Server version: 3.0.5781.5

Server OS: Ubuntu

post-95526-0-74532800-1451340779_thumb.png

Link to comment
Share on other sites

Did you check if by any chance the self-signed certificate changed and now you have one certificate on the phone and a different one in the server?

 

Also if you can post the server log while trying to connect with your phone using HTTPS it can help the troubleshooting. :)

Restarting the server before doing that test will give us a lighter and cleaner log to look at.

 

Thanks

Link to comment
Share on other sites

miquelx

Got over the problem. I'm now using a certificate by a CA, and installed the CA root certificate on the devices.
Now I can connect for HTTPS but i get a failure error when playing media. When i have the time I'll post some logs of the server and the android app.

Link to comment
Share on other sites

  • 4 weeks later...
anderbytes

As told in other topic (you are there), libVLC that streams the media still can`t use the PFX certificate, for now.

 

Devs are working on it, I hope.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...