Jump to content

Confirmed MB3 can stream to Xbox One


subkamran
 Share

Recommended Posts

subkamran

Hey everyone,

 

There have been lots of questions around the net where people have asked if Xbox One can stream from a PC like you could in 360 or PS3 using DLNA. You can't (yet).

 

However, today I discovered that you TOTALLY CAN just browse to your network Media Browser dashboard and stream like a boss; I tested playing Star Wars Empire Strikes Back without issues.

 

I'll be posting a tutorial this weekend but it's real simple if you already have MB3 installed on a PC:

 

1. Open IE in Xbox One

2. Browse to: http://yourcomputername:8096/mediabrowser/dashboard/index.html

3. Login

4. Browse to http://yourcomputername:8096/mediabrowser/dashboard/index.html again

5. Hit Menu button on the controller

6. Select the tab

7. Hit the "Views" button on the controller

8. Pin the tab to Home

 

You can now browse your MB3 server anytime on Xbox One and stream from it. To stream, once you hit Play a box in the bottom will show and you can just press the fullscreen button to go full. It uses the Xbox native controls.

 

This is a good stopgap until we can see a Xbox App or Windows Store app ported to Xbox (I believe C#/XAML Windows Store apps will be compatible with Xbox One eventually).

  • Like 9
Link to comment
Share on other sites

  • 3 weeks later...
subkamran

Damn, Does not work for me. says not supported.

Sometimes there are multiple formats. Click the gear icon and try a higher format... I dont think all of them work right. Once i did that, it worked.

Link to comment
Share on other sites

Tanamur

That's a good idea I'll try tonight on my TV and let you know

Thanks I am really curious how well it works. Even if someone doesn't have a smart tv, the blu-ray players with smart/browser features are quite inexpensive. The specs on the browsers (HTML5, Flash Player support, etc) are proving hard to find for me.

Link to comment
Share on other sites

Latchmor

Hi, I have used the browser in my 2012 LG TV and it works. The TV shows in the Dashboard Active Connections as 'Safari 534.26'.

 

You can see in the image it's playing and it will go full screen too.  However the web client is limited to 480p highest quality and full screen it doesn't look great, but it does play.

 

52b86b09072bb_IMG_20131223_164355.jpg

  • Like 1
Link to comment
Share on other sites

Ironman273

Sometimes there are multiple formats. Click the gear icon and try a higher format... I dont think all of them work right. Once i did that, it worked.

Could you expand on your explanation?  I'm getting the same "Application not supported" error.  Which gear icon do you mean?

Link to comment
Share on other sites

subkamran

Could you expand on your explanation?  I'm getting the same "Application not supported" error.  Which gear icon do you mean?

 

Sure. There's  a gear icon on the bottom toolbar (see Latchmor's screenshot above). It will present a drop-down of available formats like 1080p+ and 480p etc. I dont know why it detects multiple formats or if it's a feature, but sometimes it doesn't pick the right one so I just try a different one and it typically works.

 

I haven't tested every format, like MKVs, it might be restricted to certain formats that are compatible unless it transcodes... I haven't used MB3 enough to know the ins and outs of how it streams. I remember with TVersity it would always transcode.

Edited by subkamran
Link to comment
Share on other sites

Ironman273

Sure. There's  a gear icon on the bottom toolbar (see Latchmor's screenshot above). It will present a drop-down of available formats like 1080p+ and 480p etc. I dont know why it detects multiple formats or if it's a feature, but sometimes it doesn't pick the right one so I just try a different one and it typically works.

 

I haven't tested every format, like MKVs, it might be restricted to certain formats that are compatible unless it transcodes... I haven't used MB3 enough to know the ins and outs of how it streams. I remember with TVersity it would always transcode.

I'm sorry.  I'm still a little confused.  We're talking about IE11 on the Xbox One, right?  My browser looks like this:

Internet%20Explorer%20NFL.png?itok=XDXf8

 

Edit:  Wait, that gear icon is an element from MediaBrowser, isn't it?  I'm not getting far enough to get the page to load up.  When I go to the site I get a blank page that says:

post-1760-0-83500800-1388166042_thumb.jpg

 

Edited by Ironman273
Link to comment
Share on other sites

Ironman273

OK, I was having trouble connecting from my Surface tablet using IE in metro mode but I connected fine using Chrome from the Windows desktop.  It then hit me that I have to include "http://" in the address.  Once I did that on the Xbox One browser it loaded up fine.

Link to comment
Share on other sites

Brendon

aww i am jealous, missed out on my XBox One, major shortage here in Oz for xmas and every single place i went had signs up saying sold out / pre-order for 2014, rang a mate at The Good Guys to nab one and he laughed at me  :(  Seriously how did M$ and Sony not see that coming, the rest of the world did lol

Link to comment
Share on other sites

subkamran

I'm sorry.  I'm still a little confused.  We're talking about IE11 on the Xbox One, right?  My browser looks like this:

 

 

Edit:  Wait, that gear icon is an element from MediaBrowser, isn't it?  I'm not getting far enough to get the page to load up.  When I go to the site I get a blank page that says:

attachicon.gifWP_20131226_18_31_09_Pro.jpg

 

Oh, I have no idea on that... I pinned the dashboard URL for MB3 and use that, after I logged in once. You do have to make sure you can access your server and port. If you can access from another computer, the Xbox should be able to browse to it fine. I have multiple PCs to test and my tablet, so I'd try to get to it first from another device on the same network.

Link to comment
Share on other sites

trooper11

aww i am jealous, missed out on my XBox One, major shortage here in Oz for xmas and every single place i went had signs up saying sold out / pre-order for 2014, rang a mate at The Good Guys to nab one and he laughed at me  :(  Seriously how did M$ and Sony not see that coming, the rest of the world did lol

 

 

 

That sucks, well hopefully you can get yours without too much of a wait.  Demand just overwhelmed stock.  It was like a tidal wave lol.

Link to comment
Share on other sites

  • 1 month later...

Sorry to ping this thread, but I got really excited at the possibility of accessing MB from my XB1, but upon clicking "play" on any listed movie absolutely nothing happens... nothing. No error. No playback window. No control bar. Nothing. Has any one else run into this issue and can suggest a fix? I played with various IE11 settings on the box without any luck.

 

Thanks for your time!

Link to comment
Share on other sites

subkamran

Sorry to ping this thread, but I got really excited at the possibility of accessing MB from my XB1, but upon clicking "play" on any listed movie absolutely nothing happens... nothing. No error. No playback window. No control bar. Nothing. Has any one else run into this issue and can suggest a fix? I played with various IE11 settings on the box without any luck.

 

Thanks for your time!

 

Hmm not sure. I tested with MP4, MKV, and AVI and all work as expected... actually just used it to watch American Horror Story a couple days ago without issues.

 

Does it work via the web interface on your computer itself?

Link to comment
Share on other sites

Ironman273

The only issue I've had is with one movie that was in mkv format.  It would not play and give me an error message.  After the error nothing else would play until I closed the IE app and reopened it.  I tried converting the movie to MP4 and had the same problem.  But at least I did get an error message (even if I can't remember what it is).  I do remember when I looked up the error the replies were with an IE problem and the solution (which wouldn't work on the X1) was to install a plugin or use Chrome.

Link to comment
Share on other sites

skywalker993

Someone else please check this.

 

It was perfect before the update! Just like @@subkamran said, load the index and log in, then go to the index again and pin to home. Been using it a week without issue.

 

Then the recent Xbox One update seems to have broken HTML5, or at least prevented certain content from displaying. Before the update, Pandora and MB could be accessed through Internet Explorer and work without issue. Now Pandora loads a blank screen and MB loads the button "Media Folders," and within that shows nothing.

post-2520-0-69550400-1392957427_thumb.jpg

Edited by skywalker993
Link to comment
Share on other sites

skywalker993

Update: Enabling JavaScript errors gives me this...

 

JavaScript error

Line 4429, Character 5

System could not find the path specified

80070003

 

Clearing cache (soft reset by holding down power button and then unplugging for a few minutes) changes nothing.

Edited by skywalker993
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...