Jump to content
Sign in to follow this  
dmartinez7500

Issues installing emby-server due to missing

Recommended Posts

dmartinez7500

In the process of installing Emby on Ubuntu Server 14.10, following the process outlined here. I've been able to get the repo setup, although I needed to manually add the proper keys, get the repo cache updated, and install the listed dependencies, but when I go to install the actual emby-server application, it gives me the following:

david@plexserver:~$ sudo apt-get install emby-server
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 emby-server : Depends: mono-devel (>= 1.0) but it is not going to be installed
               Depends: lsb-base (>= 4.1+Debian11ubuntu7) but 4.1+Debian11ubuntu6 is to be installed
E: Unable to correct problems, you have held broken packages.

I did some investigating, and tried to manually install both mono-devel and lsb-base. Those outputs are below:

david@plexserver:~$ sudo apt-get install lsb-base
Reading package lists... Done
Building dependency tree
Reading state information... Done
lsb-base is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
david@plexserver:~$ sudo apt-get install lsb-base
Reading package lists... Done
Building dependency tree
Reading state information... Done
lsb-base is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
david@plexserver:~$ sudo apt-get install mono-devel
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 mono-devel : Depends: libglib2.0-0 (>= 2.42.0) but 2.40.2-0ubuntu1 is to be installed
E: Unable to correct problems, you have held broken packages.

Not sure what exactly could be causing this, but I do have mono previously installed, as I'm using Sonarr for grabbing TV Shows.

 

Has anybody run into something similar?

 

EDIT: Sorry about the weird title. Wasn't paying attention.

Edited by dmartinez7500

Share this post


Link to post
Share on other sites
hurricanehrndz

At first glance, I would think you do not have the right repo setup in your sources.list. Can you please post them.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...