Jump to content
benjamoomin

Using NAR (Narrated) Audio stream instead of English

Recommended Posts

Luke

Having similar problems still with Dvblink and the android app. Not getting any help unfortunately

 

It is up to the tv provider to provide the media info. Then the app will display the subtitles.

Share this post


Link to post
Share on other sites
Spaceboy

It is up to the tv provider to provide the media info. Then the app will display the subtitles.

It's a second audio stream actually. It works fine in all other apps, just not android. We haven't had much help to know where the problem lies

  • Like 1

Share this post


Link to post
Share on other sites
benjamoomin

Hi @@Luke,the issue is around audio channels rather than subs.

In some instances NAR (narrated audio for people with sight issues) is the first audio stream for a channel and ENG being the 2nd audio stream.

It sounds like the first stream is known as the default on emby, however the android app and android tv app will just use the first/default stream regardless of the user profile setting where you can untick the option to always use default stream and select the preferred language which is set to English.

Share this post


Link to post
Share on other sites
Luke

Hi @@Luke,the issue is around audio channels rather than subs.

In some instances NAR (narrated audio for people with sight issues) is the first audio stream for a channel and ENG being the 2nd audio stream.

It sounds like the first stream is known as the default on emby, however the android app and android tv app will just use the first/default stream regardless of the user profile setting where you can untick the option to always use default stream and select the preferred language which is set to English.

 

It's the same idea as audio and subtitles. the media info needs to be there.

Share this post


Link to post
Share on other sites
benjamoomin

It's the same idea as audio and subtitles. the media info needs to be there.

Thanks @@Luke, does this mean the plugin is missing the media info? @@pünktchen is this something you can help with? Cheers

Share this post


Link to post
Share on other sites
pünktchen

It's the same idea as audio and subtitles. the media info needs to be there.

The media info is there with MediaPortal plugin!

Share this post


Link to post
Share on other sites
Luke

is the app direct playing or using server transcoding?

Share this post


Link to post
Share on other sites
pünktchen

Thanks @@pünktchen. I'll raise it in the android app and android tv app forums. As a thought is there any way for this plugin to change the order of audio tracks? For example always make the NAR track come last, forcing it to be stream 9 or something similar? Thanks

I can't change the order of the tracks, but as workaround i could create another plugin option where you can set your prefered language code to be used as default track. But this is really only a bad workaround, because Emby server should already take care of it!

Share this post


Link to post
Share on other sites
pünktchen

is the app direct playing or using server transcoding?

@@benjamoomin ?

Share this post


Link to post
Share on other sites
Luke

well that's the tv app. what about the mobile app?

Share this post


Link to post
Share on other sites
benjamoomin

is the app direct playing or using server transcoding?

Both the android app and the android tv app are playing direct. Well I know the android tv is direct (as it tells me when it starts playing) but on the android app I can only presume it's direct as there's nothing in the transcoding log (can't seem to tell from within the app itself)

Share this post


Link to post
Share on other sites
benjamoomin

I can't change the order of the tracks, but as workaround i could create another plugin option where you can set your prefered language code to be used as default track. But this is really only a bad workaround, because Emby server should already take care of it!

This sounds like it would be a good idea anyway, as the eng audio should be the default rather than the narrated track.

Share this post


Link to post
Share on other sites
benjamoomin

Both the android app and the android tv app are playing direct. Well I know the android tv is direct (as it tells me when it starts playing) but on the android app I can only presume it's direct as there's nothing in the transcoding log (can't seem to tell from within the app itself)

Hi @@Luke, I can confirm that if the TV channel is transcoding (in either the Android or Android tv app) then the ENG audio is selected correctly by default. If either play direct then the NAR track is started when starting a stream.

 

As a side note that with Android app you can switch to the eng track. On the android tv app, neither track is ticked in the gui and you can't switch tracks.

Share this post


Link to post
Share on other sites
pünktchen

Hi @@Luke, I can confirm that if the TV channel is transcoding (in either the Android or Android tv app) then the ENG audio is selected correctly by default. If either play direct then the NAR track is started when starting a stream.

 

As a side note that with Android app you can switch to the eng track. On the android tv app, neither track is ticked in the gui and you can't switch tracks.

Can confirm this also.

Share this post


Link to post
Share on other sites
benjamoomin

@@pünktchen I still seem to be having this issue of the narrated/audio description track heard when watching TV. I use the fire tv and android app and there doesn't seem to be a way to switch audio tracks whilst viewing a channel, also doesn't seem to be a way to view the language of the audio playing like you used to. The stats for nerds doesn't show it at least.

Am I the only one using MP with this issue? I'm surprised it's not been mentioned by anyone else.

Share this post


Link to post
Share on other sites
Spaceboy

Utterly ridiculous that three years on this still hasn’t been solved, but it’s the same with all plugins unfortunately

Edited by Spaceboy
  • Like 1

Share this post


Link to post
Share on other sites
Luke

@@pünktchen I still seem to be having this issue of the narrated/audio description track heard when watching TV. I use the fire tv and android app and there doesn't seem to be a way to switch audio tracks whilst viewing a channel, also doesn't seem to be a way to view the language of the audio playing like you used to. The stats for nerds doesn't show it at least.

Am I the only one using MP with this issue? I'm surprised it's not been mentioned by anyone else.

 

@@benjamoomin, please attach the information requested in how to report a media playback issue. thanks !

Share this post


Link to post
Share on other sites
pünktchen

@@pünktchen I still seem to be having this issue of the narrated/audio description track heard when watching TV. I use the fire tv and android app and there doesn't seem to be a way to switch audio tracks whilst viewing a channel, also doesn't seem to be a way to view the language of the audio playing like you used to. The stats for nerds doesn't show it at least.

Am I the only one using MP with this issue? I'm surprised it's not been mentioned by anyone else.

This is out of the plugins control. This is purely Emby server and Emby app related.

Share this post


Link to post
Share on other sites
benjamoomin

Hi @@Luke,

Attached are my logs. I restarted emby server to minimise the log sizes. I first is the server log when I played a channel (channel 4 uk, movie Thor was on) from the android app. It was not transcoded and the NAR audio could be heard.

I then then set my home network under profile - playback, to 144p instead of auto to force transcoding and started the channel again, with the same result of NAR heard. The second log is the ffmpeg transcode log generated from the second test.

There's no mention or reference to NAR in the first log from the server when playing direct, but it mentioned once in the transcode log. As you can see it is the first audio track, English being the second audio track. It then goes on to use the first audio track regardless of the language. Also to note that in profile - playback settings, preferred audio language is set to English and "play default audio regardless of language" is disabled.

Any help getting this sorted would be great! Thanks

Log (1).txt

Log (2).txt

Share this post


Link to post
Share on other sites
Luke

Is this the android mobile app, or android tv app?  The server log you provided doesn't appear to be from the same timeframe as the ffmpeg log, it doesn't contain that activity.

Share this post


Link to post
Share on other sites
benjamoomin

Hi @@Luke, apologies I realise I took the server logs after the first direct test, and didn't take a copy after the second transcoding test. Attached is another copy of the server log from last night which should cover both. Thanks

Log (4).txt

Share this post


Link to post
Share on other sites
Spaceboy

The problem from a UK perspective is that three years after reporting it the audio tracks are STILL wrongly labelled. The first track is always going to be track 0 and emby doesn’t seem to like this

  • Like 1

Share this post


Link to post
Share on other sites
benjamoomin

Hi @@Spaceboy @@Luke , is this the section of the transcoding log where the issue stems from?

 

Stream #0:0[0x30]: Video: mpeg2video (Main) ([2][0][0][0] / 0x0002), yuv420p(tv, top first), 704x576 [SAR 16:11 DAR 16:9], 25 fps, 25 tbr, 90k tbn, 50 tbc
    Stream #0:1[0x40](NAR): Audio: mp2 ([4][0][0][0] / 0x0004), 48000 Hz, stereo, s16p, 128 kb/s
    Stream #0:2[0x41](eng): Audio: mp2 ([4][0][0][0] / 0x0004), 48000 Hz, stereo, s16p, 192 kb/s
    Stream #0:3[0x50](eng): Subtitle: dvb_subtitle ([6][0][0][0] / 0x0006)
    Stream #0:4[0x65](eng,eng): Subtitle: dvb_teletext ([6][0][0][0] / 0x0006)
Stream mapping:
  Stream #0:0 -> #0:0 (mpeg2video (native) -> h264 (libx264))
  Stream #0:1 -> #0:1 (mp2 (native) -> ac3 (native))
Edited by benjamoomin

Share this post


Link to post
Share on other sites
benjamoomin

Hi @@Luke is there anything else you need to investigate this issue, or is it already being looked at? Cheers

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...