Jump to content

Supporter unlock not working on Kindle Fire


revengineer
 Share

Go to solution Solved by revengineer,

Recommended Posts

revengineer

I installed the emby for android app on my Kindle Fire HD 10 (5th generation). I am having trouble to unlock the TV guide. I am connected to my home LAN where the emby server resides. I followed the blue link to sign in with emby supporter membership. But selecting the guide upon login leads to the same prompt to update the app. The unlock worked fine with my Motorola android phone.

 

Related log entry shows success:

2015-10-05 14:10:49.5032 Info - UserManager: Authentication request for htpcuser has succeeded.

Link to comment
Share on other sites

try closing the app and coming back in. i will have to review this for the next release because currently the app needs to be able to auto-detect the emby server on the lan and that might be a little too restrictive.

Link to comment
Share on other sites

revengineer

Luke,

I tried that multiple time without success, including closing the app completely. (I would not have posted after a single try :) )

 

EDIT: The server is not auto-detected. I am entering the local IP address to login.

Edited by revengineer
Link to comment
Share on other sites

yea for the next release of the app we'll add a secondary validation method besides just detecting the server.

Link to comment
Share on other sites

In the meantime you could try to get auto detection working.  Is your firewall blocking UDP traffic?

Link to comment
Share on other sites

revengineer

In the meantime you could try to get auto detection working. Is your firewall blocking UDP traffic?

Not on the internal network, but it's blocked going external. Plus I use a nonstandard port for tcp traffic for better security. Which firewall are you referring to.
Link to comment
Share on other sites

revengineer

Ok, that would be the windows server and should have nothing to do with my firewall gateway. I then checked the Windows Firewall on the Server. It looks like on emby server install two entries were added for Port 8096 and 8920. Both ports were enabled for TCP traffic. Are you saying I need to create entries for UDP traffic as well? I am puzzled because my android phone unlocked the app with the present firewall configuration just fine.

Link to comment
Share on other sites

Yes, I would create rules for UDP as well and see if the app can then find the server automatically.

Link to comment
Share on other sites

  • Solution
revengineer

Yes, opening port 8096 for UDP traffic on the emby server machine solved the problem. Thank you!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...