Jump to content


Photo

Old Bug Thread

bugs

  • This topic is locked This topic is locked
65 replies to this topic

#1 cmcg OFFLINE  

cmcg

    Advanced Member

  • Developers
  • 718 posts
  • Local time: 06:54 AM
  • LocationCambridge, UK

Posted 05 October 2015 - 10:07 AM

Let's use this thread to list and track bugs shall we? People can Like bug reports to vote for them and we'll use that to target our remediation efforts.

 

Only bug reports please. Feature requests can be made here.

 

Please include as much of the following information as you can. Anyone can investigate a bug and send additional information about reproducing the issue with different TVs or Emby versions and the feedback will be added to the main report for that issue.

 

Issue description:

 

Steps to reproduce:

 

My TV/HTS/BDPlayer:

 

My firmware version:

 

Other TVs etc. the issue has been reproduced on:

 

My Emby server version:

 

My current Emby Samsung client version:

 

Other Emby Samsung versions the issue can be reproduced in: 

Developer comments:


Edited by cmcg, 05 October 2015 - 10:36 AM.


#2 cmcg OFFLINE  

cmcg

    Advanced Member

  • Developers
  • 718 posts
  • Local time: 06:54 AM
  • LocationCambridge, UK

Posted 05 October 2015 - 10:08 AM

Issue description: Settings page can't regain focus when using the music player.

 

Steps to reproduce: Navigate to music and play an album. Leave it playing and open the settings page. Press the blue button to bring up the music controls. Press blue again to dismiss them. Settings page can't be controlled anymore. Pressing the return button a couple of time regains control.

 

My TV/HTS/BDPlayer: UE55F800

 

My firmware version: 1128

 

Other TVs etc. the issue has been reproduced on:

 

My Emby server version: 3.0.5724.5

 

My current Emby Samsung client version: 0.593i

 

Other Emby Samsung versions the issue can be reproduced in: 0.590

 

Developer comments: Fixed in v0.593m


Edited by cmcg, 10 October 2015 - 06:25 AM.


#3 cmcg OFFLINE  

cmcg

    Advanced Member

  • Developers
  • 718 posts
  • Local time: 06:54 AM
  • LocationCambridge, UK

Posted 05 October 2015 - 10:09 AM

Issue description: Clock ignores daylight saving time.

 

Steps to reproduce: Clock in the app is one hour behind the clock in the smarthub.

 

My TV/HTS/BDPlayer: UE55F800

 

My firmware version: 1128

 

Other TVs etc. the issue has been reproduced on:

 

My Emby server version: 3.0.5724.5

 

My current Emby Samsung client version: 0.593i

 

Other Emby Samsung versions the issue can be reproduced in: 0.590, 0.588

 

Developer comments: Might be just me this one. I beleve it's a TV firmware issue. Won't fix. Added a user clock offset option. Fixed in v0.593q


Edited by cmcg, 13 October 2015 - 03:56 PM.


#4 cmcg OFFLINE  

cmcg

    Advanced Member

  • Developers
  • 718 posts
  • Local time: 06:54 AM
  • LocationCambridge, UK

Posted 05 October 2015 - 10:11 AM

Issue description: Collections folder doesn't use the enhanced folder image.

 

Steps to reproduce: Navigate to Media Folders. All folder have the enhanced poster image with slices of the contained content displayed, apart from Collections which has the older style icon and green background.

 

My TV/HTS/BDPlayer: UE55F800

 

My firmware version: 1128

 

Other TVs etc. the issue has been reproduced on:

 

My Emby server version: 3.0.5724.5

 

My current Emby Samsung client version: 0.593i

 

Other Emby Samsung versions the issue can be reproduced in: 0.590, 0.588

 

Developer comments: I've looked at this. It's requesting the wrong item image. Not sure how to fix as the server sends the list of items.  Also, Collections shouldn't really be in the Media Folders view so might not fix.



#5 cmcg OFFLINE  

cmcg

    Advanced Member

  • Developers
  • 718 posts
  • Local time: 06:54 AM
  • LocationCambridge, UK

Posted 05 October 2015 - 10:11 AM

Issue description: No poster images on home videos.

 

Steps to reproduce: Naviagate to Media Folders. My home videos are in a subfolder called Home Movies. It shows slices of the contents on enhanced folder image. But if I go in to the Home Movies folder they are blank with just the name and date.

 

My TV/HTS/BDPlayer: UE55F800

 

My firmware version: 1128

 

Other TVs etc. the issue has been reproduced on:

 

My Emby server version: 3.0.5724.5

 

My current Emby Samsung client version: 0.593i

 

Other Emby Samsung versions the issue can be reproduced in: 0.590

 

Developer comments: The Home Videos media type is not yet properly supported in Emby Samsung. This is planned. However, I do agree (with myself) that they should have images when displayed via the media folders view.

 

Fixed in 1.0.0c


Edited by cmcg, 28 October 2015 - 11:50 AM.

  • fluffykiwi likes this

#6 cmcg OFFLINE  

cmcg

    Advanced Member

  • Developers
  • 718 posts
  • Local time: 06:54 AM
  • LocationCambridge, UK

Posted 05 October 2015 - 10:12 AM

Issue description: Album details overlap CD cover image.

 

Steps to reproduce: Naviagte to Music, Albums. When selecting an album the details below often overlap with the bottom row of album cover images.

 

My TV/HTS/BDPlayer: UE55F800

 

My firmware version: 1128

 

Other TVs etc. the issue has been reproduced on:

 

My Emby server version: 3.0.5724.5

 

My current Emby Samsung client version: 0.593i

 

Other Emby Samsung versions the issue can be reproduced in: 0.590

 

Developer comments: Confirmed. Fixed in 1.0.0d


Edited by cmcg, 28 October 2015 - 11:51 AM.

  • fluffykiwi likes this

#7 cmcg OFFLINE  

cmcg

    Advanced Member

  • Developers
  • 718 posts
  • Local time: 06:54 AM
  • LocationCambridge, UK

Posted 05 October 2015 - 10:13 AM

Issue description: CD cover image should change when scrolling a list of songs from different albums.

 

Steps to reproduce: Navigate to Music, Artists and select an artist with multiple ablums. Click Select. When moving down the list of songs the album art remains the same as the album for the first song.

 

My TV/HTS/BDPlayer: UE55F800

 

My firmware version: 1128

 

Other TVs etc. the issue has been reproduced on:

 

My Emby server version: 3.0.5724.5

 

My current Emby Samsung client version: 0.593i

 

Other Emby Samsung versions the issue can be reproduced in: 0.590

 

Developer comments: Confirmed, although this is almost a feature request as it's not broken, it's just never been implemented. But it seems like it should be.


Edited by cmcg, 05 October 2015 - 10:47 AM.

  • fluffykiwi likes this

#8 cmcg OFFLINE  

cmcg

    Advanced Member

  • Developers
  • 718 posts
  • Local time: 06:54 AM
  • LocationCambridge, UK

Posted 05 October 2015 - 10:17 AM

@FrostByte

 

Issue description: Under Settings...Server Settings every gray box says "MediaBrowser".  Should be Emby of course

 

Steps to reproduce:

 

My TV/HTS/BDPlayer: UE55F800

 

My firmware version: 1128

 

Other TVs etc. the issue has been reproduced on:

 

My Emby server version: 3.0.5724.5

 

My current Emby Samsung client version: 0.593i

 

Other Emby Samsung versions the issue can be reproduced in: 0.590

 

Developer comments: Fixed in v0.593l


Edited by cmcg, 10 October 2015 - 06:26 AM.

  • fluffykiwi likes this

#9 cmcg OFFLINE  

cmcg

    Advanced Member

  • Developers
  • 718 posts
  • Local time: 06:54 AM
  • LocationCambridge, UK

Posted 05 October 2015 - 10:20 AM

@FrostByte

 

Issue description: The headers at the top of a playlist do not Highlight in green like other areas of music "Play All"  "Shuffle" "Delete".  You can sort of tell where you are by looking at the count in the bottom left.

 

Steps to reproduce:

 

My TV/HTS/BDPlayer: UE55F800

 

My firmware version: 1128

 

Other TVs etc. the issue has been reproduced on:

 

My Emby server version:  3.0.5724.5

 

My current Emby Samsung client version: 0.593i

 

Other Emby Samsung versions the issue can be reproduced in: 0.590

 

Developer comments: Confirmed. Fixed in 0.593n


Edited by cmcg, 10 October 2015 - 06:25 AM.


#10 cmcg OFFLINE  

cmcg

    Advanced Member

  • Developers
  • 718 posts
  • Local time: 06:54 AM
  • LocationCambridge, UK

Posted 05 October 2015 - 10:22 AM

@FrostByte

 

Issue description: I don't believe "Shuffle All" actually shuffles the playlist.  When I click it the playlist just plays down through the list in order.

 

Steps to reproduce: 

Click Playlists. Select a Playlist and click. At the top of the list there should be 3 options

 

My TV/HTS/BDPlayer: UE55F800

 

My firmware version: 1128

 

Other TVs etc. the issue has been reproduced on:

 

My Emby server version:  3.0.5724.5

 

My current Emby Samsung client version: 0.593i

 

Other Emby Samsung versions the issue can be reproduced in: 0.590

 

Developer comments: Agreed, although it's rather difficult to know what actually happening due the previous bug. Server issue, won't fix.


Edited by cmcg, 11 October 2015 - 01:12 PM.


#11 cmcg OFFLINE  

cmcg

    Advanced Member

  • Developers
  • 718 posts
  • Local time: 06:54 AM
  • LocationCambridge, UK

Posted 05 October 2015 - 10:25 AM

@MongooseMan

 

Issue description: Can't enter text in server setup menu on HU7000.

 

Steps to reproduce: I pressed '6' and then it asked me to use the arrows to choose a letter. Pressing right moved the cursor to the second IP address box instead of selecting a letter.

 

My TV/HTS/BDPlayer: HU7000

 

My firmware version:

 

Other TVs etc. the issue has been reproduced on:

 

My Emby server version: 

 

My current Emby Samsung client version: 0.593d

 

Other Emby Samsung versions the issue can be reproduced in: 

 

Developer comments:


Edited by cmcg, 05 October 2015 - 10:25 AM.


#12 cmcg OFFLINE  

cmcg

    Advanced Member

  • Developers
  • 718 posts
  • Local time: 06:54 AM
  • LocationCambridge, UK

Posted 05 October 2015 - 10:28 AM

@gogreenpower

 

Issue description: Video stream interupted switching audio track in MKV dual audio file.

 

Steps to reproduce: 

 

My TV/HTS/BDPlayer:

 

My firmware version:

 

Other TVs etc. the issue has been reproduced on:

 

My Emby server version: 

 

My current Emby Samsung client version: 0.593e

 

Other Emby Samsung versions the issue can be reproduced in: 

 

Developer comments: File:   file://c/Program%20Files%20(x86)/Samsung/Samsung%20TV%20SDK%204/apps/Emby/app/javascript/Gui/GuiPlayer/GuiPlayer_Display.js
                                       Line No:  145
                                       Error Detail: Uncaught TypeError: Cannot read property 'Name' of undefined

Fixed in 1.0.0b


Edited by cmcg, 28 October 2015 - 11:52 AM.


#13 cmcg OFFLINE  

cmcg

    Advanced Member

  • Developers
  • 718 posts
  • Local time: 06:54 AM
  • LocationCambridge, UK

Posted 05 October 2015 - 10:31 AM

@fluffykiwi

 

Issue description: Pressing Return while viewing Help text causes Emby to exit.

 

Steps to reproduce: 

 

My TV/HTS/BDPlayer:

 

My firmware version:

 

Other TVs etc. the issue has been reproduced on:

 

My Emby server version: 

 

My current Emby Samsung client version: 0.593i

 

Other Emby Samsung versions the issue can be reproduced in: 0.590

 

Developer comments: Behaviour changed. Pressing Return with help text open will simply close help text in future. Also, Return changed to Exit while on the home page for extra clarity. Look out for the next beta.

Fixed in v0.593j


Edited by cmcg, 10 October 2015 - 06:26 AM.

  • fluffykiwi likes this

#14 cmcg OFFLINE  

cmcg

    Advanced Member

  • Developers
  • 718 posts
  • Local time: 06:54 AM
  • LocationCambridge, UK

Posted 05 October 2015 - 10:32 AM

@fluffykiwi

 

Issue description: Pressing Help twice in HomeTwoItems causes item focus to become confused.

 

Steps to reproduce: 

 

My TV/HTS/BDPlayer:

 

My firmware version:

 

Other TVs etc. the issue has been reproduced on:

 

My Emby server version: 

 

My current Emby Samsung client version: 0.593i

 

Other Emby Samsung versions the issue can be reproduced in: 0.590

 

Developer comments: Confirmed. Fixed n v0.593j


Edited by cmcg, 11 October 2015 - 01:14 PM.


#15 fluffykiwi OFFLINE  

fluffykiwi

    Advanced Member

  • Members
  • 65 posts
  • Local time: 05:54 AM

Posted 05 October 2015 - 01:10 PM

Issue description:
On Home View pressing RED to show help info causes Emby to become unresponsive to further key presses.

Steps to reproduce:
In Home View press RED them try to navigate.

My TV/HTS/BDPlayer:
UE55HU8500 and BD-F7500

My firmware version:
TV 1280 BD 1021

Other TVs etc. the issue has been reproduced on:
See above

My Emby server version:
3.0.5724.6

My current Emby Samsung client version: 0.593i

Other Emby Samsung versions the issue can be reproduced in:

 

Developer comments: Confirmed. Fixed in v0.593j.


Edited by cmcg, 10 October 2015 - 06:26 AM.


#16 JeremyG OFFLINE  

JeremyG

    Advanced Member

  • Members
  • 84 posts
  • Local time: 06:54 AM

Posted 05 October 2015 - 02:30 PM

Issue description: Can't log in with an account that has no password.

 

Steps to reproduce:   I cannot get this to re-produce.   I actually re-installed my Emby Server for another reason and it logged in first time with no problems.   It "might" have been related to monkeying with default user in settings.  Wish I could be more help.   (will post details in this thread next time I find something)

 

My TV/HTS/BDPlayer:   F6500W

 

My firmware version:

 

Other TVs etc. the issue has been reproduced on:

 

My Emby server version:   3.0.5724.6

 

My current Emby Samsung client version: 0.593g

 

Other Emby Samsung versions the issue can be reproduced in: 

 

Developer comments: Thanks for the info. I'll close this.


Edited by cmcg, 05 October 2015 - 06:25 PM.


#17 FrostByte OFFLINE  

FrostByte

    Advanced Member

  • ForumMod
  • 4550 posts
  • Local time: 12:54 AM
  • LocationThe UP

Posted 05 October 2015 - 03:03 PM

@CBers

 

Issue description: Media Folders aren't in the same order as they appear on the web client.  Media Folders in app always display in alpha numeric order.  Attachment shows how they are displayed in the webclient.  This can be reproduced in .590, but was good in past releases.

 

Steps to reproduce: Change sort order of Media Folders on server.  Click Menu.  Click Media Folders

 

My TV/HTS/BDPlayer: UN55F8000

 

My firmware version: 1209.1

 

Other TVs etc. the issue has been reproduced on: HT-F6500W

 

My Emby server version:  3.0.5724.6

 

My current Emby Samsung client version: 0.593i

 

Other Emby Samsung versions the issue can be reproduced in: .590

 

Developer comments: cmcg: This is only a problem on the Media Folder view. It works fine for TV, Movies etc. The server team have said they will not fix as Media Folders is deprecated. Sorry.

 

http://​emby.media/community/index.php?/topic/23711-v0590/?p=231496

 

5612c4be4f62c_Sort.jpg


Edited by cmcg, 11 October 2015 - 01:14 PM.

  • CBers likes this

#18 DrWatson OFFLINE  

DrWatson

    Advanced Member

  • Alpha Testers
  • 125 posts
  • Local time: 03:54 PM

Posted 05 October 2015 - 04:50 PM

I saw some mention of this but i couldn't find it again.

 

Issue description: Now that missing ep are included in next up the Samsung app need to a ) put a missing icon on them b ) make them non playable (via play button).  Hitting play on a missing ep results in a loading screen hitting the back button shows loading icon in top right that cant be dismissed

 

Steps to reproduce: Press play button on an ep in next up that is a missing ep

 

My TV/HTS/BDPlayer: ua55h6400, ua75h6400

 

My firmware version: not relevant

 

Other TVs etc. the issue has been reproduced on:

 

My Emby server version: 3.0.5724.6

 

My current Emby Samsung client version: v0.592 and 0.590 

 

Other Emby Samsung versions the issue can be reproduced in: 

 

I am not sure if this has been fixed or not as i have been unable to find the original post about the loading screens.

 

Thanks for the updates on this app it is by far the best client that is available for Emby.

Cheers keep up the great work.


Edited by DrWatson, 05 October 2015 - 04:50 PM.

  • SamES, fluffykiwi and cmcg like this

#19 FrostByte OFFLINE  

FrostByte

    Advanced Member

  • ForumMod
  • 4550 posts
  • Local time: 12:54 AM
  • LocationThe UP

Posted 05 October 2015 - 04:59 PM

Issue description: Now Playing skip track mapped to wrong keys on remote still.  Recent change corrected the icon to |< >|, however you still need to press FF/RW << >>on the remote to skip track.  The skip function should be assigned to |< >| on remote also

 

Steps to reproduce: Navigate to music album, artist, etc.  Click Play All.  Now Playing shows up at the bottom.  Click |< or >| and nothing happens

 

My TV/HTS/BDPlayer: UN55F8000

 

My firmware version: 1209.1

 

Other TVs etc. the issue has been reproduced on: HT-F6500W

 

My Emby server version:  3.0.5724.6

 

My current Emby Samsung client version: 0.593i

 

Other Emby Samsung versions the issue can be reproduced in: 

 

Developer comments: No luck I'm afraid. There are no skip or previous key mappings available.

http://www.samsungdf...lue_object.html

 

Hmmm... crazy of them to have a key on the remote you can't program.  Well maybe the icons should be put back the way they originally were.  It functions like a skip but now the icons and the remote don't match and may confuse people @cmcg

 

56131b4b59b58_skip.jpg

 

@FrostByte your remote has more button than mine! I wonder if they added some APIs for it. Could try guessing a few.

 


Edited by cmcg, 06 October 2015 - 07:12 PM.

  • CBers likes this

#20 FrostByte OFFLINE  

FrostByte

    Advanced Member

  • ForumMod
  • 4550 posts
  • Local time: 12:54 AM
  • LocationThe UP

Posted 05 October 2015 - 09:06 PM

Issue description: The time shown in the app is incorrect in locations that do daylight savings time.  The TV itself has the correct time and auto adjusted to DST in the spring.  I'm guessing when we change our clocks here soon that it will be correct again for 6 months

 

Steps to reproduce: Start app.  Any screen with time in the bottom right will be off by 1 hour in locations that have DST.

 

My TV/HTS/BDPlayer: UN55F8000

 

My firmware version: 1209.1

 

Other TVs etc. the issue has been reproduced on: HT-F6500W

 

My Emby server version:  3.0.5724.6

 

My current Emby Samsung client version: 0.593j

 

Other Emby Samsung versions the issue can be reproduced in: .590

 

Developer comments: Not just me then. It's a firmware issue. Not sure if we can work around. http://stackoverflow...art-tv-firmware

 

Added a user clock offset option. Fixed in v0.593q


Edited by cmcg, 13 October 2015 - 04:01 PM.






Also tagged with one or more of these keywords: bugs

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users