Jump to content

Problem with CinemaVision Kodi addon, Music will not play


cirkator
 Share

Go to solution Solved by Cirkator01,

Recommended Posts

Hi, I am having a problem with the newly developed CinemaVison addon in Kodi.

It lets you play trailers, video bumpers such as ratings for movies and play trivia slides before the movie starts to give you a cinema feeling in the comfort of your home.

 

One feature are trivia slides, actor names scrambled, funny facts about movies or other quiz questions. You can have music playing while these slides show.

Thats where my problem is. When i enable the music option it should play music that is stored directly on the SSD in my HTPC. These music files are not connected with Emby.

Instead of the slides with the music i get a black screen and no music. When i disable the music option, the slides play fine.

 

I tried to add the music folder on my HTPC as a music source in Kodi and added the folder with the file manager in Kodi, but that didnt help my problem.

 

I am using Kodi 15.1, CV 0.39 and Emby for Kodi 1.1.39 from the stable repo. On Ubuntu 14.04.3.

 

I have posted about my problem in the CinemaVision Forum as well. I will link both threads, maybe we can find a solution.

 

A log with Kodi debug, Emby for Kodi debug and CinemaVision debug is attached.

 

http://pastebin.com/qsGW3J9k

 

Do you need any more info?

kodi_CV_v0.39.log

Edited by cirkator
Link to comment
Share on other sites

I'm not really sure why music would give you issues. We import them with direct paths - normal Kodi integration. You got one error, I don't know if it's related or what it would affect:

11:09:28 T:140367408113408   ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<--
                                             - NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS!
                                            Error Type: <type 'exceptions.TypeError'>
                                            Error Contents: unsupported operand type(s) for -: 'float' and 'str'
                                            Traceback (most recent call last):
                                              File "/home/kodi/.kodi/addons/script.cinemavision/lib/experience.py", line 485, in onPlayBackStopped
                                                self.next()
                                              File "/home/kodi/.kodi/addons/script.cinemavision/lib/experience.py", line 1040, in next
                                                if not self.showImageQueue(playable):
                                              File "/home/kodi/.kodi/addons/script.cinemavision/lib/experience.py", line 925, in showImageQueue
                                                musicEnd = end - image_queue.musicFadeOut
                                            TypeError: unsupported operand type(s) for -: 'float' and 'str'
                                            -->End of Python script error report<--
Link to comment
Share on other sites

I thought that it could be an Emby issue because i have read in some thread here, that you should avoid using the Emby for Kodi addon and manually create sources that get integrated in the Kodi database as well. That you should not mix Emby for Kodi content and manually added content.

So i was thinking that since the music files (.mp3) I want to have CinemaVision play are on the SSD of my HTPC and not on my Server that holds Emby and all the movie + tv files, that could be the problem.

 

 

Lets wait and see what the CV guys will say to the error message...

I saw that error as well but it didnt make sense to me.

Edited by cirkator
Link to comment
Share on other sites

Having sources for music should be fine if you don't also have it enabled with the add-on. It's really if you have video sources that it will affect things. Let's wait and see what they say. To be honest, cinema vision hasn't been tested much, or at least not much feedback about being used in junction with our add-on, so it's hard to say what could be the problem.

Link to comment
Share on other sites

I may have an idea, ill post in their forum and thanks for the explanation

I do not have music enabled in the addon. Besides the songs i want for CV I have no music whatsoever on my server or htpc.

Edited by cirkator
Link to comment
Share on other sites

  • Solution

I looks like my idea was right, they will fix it in their next release.

Sorry for creating turbulences here.

Emby is still working great and has nothing to do with my problem.

 

You can mark this question solved.

Thanks for your replies and for giving me the kickstart to solve this!

  • Like 1
Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...