Jump to content

Can't Play All Movies OS X emby for Kodi


Recommended Posts

Hey guys.  Hopefully someone can help me out.  I recently switched from mysql to emby for Kodi and for the most part.  It's been great.  But I seem to have hit a snag.  


Currently I run Emby Server in OS X with a Mac mini which also doubles as a HTPC.  My movies are connected via external HDD's to the Mac mini.  Now if I play the files directly from the web browser they work great.  But if I try viewing them using Kodi, I can only play a select few and the one's that don't work give me a playback error.  I've done a little bit of research to try and find the culprit with most people saying to use path substitution.  But many of the guides to set it up are for Windows and I am not entirely sure of how to set it up in OS X.  This is currently what my library looks like...



I am a total newb when it comes to setting up this path substitution.  If thats even what I need to do. If it makes it any easier.  The Mac's name is "David's Mac mini" and it has a local ip address of "" I just have no idea how to use this information for path substitution and what settings I might need to change in Kodi as well. Also attached is a copy of my log from Kodi.  Any help would be greatly appreciated!


Link to comment
Share on other sites

  • 2 months later...

I had a similar issue and I believed it was just me not understanding path substitution on osx.

I used the path substitution /Volumes/Movies 4tb/movies -> smb:// 4tb/movies

I can now play movies in kodi but it tells me direct play is not avaliable and turns on http automatically? If I check the emby server dashboard, under Active device, while Kodi is playing something, mouseover the Kodi device and it tells me that it is actually direct streaming.

So with yours try mapping...
/Volumes/Movie Collection/Movies -> smb:// Collection/Movies
/Volumes/Stuff 2/Movies -> smb:// 2/Movies


EDIT: realised I'd missed an option in the Emby setting within Kodi... Enabling "Use local paths instead of addon redirect for playback" under the "Sync Options" section means that my media is now direct playing :)

Edited by chriskeens
  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...